summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-09-09 12:45:41 -0700
committerTom Rini <tom_rini@mentor.com>2010-09-13 09:00:43 -0700
commit3f7a74fd62188bd06797a2397d51a69f67933549 (patch)
tree18bdf958fedd21911fef891273e7147dfbd0afa0
parentd0dece3a6356ee4687ee5b5670a2b8b10b84f564 (diff)
downloadopenembedded-3f7a74fd62188bd06797a2397d51a69f67933549.tar.gz
apmd: Switch to getting libtool from PATH
While doing this, also ensure CC/CFLAGS/LDFLAGS are also obeyed. Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/apmd/apmd_3.2.2.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes/apmd/apmd_3.2.2.bb b/recipes/apmd/apmd_3.2.2.bb
index 6b8313281d..ec85d882ab 100644
--- a/recipes/apmd/apmd_3.2.2.bb
+++ b/recipes/apmd/apmd_3.2.2.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "required"
DEPENDS = "libtool-cross"
LICENSE = "GPL"
-PR = "r12"
+PR = "r13"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz \
file://debian.patch \
@@ -23,8 +23,12 @@ inherit update-rc.d
INITSCRIPT_NAME = "apmd"
INITSCRIPT_PARAMS = "defaults"
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}' 'CC=${CC}' 'CFLAGS=${CFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}'"
+
do_compile() {
- oe_runmake "LIBTOOL=${STAGING_BINDIR_NATIVE}/${TARGET_PREFIX}libtool" apm apmd
+ oe_runmake apm apmd
}
do_install() {