summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2010-05-19 14:24:19 +0200
committerMichael Lippautz <michael.lippautz@gmail.com>2010-05-19 14:25:32 +0200
commit4f15295e5b226725e7844f0a3bb741e97846d65d (patch)
tree030d796a3637308fca54840e069b2187fedcb6de
parente92042a4e03b0d40dab3886867340059e6fafcb3 (diff)
downloadopenembedded-4f15295e5b226725e7844f0a3bb741e97846d65d.tar.gz
gpsd: Add version 2.94
* Makes python-pygps usable again (2.91 lacks bindings)
-rwxr-xr-xrecipes/gpsd/files/gpsd3
-rw-r--r--recipes/gpsd/gpsd.inc4
-rw-r--r--recipes/gpsd/gpsd_2.94.bb9
3 files changed, 13 insertions, 3 deletions
diff --git a/recipes/gpsd/files/gpsd b/recipes/gpsd/files/gpsd
index fde4285569..3687d24001 100755
--- a/recipes/gpsd/files/gpsd
+++ b/recipes/gpsd/files/gpsd
@@ -52,7 +52,8 @@ do_start()
# 0 if daemon has been started
# 1 if daemon was already running
# 2 if daemon could not be started
- start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test > /dev/null \
+ start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test \
+ -- $GPSD_OPTIONS -P $PIDFILE $GPS_DEVICES > /dev/null \
|| return 1
start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- \
$GPSD_OPTIONS -P $PIDFILE $GPS_DEVICES \
diff --git a/recipes/gpsd/gpsd.inc b/recipes/gpsd/gpsd.inc
index 5c55e3ff1f..f2fdb4c07e 100644
--- a/recipes/gpsd/gpsd.inc
+++ b/recipes/gpsd/gpsd.inc
@@ -4,7 +4,7 @@ PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "dbus-glib ncurses python"
PROVIDES = "virtual/gpsd"
-INC_PR = "r5"
+INC_PR = "r6"
EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
@@ -86,5 +86,5 @@ RDEPENDS_gps-utils = "python-pygps"
DESCRIPTION_python-pygps = "Python bindings to gpsd"
FILES_python-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
-RDEPENDS_python-pygps = "python-core python-curses gpsd"
+RDEPENDS_python-pygps = "python-core python-curses gpsd python-json"
diff --git a/recipes/gpsd/gpsd_2.94.bb b/recipes/gpsd/gpsd_2.94.bb
new file mode 100644
index 0000000000..23a8c4c6b1
--- /dev/null
+++ b/recipes/gpsd/gpsd_2.94.bb
@@ -0,0 +1,9 @@
+require gpsd.inc
+
+SRC_URI += "file://libtool.patch;patch=1"
+SRC_URI[gpsd.md5sum] = "ce70bcd707ac1df861d4c72f503c09d1"
+SRC_URI[gpsd.sha256sum] = "1520b87d106d198aa42137db4b230615dbd0d06b04e6fcc84e010172fba2da41"
+
+PR = "${INC_PR}.0"
+
+PARALLEL_MAKE = ""