summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-19 09:39:02 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-19 09:39:02 +0100
commit51b6d90f1d72ecf183ec0d78fcc103f2d8a7213e (patch)
tree5eb3b61a7c033f2d5bca689edcaa66e973b2dd64
parent49c1a7699ac24c580449c13bc3dba425f1d2bb48 (diff)
downloadopenembedded-51b6d90f1d72ecf183ec0d78fcc103f2d8a7213e.tar.gz
glib-2.0: add 2.20
-rw-r--r--conf/checksums.ini12
-rw-r--r--recipes/glib-2.0/glib-2.0-2.20.0/atomic-thumb.patch42
-rw-r--r--recipes/glib-2.0/glib-2.0-2.20.0/configure-libtool.patch34
-rw-r--r--recipes/glib-2.0/glib-2.0_2.20.0.bb10
4 files changed, 98 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 1358d11583..af7d67a058 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -1198,6 +1198,10 @@ sha256=e5ffecc423e2a9214cb4abd9dbd086552a0d45387b7bc2072738f5e2a8dd90ec
md5=16748b2d6e318e0e2a25581005e1943a
sha256=4d2d7a6b69b00ffe603a136a9df7ecda9f43448c7bc723503e76eaec9ab8e9fe
+[http://www.abiword.org/downloads/abiword/2.6.8/source/abiword-2.6.8.tar.gz]
+md5=fab04d8ef999c303f720197adf261310
+sha256=b6656a0da13d94b334f02637c89d8fe13aa54752040ad1b8f14f668d8cb96e93
+
[http://www.abiword.org/downloads/abiword/2.5.1/source/abiword-plugins-2.5.1.tar.gz]
md5=b1ce7ca49a0ee4e04f828e10eaebe6a9
sha256=37faf6ea346c9b6473c5b2dfd1bb599457faa06b6a7cdef58e3e9f3e2773976b
@@ -7406,6 +7410,10 @@ sha256=9f769e8449c8cc1d8789ba987e446bdac3ed22671d71f946c973c7aadccc0b36
md5=aa214a10d873b68ddd67cd9de2ccae55
sha256=af1456e075954c122bda008736437b048d5336d0b426847c627e607eb35e59e5
+[http://ftp.gnome.org/pub/GNOME/sources/glib/2.20/glib-2.20.0.tar.bz2]
+md5=05188e560dbd8bddd568e24ce10dd003
+sha256=6fb4269a187bee6f7825c358fd6f0e0e99e6ad71f7f995ddcbfe9466ec8f6631
+
[ftp://ftp.gtk.org/pub/gtk/v2.4/glib-2.4.6.tar.bz2]
md5=a45db7d82480da431f6cd00ea041a534
sha256=d2ca79bac06a625d9276b48492c2c1caccf7f8962f9b331b39796391013e72f2
@@ -9438,6 +9446,10 @@ sha256=516d981d1d696bb00a8c451fe928efd64ce0bd674ccc3024a0aefb292343231b
md5=b693a2c1c2dd95457b87d0d042aa5bba
sha256=efc277e87e3b7e0315eb3c2837fad6a06aab92b38e08fec6f30beb53e7e56e09
+[http://download.gnome.org/sources/gtk+/2.16/gtk+-2.16.0.tar.bz2]
+md5=139528802794287427fd4d18875b5cf5
+sha256=ff25cbf43dd5c5f8cddc1b2094505c1d079a576b873a6d3d6b62d95da1bdd1d7
+
[http://handhelds.org/packages/gtk-2.0/gtk+-2.2.4.diff.bz2]
md5=c6697665e06cad01e87c2cf8d0913725
sha256=2a768a45adea587c4a7d6e3c3567ad7961bf7509e118ae62ce32f5369b1aeeb0
diff --git a/recipes/glib-2.0/glib-2.0-2.20.0/atomic-thumb.patch b/recipes/glib-2.0/glib-2.0-2.20.0/atomic-thumb.patch
new file mode 100644
index 0000000000..d7aa08821f
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.20.0/atomic-thumb.patch
@@ -0,0 +1,42 @@
+# gatomic.c uses SWP, which doesn't work in Thumb mode.
+# Put that source file into a separate convenience library which is always built as ARM.
+
+Index: glib-2.18.1/glib/Makefile.am
+===================================================================
+--- glib-2.18.1/glib/Makefile.am 2008-09-18 00:33:57.000000000 +0200
++++ glib-2.18.1/glib/Makefile.am 2008-11-08 10:13:27.000000000 +0100
+@@ -80,6 +80,7 @@
+ galiasdef.c
+
+ lib_LTLIBRARIES = libglib-2.0.la
++noinst_LTLIBRARIES = libgatomic.la
+
+ if OS_WIN32_AND_DLL_COMPILATION
+ if MS_LIB_AVAILABLE
+@@ -96,10 +97,14 @@
+ uninstall-ms-lib:
+ $(uninstall_ms_lib_cmd)
+
++libgatomic_la_CFLAGS = $(CFLAGS) -mno-thumb
++
++libgatomic_la_SOURCES = \
++ gatomic.c
++
+ libglib_2_0_la_SOURCES = \
+ garray.c \
+ gasyncqueue.c \
+- gatomic.c \
+ gbacktrace.c \
+ gbase64.c \
+ gbookmarkfile.c \
+@@ -286,8 +291,8 @@
+ pcre_inc =
+ endif
+
+-libglib_2_0_la_LIBADD = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ @ICONV_LIBS@ @G_LIBS_EXTRA@ $(pcre_lib)
+-libglib_2_0_la_DEPENDENCIES = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ $(glib_win32_res) $(glib_def)
++libglib_2_0_la_LIBADD = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ @ICONV_LIBS@ @G_LIBS_EXTRA@ $(pcre_lib) libgatomic.la
++libglib_2_0_la_DEPENDENCIES = libcharset/libcharset.la $(printf_la) @GIO@ @GSPAWN@ @PLATFORMDEP@ $(glib_win32_res) $(glib_def) libgatomic.la
+
+ libglib_2_0_la_LDFLAGS = \
+ $(glib_win32_res_ldflag) \
diff --git a/recipes/glib-2.0/glib-2.0-2.20.0/configure-libtool.patch b/recipes/glib-2.0/glib-2.0-2.20.0/configure-libtool.patch
new file mode 100644
index 0000000000..3ba79b8986
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0-2.20.0/configure-libtool.patch
@@ -0,0 +1,34 @@
+# Poky renames libtool to $host_alias-libtool.
+# ./$host_alias-libtool isn't created until after configure runs with libtool >= 2.2.2
+# so we can't call # it at this point. We can safely assume a version is available
+# from PATH though
+
+--- glib-2.12.10/configure.in.orig 2006-06-05 13:34:08.000000000 +0100
++++ glib-2.12.10/configure.in 2006-06-05 13:34:36.000000000 +0100
+@@ -1174,7 +1174,7 @@
+ G_MODULE_LDFLAGS=
+ else
+ export SED
+- G_MODULE_LDFLAGS=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
++ G_MODULE_LDFLAGS=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
+ fi
+ dnl G_MODULE_IMPL= don't reset, so cmd-line can override
+ G_MODULE_NEED_USCORE=0
+@@ -1265,7 +1265,7 @@
+ LDFLAGS="$LDFLAGS $G_MODULE_LDFLAGS"
+ dnl *** check for OSF1/5.0 RTLD_GLOBAL brokenness
+ echo "void glib_plugin_test(void) { }" > plugin.c
+- ${SHELL} ./libtool --mode=compile ${CC} -shared \
++ ${SHELL} $host_alias-libtool --mode=compile ${CC} -shared \
+ -export-dynamic -o plugin.o plugin.c 2>&1 >/dev/null
+ AC_CACHE_CHECK([for RTLD_GLOBAL brokenness],
+ glib_cv_rtldglobal_broken,[
+@@ -1339,7 +1339,7 @@
+
+ AC_MSG_CHECKING(for the suffix of shared libraries)
+ export SED
+-shrext_cmds=`./libtool --config | grep '^shrext_cmds='`
++shrext_cmds=`$host_alias-libtool --config | grep '^shrext_cmds='`
+ eval $shrext_cmds
+ module=yes eval std_shrext=$shrext_cmds
+ # chop the initial dot
diff --git a/recipes/glib-2.0/glib-2.0_2.20.0.bb b/recipes/glib-2.0/glib-2.0_2.20.0.bb
new file mode 100644
index 0000000000..e0afd218f7
--- /dev/null
+++ b/recipes/glib-2.0/glib-2.0_2.20.0.bb
@@ -0,0 +1,10 @@
+require glib.inc
+
+PR = "r0"
+
+SRC_URI = "\
+ http://ftp.gnome.org/pub/GNOME/sources/glib/2.20/glib-${PV}.tar.bz2 \
+ file://glibconfig-sysdefs.h \
+ file://configure-libtool.patch;patch=1 \
+"
+SRC_URI_append_arm = " file://atomic-thumb.patch;patch=1"