summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-07-22 22:42:45 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-07-22 22:44:24 +0200
commit839088da9bb5ece957ca5496aec43153937768d5 (patch)
tree2dff6f060307fd44d95589805f7228429e7eef22
parent9718ee0eea45a5986eb185e09fc0c4cc53f9dd7e (diff)
downloadopenembedded-839088da9bb5ece957ca5496aec43153937768d5.tar.gz
gcc: added COMPATIBLE_TARGET_SYS
added COMPATIBLE_TARGET_SYS ?= "(?!nios2)" to the gcc-common.inc file and COMPATIBLE_TARGET_SYS = "." to the only recipe that does support nios2 (gcc-4.2.1.bb) Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/gcc/gcc-4.1.2.inc2
-rw-r--r--recipes/gcc/gcc-common.inc2
2 files changed, 4 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.1.2.inc b/recipes/gcc/gcc-4.1.2.inc
index 2505b09448..000767a417 100644
--- a/recipes/gcc/gcc-4.1.2.inc
+++ b/recipes/gcc/gcc-4.1.2.inc
@@ -3,6 +3,8 @@ require gcc-common.inc
DEPENDS = "mpfr gmp"
NATIVEDEPS = "mpfr-native gmp-native"
+COMPATIBLE_TARGET_SYS = "."
+
INC_PR = "r23"
SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2;name=archive \
diff --git a/recipes/gcc/gcc-common.inc b/recipes/gcc/gcc-common.inc
index 7aee542461..ffd4dd3146 100644
--- a/recipes/gcc/gcc-common.inc
+++ b/recipes/gcc/gcc-common.inc
@@ -9,6 +9,8 @@ inherit autotools gettext
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+COMPATIBLE_TARGET_SYS ?= "(?!nios2)"
+
# When making a Canadian SDK, we use these files too to make the compiler
# for building for the new host part. So only obey TARGET_FPU for the
# real target.