summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-02-10 00:17:46 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-02-10 00:17:46 +0000
commit97ed01f3e5d63d088dd1ca10ae009a93fa63739e (patch)
treed20c8eeaed6ada3568248e52d0502736a23afc00
parent5114b62e16ee52ec3ede08d40accc22913ffa099 (diff)
downloadopenembedded-97ed01f3e5d63d088dd1ca10ae009a93fa63739e.tar.gz
kobodeluxe: New recipe.
-rw-r--r--packages/kobodeluxe/.mtn2git_empty0
-rw-r--r--packages/kobodeluxe/files/.mtn2git_empty0
-rw-r--r--packages/kobodeluxe/files/debian-kobo.patch72
-rw-r--r--packages/kobodeluxe/kobodeluxe_0.5.1.bb26
4 files changed, 98 insertions, 0 deletions
diff --git a/packages/kobodeluxe/.mtn2git_empty b/packages/kobodeluxe/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kobodeluxe/.mtn2git_empty
diff --git a/packages/kobodeluxe/files/.mtn2git_empty b/packages/kobodeluxe/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kobodeluxe/files/.mtn2git_empty
diff --git a/packages/kobodeluxe/files/debian-kobo.patch b/packages/kobodeluxe/files/debian-kobo.patch
new file mode 100644
index 0000000000..90b1d84080
--- /dev/null
+++ b/packages/kobodeluxe/files/debian-kobo.patch
@@ -0,0 +1,72 @@
+--- kobodeluxe-0.5.1.orig/kobo.cpp
++++ kobodeluxe-0.5.1/kobo.cpp
+@@ -141,21 +141,21 @@
+ * Graphics data
+ */
+ /* Current dir; from within the build tree */
+- fmap->addpath("GFX", "./data/gfx");
++ //fmap->addpath("GFX", "./data/gfx");
+ /* Real data dir */
+ fmap->addpath("GFX", "DATA>>gfx");
+ /* Current dir */
+- fmap->addpath("GFX", "./gfx");
++ //fmap->addpath("GFX", "./gfx");
+
+ /*
+ * Sound data
+ */
+ /* Current dir; from within the build tree */
+- fmap->addpath("SFX", "./data/sfx");
++ //fmap->addpath("SFX", "./data/sfx");
+ /* Real data dir */
+ fmap->addpath("SFX", "DATA>>sfx");
+ /* Current dir */
+- fmap->addpath("SFX", "./sfx");
++ //fmap->addpath("SFX", "./sfx");
+
+ /*
+ * Score files (user and global)
+@@ -173,7 +173,7 @@
+ /* System local */
+ fmap->addpath("CONFIG", SYSCONF_DIR);
+ /* In current dir (last resort) */
+- fmap->addpath("CONFIG", "./");
++ //fmap->addpath("CONFIG", "./");
+ }
+
+
+--- kobodeluxe-0.5.1.orig/graphics/window.cpp
++++ kobodeluxe-0.5.1/graphics/window.cpp
+@@ -331,7 +331,7 @@
+ }
+
+
+-void window_t::center_token(int _x, int _y, const char *txt, char token)
++void window_t::center_token(int _x, int _y, const char *txt, signed char token)
+ {
+ center_token_fxp(PIXEL2CS(_x), PIXEL2CS(_y), txt, token);
+ }
+@@ -374,7 +374,7 @@
+ }
+
+
+-void window_t::center_token_fxp(int _x, int _y, const char *txt, char token)
++void window_t::center_token_fxp(int _x, int _y, const char *txt, signed char token)
+ {
+ _x = CS2PIXEL((_x * xs + 128) >> 8);
+ _y = CS2PIXEL((_y * ys + 128) >> 8);
+--- kobodeluxe-0.5.1.orig/graphics/window.h
++++ kobodeluxe-0.5.1/graphics/window.h
+@@ -265,10 +265,10 @@
+ void font(int fnt);
+ void string(int _x, int _y, const char *txt);
+ void center(int _y, const char *txt);
+- void center_token(int _x, int _y, const char *txt, char token = 0);
++ void center_token(int _x, int _y, const char *txt, signed char token = 0);
+ void string_fxp(int _x, int _y, const char *txt);
+ void center_fxp(int _y, const char *txt);
+- void center_token_fxp(int _x, int _y, const char *txt, char token = 0);
++ void center_token_fxp(int _x, int _y, const char *txt, signed char token = 0);
+ int textwidth(const char *txt, int min = 0, int max = 255);
+ int textwidth_fxp(const char *txt, int min = 0, int max = 255);
+ int fontheight();
diff --git a/packages/kobodeluxe/kobodeluxe_0.5.1.bb b/packages/kobodeluxe/kobodeluxe_0.5.1.bb
new file mode 100644
index 0000000000..0c9ae458f8
--- /dev/null
+++ b/packages/kobodeluxe/kobodeluxe_0.5.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Fast-paced 2D top-down shooter where you have to destroy space station"
+SECTION = "games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "David Olofson <david@olofson.net>"
+HOMEPAGE = "http://olofson.net/kobodl"
+
+DEPENDS = "libsdl-image virtual/libsdl"
+
+RDEPENDS_${PN} = "${PN}-data"
+
+SRC_URI = "http://olofson.net/kobodl/download/KoboDeluxe-${PV}.tar.bz2 \
+ file://debian-kobo.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/KoboDeluxe-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-sdltest"
+
+PACKAGES += "${PN}-data"
+
+FILES_${PN}-data = "${datadir}"
+
+PACKAGE_ARCH_${PN}-data = "all"