summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-05-19 00:19:17 +0200
committerEric Bénard <eric@eukrea.com>2010-05-19 14:04:43 +0200
commitdb531256a7b9500bbff7c3864eb0f643ee0385ee (patch)
tree8fdde0bd92ec325c343b3c2b49a2823b9bf3d05a
parente79eb808d574d4f9f022a7483eb5f2936f303635 (diff)
downloadopenembedded-db531256a7b9500bbff7c3864eb0f643ee0385ee.tar.gz
prelink_20090925: allow dynamic linking of prelink
Signed-off-by: Eric Bénard <eric@eukrea.com>
-rw-r--r--recipes/prelink/prelink_20090925.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes/prelink/prelink_20090925.bb b/recipes/prelink/prelink_20090925.bb
index 0f0d670d1f..021b74bb6c 100644
--- a/recipes/prelink/prelink_20090925.bb
+++ b/recipes/prelink/prelink_20090925.bb
@@ -4,6 +4,7 @@ DESCRIPTION = " The prelink package contains a utility which modifies ELF shared
and executables, so that far fewer relocations need to be resolved at \
runtime and thus programs come up faster."
LICENSE = "GPL"
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/p/prelink/prelink_0.0.${PV}.orig.tar.gz \
file://prelink.conf \
@@ -20,6 +21,10 @@ EXTRA_OECONF = "--disable-64bit"
inherit autotools
+do_compile_prepend () {
+ sed -i -e 's:prelink_LDFLAGS = -all-static:#prelink_LDFLAGS = -all-static:g' src/Makefile
+}
+
do_install_append () {
install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf