summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-06-10 22:36:22 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-06-10 23:33:17 +0200
commitf0c0823e891c517562cb542ef6e64bb0ec9f7faf (patch)
tree18f72b16781e088b105faf13b69153f8c5a5caae
parenteb094140e84ef2fb75bc43e84d413ec1ed85f1a4 (diff)
downloadopenembedded-f0c0823e891c517562cb542ef6e64bb0ec9f7faf.tar.gz
scummvm: add version 1.1.1
*removed the useless CCACHE="" *do_configure_append is still necessary,else you still have issues like that: | sound/rate_arm_asm.s:713: Error: no such instruction: `ldr PC,[r13,' *I took the following from DJWillis(John Willis)'s recipe(he sent it to me via mail) # Make this a plugin enabled build. Bigger binary, less memory usage. Makes more games run on lower end platforms. # These plugins are not normal Linux shared libs so will fall foul of the sanity checker. INSANE_SKIP_${PN} = True EXTRA_OECONF += " --enable-plugins --default-dynamic " The comment are self explanatory Thanks a lot John Willis(who is a scummvm developer)
-rw-r--r--recipes/scummvm/scummvm-1.1.1/no-strip.patch22
-rw-r--r--recipes/scummvm/scummvm_1.1.1.bb41
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes/scummvm/scummvm-1.1.1/no-strip.patch b/recipes/scummvm/scummvm-1.1.1/no-strip.patch
new file mode 100644
index 0000000000..02bc71ec51
--- /dev/null
+++ b/recipes/scummvm/scummvm-1.1.1/no-strip.patch
@@ -0,0 +1,22 @@
+Index: scummvm-1.1.1/ports.mk
+===================================================================
+--- scummvm-1.1.1.orig/ports.mk
++++ scummvm-1.1.1/ports.mk
+@@ -10,7 +10,7 @@
+ #
+ install: all
+ $(INSTALL) -d "$(DESTDIR)$(BINDIR)"
+- $(INSTALL) -c -s -m 755 "./$(EXECUTABLE)" "$(DESTDIR)$(BINDIR)/$(EXECUTABLE)"
++ $(INSTALL) -c -m 755 "./$(EXECUTABLE)" "$(DESTDIR)$(BINDIR)/$(EXECUTABLE)"
+ $(INSTALL) -d "$(DESTDIR)$(MANDIR)/man6/"
+ $(INSTALL) -c -m 644 "$(srcdir)/dists/scummvm.6" "$(DESTDIR)$(MANDIR)/man6/scummvm.6"
+ $(INSTALL) -d "$(DESTDIR)$(PREFIX)/share/pixmaps/"
+@@ -21,7 +21,7 @@ install: all
+ $(INSTALL) -c -m 644 $(DIST_FILES_THEMES) $(DIST_FILES_ENGINEDATA) "$(DESTDIR)$(DATADIR)/scummvm/"
+ ifdef DYNAMIC_MODULES
+ $(INSTALL) -d "$(DESTDIR)$(LIBDIR)/scummvm/"
+- $(INSTALL) -c -s -m 644 $(PLUGINS) "$(DESTDIR)$(LIBDIR)/scummvm/"
++ $(INSTALL) -c -m 644 $(PLUGINS) "$(DESTDIR)$(LIBDIR)/scummvm/"
+ endif
+
+ uninstall:
diff --git a/recipes/scummvm/scummvm_1.1.1.bb b/recipes/scummvm/scummvm_1.1.1.bb
new file mode 100644
index 0000000000..4ee3031e68
--- /dev/null
+++ b/recipes/scummvm/scummvm_1.1.1.bb
@@ -0,0 +1,41 @@
+require scummvm.inc
+
+DEPENDS = "virtual/libsdl libvorbis libogg zlib \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad mpeg2dec', d)}"
+
+SRC_URI += " file://scummvm.desktop \
+ file://no-strip.patch;patch=1 \
+ "
+PR = "${INC_PR}.0"
+
+SRC_URI_append_openmoko = " file://openmoko-scummvm "
+SRC_URI_append_shr = " file://openmoko-scummvm "
+
+SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
+
+# Make this a plugin enabled build. Bigger binary, less memory usage. Makes more games run on lower end platforms.
+# These plugins are not normal Linux shared libs so will fall foul of the sanity checker.
+INSANE_SKIP_${PN} = True
+EXTRA_OECONF += " --enable-plugins --default-dynamic "
+
+# Workaround, because some env variables aren't recognised correctly
+do_configure_append() {
+ sed -i "s/AS := as/AS := ${AS}/" ${S}/config.mk
+ sed -i "s/AR := ar cru/AR := ${AR} cru/" ${S}/config.mk
+ sed -i "s/STRIP := strip/STRIP := ${STRIP}/" ${S}/config.mk
+ sed -i "s/RANLIB := ranlib/RANLIB := ${RANLIB}/" ${S}/config.mk
+}
+
+do_install_append() {
+ if [ -f ${WORKDIR}/openmoko-scummvm ]; then
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/openmoko-scummvm ${D}${bindir}/openmoko-scummvm
+ fi
+ if [ -f ${WORKDIR}/scummvm.desktop ]; then
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/scummvm.desktop ${D}${datadir}/applications
+ fi
+}
+
+SRC_URI[md5sum] = "ed9098a78022d07fa1482f14325e3ab8"
+SRC_URI[sha256sum] = "9cc865c5690bfc1df4970d35984455031467381180a71d84b08dcc9f51e39d4a"