summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-31 15:16:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-31 16:51:05 +0200
commitf2949c20d2f4b6f02842a09650a93151c81f2ad3 (patch)
tree8fa3e21a3bb061677fa980f9abff5f9081dedf8f
parent05c796f95b5399548ad77a0f20aa851594539716 (diff)
downloadopenembedded-f2949c20d2f4b6f02842a09650a93151c81f2ad3.tar.gz
fso-specs: don't break QA while staging pkgconfig file
* move STAGING_DIR_HOST prefix to recipes using it Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/freesmartphone/fso-specs_git.bb5
-rw-r--r--recipes/freesmartphone/libfso-glib_git.bb6
2 files changed, 7 insertions, 4 deletions
diff --git a/recipes/freesmartphone/fso-specs_git.bb b/recipes/freesmartphone/fso-specs_git.bb
index a003637fa9..345422a3e0 100644
--- a/recipes/freesmartphone/fso-specs_git.bb
+++ b/recipes/freesmartphone/fso-specs_git.bb
@@ -7,6 +7,7 @@ SECTION = "devel/specifications"
SRCREV = "5e5c9b52e7525085f0d8601861d712f05523ad0a"
PV = "2010.05.11.2+gitr${SRCPV}"
PE = "1"
+PR = "r1"
SRC_URI = "${FREESMARTPHONE_GIT}/specs.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
@@ -14,7 +15,3 @@ S = "${WORKDIR}/git"
inherit autotools pkgconfig
FILES_${PN}-dev += "${datadir}/freesmartphone/xml"
-
-do_compile_append() {
- sed -i -e s,\$\{datarootdir\},${STAGING_DATADIR},g *.pc
-}
diff --git a/recipes/freesmartphone/libfso-glib_git.bb b/recipes/freesmartphone/libfso-glib_git.bb
index dad6c002dd..ecfc9dcd34 100644
--- a/recipes/freesmartphone/libfso-glib_git.bb
+++ b/recipes/freesmartphone/libfso-glib_git.bb
@@ -6,8 +6,14 @@ DEPENDS = "vala-dbus-binding-tool-native dbus-glib glib-2.0 fso-specs"
SRCREV = "5cda3952855d6c4273929449339b04509387bdd2"
PV = "2010.05.11.2+gitr${SRCPV}"
PE = "1"
+PR = "r1"
inherit autotools vala
SRC_URI = "${FREESMARTPHONE_GIT}/libfso-glib.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ sed -i -e s#FSO_SPECS_DIR="#FSO_SPECS_DIR="${STAGING_DIR_HOST}/#g ${S}/configure.ac
+}
+