summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-15 19:09:07 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-15 19:16:49 -0700
commit4afbc9ed25e434dd34ec6e9864feaf1d96c017c7 (patch)
tree025da5f877fd6574767e1e7cd91284b839436080
parentb0e141cadc987fa8003969e5b6173b75a7c882d3 (diff)
downloadopenembedded-4afbc9ed25e434dd34ec6e9864feaf1d96c017c7.tar.gz
gtkhtml2, libxosd_svn.bb: Move the recipe to fetch from git instead of obsolete svn
libxosd_svn.bb fix compilation issue. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/gtkhtml2/gtkhtml2_git.bb (renamed from recipes/gtkhtml2/gtkhtml2_svn.bb)15
-rw-r--r--recipes/libxosd/files/fix_duplicate_xosd_is_onscreen.patch13
-rw-r--r--recipes/libxosd/libxosd_svn.bb6
3 files changed, 21 insertions, 13 deletions
diff --git a/recipes/gtkhtml2/gtkhtml2_svn.bb b/recipes/gtkhtml2/gtkhtml2_git.bb
index d2b1760dea..94e7d43371 100644
--- a/recipes/gtkhtml2/gtkhtml2_svn.bb
+++ b/recipes/gtkhtml2/gtkhtml2_git.bb
@@ -2,10 +2,10 @@ SECTION = "libs"
DEPENDS = "gtk+ glib-2.0 libxml2"
DESCRIPTION = "A GTK+ HTML rendering library."
LICENSE = "GPL"
-SRCREV = "1158"
-PV = "2.11.0+svnr${SRCPV}"
+SRCREV = "f4a698dbbedbdb2614ca2bfb585095049b57748e"
+PV = "2.11.1+gitr${SRCPV}"
-SRC_URI = "svn://anonymous@svn.gnome.org/svn/gtkhtml2/;module=trunk \
+SRC_URI = "git://git.gnome.org/gtkhtml2;protocol=git;branch=master \
http://svn.o-hand.com/repos/web/trunk/patches/at-import_box-pos.patch;striplevel=0;maxrev=1157;name=patch1 \
http://svn.o-hand.com/repos/web/trunk/patches/css-stylesheet-user.patch;striplevel=0;maxrev=1157;name=patch2 \
http://svn.o-hand.com/repos/web/trunk/patches/css-media.patch;striplevel=0;maxrev=1157;name=patch3 \
@@ -13,19 +13,12 @@ SRC_URI = "svn://anonymous@svn.gnome.org/svn/gtkhtml2/;module=trunk \
http://svn.o-hand.com/repos/web/trunk/patches/add-dom-functions.patch;striplevel=0;maxrev=1157;name=patch5 \
http://svn.o-hand.com/repos/web/trunk/patches/iain-mem-leak.patch;striplevel=0;maxrev=1157;name=patch6"
-S = "${WORKDIR}/trunk"
+S = "${WORKDIR}/git"
inherit pkgconfig autotools
EXTRA_OECONF = " --disable-accessibility"
-do_stage() {
- oe_libinstall -so -C libgtkhtml libgtkhtml-2 ${STAGING_LIBDIR}
- install -d ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml
- ( for i in css document dom dom/core dom/events dom/html dom/traversal dom/views graphics layout layout/html util view; do install -d ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml/$i; install -m 0644 ${S}/libgtkhtml/$i/*.h ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml/$i; done )
- install -m 0644 ${S}/libgtkhtml/*.h ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml
-}
-
SRC_URI[patch1.md5sum] = "160c648e29637f2ed6301f4dfdecce21"
SRC_URI[patch1.sha256sum] = "3ec786e6df9e1a935aff4848b6989cad8f87c1fa8813dc033b338e18b17138d8"
SRC_URI[patch2.md5sum] = "05fc3627ca364095702dc804f41c8391"
diff --git a/recipes/libxosd/files/fix_duplicate_xosd_is_onscreen.patch b/recipes/libxosd/files/fix_duplicate_xosd_is_onscreen.patch
new file mode 100644
index 0000000000..8e819ff947
--- /dev/null
+++ b/recipes/libxosd/files/fix_duplicate_xosd_is_onscreen.patch
@@ -0,0 +1,13 @@
+Index: current/man/Makefile.am
+===================================================================
+--- current.orig/man/Makefile.am 2007-07-27 06:33:14.000000000 -0700
++++ current/man/Makefile.am 2010-09-15 18:05:21.895210000 -0700
+@@ -3,7 +3,7 @@ man_MANS = osd_cat.1 xosd-config.1 \
+ xosd_display.3 xosd_hide.3 xosd_is_onscreen.3 xosd_set_vertical_offset.3 \
+ xosd_set_pos.3 xosd_set_shadow_offset.3 xosd_show.3 xosd_uninit.3 xosd.3 \
+ xosd_get_number_lines.3 xosd_set_align.3 xosd_create.3 \
+- xosd_set_horizontal_offset.3 xosd_destroy.3 xosd_create.3 xosd_is_onscreen.3 \
++ xosd_set_horizontal_offset.3 xosd_destroy.3 \
+ xosd_set_bar_length.3
+
+ EXTRA_DIST = ${man_MANS}
diff --git a/recipes/libxosd/libxosd_svn.bb b/recipes/libxosd/libxosd_svn.bb
index 7a0ecd4fba..86de1d9558 100644
--- a/recipes/libxosd/libxosd_svn.bb
+++ b/recipes/libxosd/libxosd_svn.bb
@@ -4,11 +4,13 @@ DEPENDS = "virtual/libx11 libxext"
LICENSE = "LGPL"
SRCREV = "627"
PV = "2.2.15+svnr${SRCPV}"
-PR = "r5"
+PR = "r6"
SRC_URI = "svn://libxosd.svn.sourceforge.net/svnroot/libxosd/source;module=current;proto=https \
file://autofoo.patch \
- file://use-sane-default-font.patch"
+ file://use-sane-default-font.patch \
+ file://fix_duplicate_xosd_is_onscreen.patch \
+ "
S = "${WORKDIR}/current"