summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-15 13:41:29 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-15 13:42:08 -0700
commitc3b08fdce0a91bc467228fc01ef1024f6255f0d8 (patch)
treeee7152ea1d383a0e6fdf3f756fd7ca03fd822b73
parenta5418685b3a9b5cf935c5ada4b507142d2e5f4e5 (diff)
downloadopenembedded-c3b08fdce0a91bc467228fc01ef1024f6255f0d8.tar.gz
libjingle-tapioca_0.3.10.bb: Fix compilation and install issues.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/tapioca/libjingle-tapioca-0.3.10/fix-host-h-double-install.patch12
-rw-r--r--recipes/tapioca/libjingle-tapioca-0.3.10/gcc-4.5-compilation-fixes.patch202
-rw-r--r--recipes/tapioca/libjingle-tapioca_0.3.10.bb7
3 files changed, 219 insertions, 2 deletions
diff --git a/recipes/tapioca/libjingle-tapioca-0.3.10/fix-host-h-double-install.patch b/recipes/tapioca/libjingle-tapioca-0.3.10/fix-host-h-double-install.patch
new file mode 100644
index 0000000000..b99115522c
--- /dev/null
+++ b/recipes/tapioca/libjingle-tapioca-0.3.10/fix-host-h-double-install.patch
@@ -0,0 +1,12 @@
+Index: libjingle-0.3.10/talk/base/Makefile.am
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/Makefile.am 2006-09-01 04:31:53.000000000 -0700
++++ libjingle-0.3.10/talk/base/Makefile.am 2010-09-15 13:33:14.465210001 -0700
+@@ -62,7 +62,6 @@ libjinglebase_@LIBJINGLE_MAJORMINOR@incl
+ winping.h \
+ socketadapters.h \
+ socketaddress.h \
+- host.h \
+ socketaddresspair.h \
+ Equifax_Secure_Global_eBusiness_CA-1.h \
+ stream.h \
diff --git a/recipes/tapioca/libjingle-tapioca-0.3.10/gcc-4.5-compilation-fixes.patch b/recipes/tapioca/libjingle-tapioca-0.3.10/gcc-4.5-compilation-fixes.patch
new file mode 100644
index 0000000000..57db0934db
--- /dev/null
+++ b/recipes/tapioca/libjingle-tapioca-0.3.10/gcc-4.5-compilation-fixes.patch
@@ -0,0 +1,202 @@
+Index: libjingle-0.3.10/talk/base/asynctcpsocket.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/asynctcpsocket.cc 2006-09-01 04:31:52.000000000 -0700
++++ libjingle-0.3.10/talk/base/asynctcpsocket.cc 2010-09-15 12:57:34.485210001 -0700
+@@ -45,6 +45,7 @@ extern "C" {
+ }
+ #endif // POSIX
+
++#include <cstring>
+ namespace cricket {
+
+ const size_t MAX_PACKET_SIZE = 64 * 1024;
+Index: libjingle-0.3.10/talk/base/bytebuffer.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/bytebuffer.cc 2006-09-01 04:31:53.000000000 -0700
++++ libjingle-0.3.10/talk/base/bytebuffer.cc 2010-09-15 12:52:40.005210002 -0700
+@@ -30,6 +30,7 @@
+ #include "talk/base/byteorder.h"
+ #include <algorithm>
+ #include <cassert>
++#include <cstring>
+
+ #if defined(_MSC_VER) && _MSC_VER < 1300
+ namespace std {
+Index: libjingle-0.3.10/talk/base/host.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/host.cc 2006-09-01 04:31:53.000000000 -0700
++++ libjingle-0.3.10/talk/base/host.cc 2010-09-15 13:08:51.945210000 -0700
+@@ -33,6 +33,7 @@
+ #include <iostream>
+ #include <cassert>
+ #include <errno.h>
++#include <cstdlib>
+
+ #if defined(_MSC_VER) && _MSC_VER < 1300
+ namespace std {
+Index: libjingle-0.3.10/talk/base/logging.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/logging.cc 2006-09-01 04:31:52.000000000 -0700
++++ libjingle-0.3.10/talk/base/logging.cc 2010-09-15 13:14:46.475210002 -0700
+@@ -33,6 +33,8 @@
+
+ #include <iostream>
+ #include <iomanip>
++#include <cstring>
++#include <cstdio>
+
+ #include "talk/base/logging.h"
+ #include "talk/base/stream.h"
+Index: libjingle-0.3.10/talk/base/messagequeue.h
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/messagequeue.h 2010-09-15 12:48:43.000000000 -0700
++++ libjingle-0.3.10/talk/base/messagequeue.h 2010-09-15 12:50:06.225210002 -0700
+@@ -35,6 +35,7 @@
+ #include <vector>
+ #include <queue>
+ #include <algorithm>
++#include <cstring>
+
+ namespace cricket {
+
+Index: libjingle-0.3.10/talk/base/physicalsocketserver.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/physicalsocketserver.cc 2006-09-01 04:31:52.000000000 -0700
++++ libjingle-0.3.10/talk/base/physicalsocketserver.cc 2010-09-15 13:05:45.445210001 -0700
+@@ -37,6 +37,7 @@ extern "C" {
+ #include <fcntl.h>
+ #include <sys/time.h>
+ #include <unistd.h>
++#include <string.h>
+ }
+ #endif
+
+@@ -50,6 +51,8 @@ extern "C" {
+
+ #ifdef __linux
+ #define IP_MTU 14 // Until this is integrated from linux/in.h to netinet/in.h
++#include <cstdio>
++#include <algorithm>
+ #endif // __linux
+
+ #ifdef WIN32
+@@ -61,7 +64,6 @@ extern "C" {
+
+ #include <algorithm>
+ #include <iostream>
+-
+ class WinsockInitializer {
+ public:
+ WinsockInitializer() {
+Index: libjingle-0.3.10/talk/base/protocolinfo.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/protocolinfo.cc 2006-09-01 04:31:53.000000000 -0700
++++ libjingle-0.3.10/talk/base/protocolinfo.cc 2010-09-15 13:11:47.815210002 -0700
+@@ -28,7 +28,7 @@
+ */
+
+ #include "talk/base/protocolinfo.h"
+-
++#include <cstring>
+ namespace cricket {
+
+ static const char * const PROTO_NAMES[PROTO_LAST+1] = { "udp", "tcp", "ssltcp" };
+Index: libjingle-0.3.10/talk/base/socketadapters.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/socketadapters.cc 2006-09-01 04:31:53.000000000 -0700
++++ libjingle-0.3.10/talk/base/socketadapters.cc 2010-09-15 13:02:10.245210000 -0700
+@@ -42,6 +42,7 @@
+ #endif
+
+ #include <cassert>
++#include <cstring>
+
+ #include "talk/base/base64.h"
+ #include "talk/base/basicdefs.h"
+Index: libjingle-0.3.10/talk/base/stream.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/stream.cc 2006-09-01 04:31:53.000000000 -0700
++++ libjingle-0.3.10/talk/base/stream.cc 2010-09-15 13:13:51.255210002 -0700
+@@ -29,6 +29,8 @@
+ #include <sys/stat.h>
+ #include <errno.h>
+ #include <string>
++#include <cstdio>
++#include <cstring>
+ #include "talk/base/basictypes.h"
+ #include "talk/base/common.h"
+ #include "talk/base/stream.h"
+Index: libjingle-0.3.10/talk/base/stringutils.h
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/stringutils.h 2006-09-01 04:31:52.000000000 -0700
++++ libjingle-0.3.10/talk/base/stringutils.h 2010-09-15 13:09:40.695210000 -0700
+@@ -36,6 +36,7 @@
+ #endif // WIN32
+
+ #include <string>
++#include <cstring>
+
+ ///////////////////////////////////////////////////////////////////////////////
+ // Rename a bunch of common string functions so they are consistent across
+Index: libjingle-0.3.10/talk/base/xmpppassword.h
+===================================================================
+--- libjingle-0.3.10.orig/talk/base/xmpppassword.h 2006-09-01 04:31:52.000000000 -0700
++++ libjingle-0.3.10/talk/base/xmpppassword.h 2010-09-15 13:10:33.105210000 -0700
+@@ -30,7 +30,7 @@
+
+ #include "talk/base/linked_ptr.h"
+ #include "talk/base/scoped_ptr.h"
+-
++#include <cstring>
+ namespace buzz {
+
+ class XmppPasswordImpl {
+Index: libjingle-0.3.10/talk/p2p/base/pseudotcp.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/p2p/base/pseudotcp.cc 2006-09-01 04:31:51.000000000 -0700
++++ libjingle-0.3.10/talk/p2p/base/pseudotcp.cc 2010-09-15 13:17:33.135210000 -0700
+@@ -52,6 +52,8 @@ extern "C" {
+ }
+ #endif // POSIX
+
++#include <cstring>
++#include <cstdlib>
+ namespace cricket {
+
+ //////////////////////////////////////////////////////////////////////
+Index: libjingle-0.3.10/talk/p2p/base/stun.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/p2p/base/stun.cc 2006-09-01 04:31:51.000000000 -0700
++++ libjingle-0.3.10/talk/p2p/base/stun.cc 2010-09-15 13:16:30.845210000 -0700
+@@ -29,6 +29,7 @@
+ #include "talk/p2p/base/stun.h"
+ #include <iostream>
+ #include <cassert>
++#include <cstring>
+
+ #if defined(_MSC_VER) && _MSC_VER < 1300
+ namespace std {
+Index: libjingle-0.3.10/talk/p2p/base/stunserver.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/p2p/base/stunserver.cc 2006-09-01 04:31:51.000000000 -0700
++++ libjingle-0.3.10/talk/p2p/base/stunserver.cc 2010-09-15 13:18:10.045210001 -0700
+@@ -28,6 +28,7 @@
+ #include "talk/base/bytebuffer.h"
+ #include "talk/p2p/base/stunserver.h"
+ #include <iostream>
++#include <cstring>
+
+ #ifdef POSIX
+ extern "C" {
+Index: libjingle-0.3.10/talk/xmpp/xmpplogintask.cc
+===================================================================
+--- libjingle-0.3.10.orig/talk/xmpp/xmpplogintask.cc 2006-09-01 04:31:52.000000000 -0700
++++ libjingle-0.3.10/talk/xmpp/xmpplogintask.cc 2010-09-15 13:15:44.185209999 -0700
+@@ -35,6 +35,7 @@
+
+ #include <iostream>
+ #include <string>
++#include <cstdio>
+ #include <vector>
+ #ifdef SSL_USE_OPENSSL
+ #include <openssl/sha.h>
diff --git a/recipes/tapioca/libjingle-tapioca_0.3.10.bb b/recipes/tapioca/libjingle-tapioca_0.3.10.bb
index a4a158f4f0..f734e820ca 100644
--- a/recipes/tapioca/libjingle-tapioca_0.3.10.bb
+++ b/recipes/tapioca/libjingle-tapioca_0.3.10.bb
@@ -1,9 +1,12 @@
LICENSE = "BERKLEY"
DEPENDS = "openssl ortp speex expat"
PROVIDES = "libjingle"
-PR = "r0"
+PR = "r1"
-SRC_URI = "${SOURCEFORGE_MIRROR}/tapioca-voip/libjingle-${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/tapioca-voip/libjingle-${PV}.tar.gz \
+ file://gcc-4.5-compilation-fixes.patch \
+ file://fix-host-h-double-install.patch \
+ "
S = "${WORKDIR}/libjingle-${PV}"