aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-02 17:16:08 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-02 17:16:08 +0100
commitf3404090052164f7843dcd5b3190b046e9ff4a25 (patch)
treefea891f17db98f7c8c0435937eeb7abc68842297
parent34ee51c144c2f02195f0ddf38f37f37dd6996f9b (diff)
downloadopenembedded-f3404090052164f7843dcd5b3190b046e9ff4a25.tar.gz
cdparanoia: created svn recipe
the 10.2 version exports a header file with a field called private g++ 4.3.3 and up fail on that this problem is resolved in svn
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--recipes/cdparanoia/cdparanoia_svn.bb35
2 files changed, 36 insertions, 0 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 2bbd1dc5ce..f7d78ec01f 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -22,6 +22,7 @@ SRCREV_pn-bfin-uclibc ?= "1857"
SRCREV_pn-bootchart-lite ?= "4"
SRCREV_pn-bubble-keyboard ?= "194"
SRCREV_pn-calibrateproto ?= "1da6fd1e2c7a49648245c98481fabea8b9690a8c"
+SRCREV_pn-cdparanoia ?= "16684"
SRCREV_pn-clutter-box2d ?= "3197"
SRCREV_pn-clutter-cairo ?= "3210"
SRCREV_pn-clutter-gst ?= "3188"
diff --git a/recipes/cdparanoia/cdparanoia_svn.bb b/recipes/cdparanoia/cdparanoia_svn.bb
new file mode 100644
index 0000000000..d3358a64e3
--- /dev/null
+++ b/recipes/cdparanoia/cdparanoia_svn.bb
@@ -0,0 +1,35 @@
+# cdparanoia OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+PR ="r0"
+LICENSE="GPL"
+
+PV = "10.2+svn${SRCREV}"
+
+SRC_URI="svn://svn.xiph.org/trunk;module=cdparanoia;proto=http \
+ file://fixes10.patch;patch=1 \
+ file://Makefile.in.patch;patch=1 \
+ file://interface_Makefile.in.patch;patch=1 \
+ file://paranoia_Makefile.in.patch;patch=1 "
+
+S="${WORKDIR}/cdparanoia"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+do_install() {
+ oe_runmake BINDIR="${D}/usr/bin" MANDIR="${D}/usr/share/man/" \
+ INCLUDEDIR="${D}/usr/include/" LIBDIR="${D}/usr/lib" install
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR} ${STAGING_LIBDIR}
+
+ install -m 0644 paranoia/cdda_paranoia.h ${STAGING_INCDIR}
+ install -m 0644 interface/cdda_interface.h ${STAGING_INCDIR}
+
+ oe_libinstall -C interface libcdda_interface ${STAGING_LIBDIR}
+ oe_libinstall -C paranoia libcdda_paranoia ${STAGING_LIBDIR}
+}