aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-06-07 21:46:40 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-06-07 21:46:40 +0200
commit910b2a21a44e9d6d17a51e24a1cf9352a64f3d7d (patch)
tree06e3c1590f1cf2bb68e1260827e70775a6518dd4
parent08fdc869f0fad6aebde1eb317fb0e15e596e5d4f (diff)
parentbd6fa71311d06f19b2797a3940d8b6779e32ae66 (diff)
downloadopenembedded-910b2a21a44e9d6d17a51e24a1cf9352a64f3d7d.tar.gz
Merge branch 'master' of git.openembedded.net:openembedded into org.openembedded.dev
-rw-r--r--recipes/h2200-bootloader/h2200-bootloader.bb1
-rw-r--r--recipes/linux/linux-2.6.24/ftdi-4n-galaxy.patch22
-rw-r--r--recipes/linux/linux_2.6.24.bb3
-rw-r--r--recipes/x-load/x-load-git/0001-Beagle-Rev-C5-support.patch60
-rw-r--r--recipes/x-load/x-load_git.bb3
5 files changed, 87 insertions, 2 deletions
diff --git a/recipes/h2200-bootloader/h2200-bootloader.bb b/recipes/h2200-bootloader/h2200-bootloader.bb
index 69214c76f2..92194e59eb 100644
--- a/recipes/h2200-bootloader/h2200-bootloader.bb
+++ b/recipes/h2200-bootloader/h2200-bootloader.bb
@@ -1,4 +1,5 @@
DESCRIPTION = "Bootloader firmware extractor for the h2200 iPAQ"
+LICENSE = "MIT"
ALLOW_EMPTY = "1"
PR = "r4"
diff --git a/recipes/linux/linux-2.6.24/ftdi-4n-galaxy.patch b/recipes/linux/linux-2.6.24/ftdi-4n-galaxy.patch
new file mode 100644
index 0000000000..133aae856b
--- /dev/null
+++ b/recipes/linux/linux-2.6.24/ftdi-4n-galaxy.patch
@@ -0,0 +1,22 @@
+diff -Nurd linux-2.6.24.orig/drivers/usb/serial/ftdi_sio.c linux-2.6.24/drivers/usb/serial/ftdi_sio.c
+--- linux-2.6.24.orig/drivers/usb/serial/ftdi_sio.c 2011-06-07 12:15:01.418982729 +0200
++++ linux-2.6.24/drivers/usb/serial/ftdi_sio.c 2011-06-07 12:16:20.107926616 +0200
+@@ -523,6 +523,7 @@
+ { USB_DEVICE(FTDI_VID, EVER_ECO_PRO_CDS) },
+ { USB_DEVICE(FTDI_VID, FTDI_4N_GALAXY_DE_1_PID) },
+ { USB_DEVICE(FTDI_VID, FTDI_4N_GALAXY_DE_2_PID) },
++ { USB_DEVICE(FTDI_VID, FTDI_4N_GALAXY_DE_3_PID) },
+ { USB_DEVICE(FTDI_VID, XSENS_CONVERTER_0_PID) },
+ { USB_DEVICE(FTDI_VID, XSENS_CONVERTER_1_PID) },
+ { USB_DEVICE(FTDI_VID, XSENS_CONVERTER_2_PID) },
+diff -Nurd linux-2.6.24.orig/drivers/usb/serial/ftdi_sio.h linux-2.6.24/drivers/usb/serial/ftdi_sio.h
+--- linux-2.6.24.orig/drivers/usb/serial/ftdi_sio.h 2011-06-07 12:15:01.413983114 +0200
++++ linux-2.6.24/drivers/usb/serial/ftdi_sio.h 2011-06-07 12:16:11.652577907 +0200
+@@ -387,6 +387,7 @@
+ */
+ #define FTDI_4N_GALAXY_DE_1_PID 0xF3C0
+ #define FTDI_4N_GALAXY_DE_2_PID 0xF3C1
++#define FTDI_4N_GALAXY_DE_3_PID 0xF3C2
+
+ /*
+ * Mobility Electronics products.
diff --git a/recipes/linux/linux_2.6.24.bb b/recipes/linux/linux_2.6.24.bb
index 85696906ca..e9844bbeae 100644
--- a/recipes/linux/linux_2.6.24.bb
+++ b/recipes/linux/linux_2.6.24.bb
@@ -11,7 +11,7 @@ DEFAULT_PREFERENCE_hipox = "1"
DEFAULT_PREFERENCE_cs-e9302 = "1"
DEFAULT_PREFERENCE_smartq5 = "1"
-PR = "r42"
+PR = "r44"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2;name=kernel \
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.7.bz2;apply=yes;name=stablepatch \
@@ -20,6 +20,7 @@ SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2;name=k
file://ubifs-v2.6.24-silent-get-sb.patch \
file://cfi-amic.patch \
file://make-3.82.patch \
+ file://ftdi-4n-galaxy.patch \
file://defconfig"
# Moved away temporarely until committed properly (work in progress).
diff --git a/recipes/x-load/x-load-git/0001-Beagle-Rev-C5-support.patch b/recipes/x-load/x-load-git/0001-Beagle-Rev-C5-support.patch
new file mode 100644
index 0000000000..1c67bd359d
--- /dev/null
+++ b/recipes/x-load/x-load-git/0001-Beagle-Rev-C5-support.patch
@@ -0,0 +1,60 @@
+From 992eb6ff881792f5c753ef6c85be0ceb2d162c78 Mon Sep 17 00:00:00 2001
+From: Joel Fernandes <agnel.joel@gmail.com>
+Date: Tue, 7 Jun 2011 09:50:03 +0200
+Subject: [PATCH] Beagle Rev C5 support
+
+---
+ board/omap3530beagle/omap3530beagle.c | 16 ++++++++++++++++
+ 1 files changed, 16 insertions(+), 0 deletions(-)
+
+diff --git a/board/omap3530beagle/omap3530beagle.c b/board/omap3530beagle/omap3530beagle.c
+index 15943f5..2b8c3c0 100644
+--- a/board/omap3530beagle/omap3530beagle.c
++++ b/board/omap3530beagle/omap3530beagle.c
+@@ -281,6 +281,7 @@ u32 wait_on_value(u32 read_bit_mask, u32 match_value, u32 read_addr, u32 bound)
+
+ #define MICRON_DDR 0
+ #define NUMONYX_MCP 1
++#define MICRON_MCP 2
+ int identify_xm_ddr()
+ {
+ int mfr, id;
+@@ -303,6 +304,8 @@ int identify_xm_ddr()
+ return MICRON_DDR;
+ if ((mfr == 0x20) && (id == 0xba))
+ return NUMONYX_MCP;
++ if ((mfr == 0x2c) && (id == 0xbc))
++ return MICRON_MCP;
+ }
+ /*********************************************************************
+ * config_3430sdram_ddr() - Init DDR on 3430SDP dev board.
+@@ -329,6 +332,17 @@ void config_3430sdram_ddr(void)
+ __raw_writel(NUMONYX_V_ACTIMB_165, SDRC_ACTIM_CTRLB_1);
+ __raw_writel(SDP_3430_SDRC_RFR_CTRL_165MHz, SDRC_RFR_CTRL_0);
+ __raw_writel(SDP_3430_SDRC_RFR_CTRL_165MHz, SDRC_RFR_CTRL_1);
++ } else if (identify_xm_ddr() == MICRON_MCP) {
++ /* Beagleboard Rev C5 */
++ __raw_writel(0x2, SDRC_CS_CFG); /* 256MB/bank */
++ __raw_writel(SDP_SDRC_MDCFG_0_DDR_MICRON_XM, SDRC_MCFG_0);
++ __raw_writel(SDP_SDRC_MDCFG_0_DDR_MICRON_XM, SDRC_MCFG_1);
++ __raw_writel(MICRON_V_ACTIMA_200, SDRC_ACTIM_CTRLA_0);
++ __raw_writel(MICRON_V_ACTIMB_200, SDRC_ACTIM_CTRLB_0);
++ __raw_writel(MICRON_V_ACTIMA_200, SDRC_ACTIM_CTRLA_1);
++ __raw_writel(MICRON_V_ACTIMB_200, SDRC_ACTIM_CTRLB_1);
++ __raw_writel(SDP_3430_SDRC_RFR_CTRL_200MHz, SDRC_RFR_CTRL_0);
++ __raw_writel(SDP_3430_SDRC_RFR_CTRL_200MHz, SDRC_RFR_CTRL_1);
+ } else {
+ __raw_writel(0x1, SDRC_CS_CFG); /* 128MB/bank */
+ __raw_writel(SDP_SDRC_MDCFG_0_DDR, SDRC_MCFG_0);
+@@ -699,6 +713,8 @@ int misc_init_r(void)
+ case REVISION_C4:
+ if (identify_xm_ddr() == NUMONYX_MCP)
+ printf("Beagle Rev C4 from Special Computing\n");
++ else if(identify_xm_ddr() == MICRON_MCP)
++ printf("Beagle Rev C5\n");
+ else
+ printf("Beagle Rev C4\n");
+ break;
+--
+1.6.6.1
+
diff --git a/recipes/x-load/x-load_git.bb b/recipes/x-load/x-load_git.bb
index 85ee9697ac..17fe369299 100644
--- a/recipes/x-load/x-load_git.bb
+++ b/recipes/x-load/x-load_git.bb
@@ -5,11 +5,12 @@ DEFAULT_PREFERENCE_omap3-pandora = "-1"
FILESPATHPKG_prepend = "x-load-git:x-load-git/${MACHINE}"
PV = "1.5.0+${PR}+gitr${SRCREV}"
-PR ="r23"
+PR ="r24"
PE = "1"
SRCREV = "04b1732220078d47c18a84cbafc52e45db71f13d"
SRC_URI = "git://gitorious.org/x-loader/x-loader.git;branch=master;protocol=git \
+ file://0001-Beagle-Rev-C5-support.patch \
"
XLOAD_MACHINE_beagleboard = "omap3530beagle_config"