aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf_samuelsson@telia.com>2011-11-21 16:59:49 +0100
committerUlf Samuelsson <ulf_samuelsson@telia.com>2011-11-21 16:59:49 +0100
commit24207644c4efe29fe22c5c69688a0c3f7ffb106e (patch)
tree75bc0c30533e79dbc0b135524f872ea52513b2dc
parent506760ceb9c025dca0edf3544aafe97b0af6a2bd (diff)
downloadopenembedded-24207644c4efe29fe22c5c69688a0c3f7ffb106e.tar.gz
linux-2.6.30: Support at91sam9g20ek_2mmc
Signed-off-by: Ulf Samuelsson <ulf_samuelsson@telia.com>
-rw-r--r--recipes/linux/linux-2.6.30/at91/exp.4/0003-change-NAND-partitions-for-Atmel-SAM9G20-boards.patch55
-rw-r--r--recipes/linux/linux_2.6.30.bb27
2 files changed, 70 insertions, 12 deletions
diff --git a/recipes/linux/linux-2.6.30/at91/exp.4/0003-change-NAND-partitions-for-Atmel-SAM9G20-boards.patch b/recipes/linux/linux-2.6.30/at91/exp.4/0003-change-NAND-partitions-for-Atmel-SAM9G20-boards.patch
new file mode 100644
index 0000000000..7b42ca1e2f
--- /dev/null
+++ b/recipes/linux/linux-2.6.30/at91/exp.4/0003-change-NAND-partitions-for-Atmel-SAM9G20-boards.patch
@@ -0,0 +1,55 @@
+From 3fa498b26edf800a26f91db628d63404a2b314e9 Mon Sep 17 00:00:00 2001
+From: Ulf Samuelsson <ulf_samuelsson@telia.com>
+Date: Fri, 28 Oct 2011 11:55:28 +0200
+Subject: [PATCH] change NAND partitions for Atmel SAM9G20 boards
+
+---
+ arch/arm/mach-at91/board-sam9g20ek-2slot-mmc.c | 9 +++++++--
+ arch/arm/mach-at91/board-sam9g20ek.c | 9 +++++++--
+ 2 files changed, 14 insertions(+), 4 deletions(-)
+
+diff --git a/arch/arm/mach-at91/board-sam9g20ek-2slot-mmc.c b/arch/arm/mach-at91/board-sam9g20ek-2slot-mmc.c
+index 51b3008..3b3604f 100644
+--- a/arch/arm/mach-at91/board-sam9g20ek-2slot-mmc.c
++++ b/arch/arm/mach-at91/board-sam9g20ek-2slot-mmc.c
+@@ -125,9 +125,14 @@ static struct at91_eth_data __initdata ek_macb_data = {
+ */
+ static struct mtd_partition __initdata ek_nand_partition[] = {
+ {
+- .name = "Bootstrap",
++ .name = "Boot",
+ .offset = 0,
+- .size = 4 * SZ_1M,
++ .size = 2 * SZ_1M,
++ },
++ {
++ .name = "Kernel",
++ .offset = 0,
++ .size = 2 * SZ_1M,
+ },
+ {
+ .name = "Root File System",
+diff --git a/arch/arm/mach-at91/board-sam9g20ek.c b/arch/arm/mach-at91/board-sam9g20ek.c
+index 811dd09..b1a3628 100644
+--- a/arch/arm/mach-at91/board-sam9g20ek.c
++++ b/arch/arm/mach-at91/board-sam9g20ek.c
+@@ -124,9 +124,14 @@ static struct at91_eth_data __initdata ek_macb_data = {
+ */
+ static struct mtd_partition __initdata ek_nand_partition[] = {
+ {
+- .name = "Bootstrap",
++ .name = "Boot",
+ .offset = 0,
+- .size = 4 * SZ_1M,
++ .size = 2 * SZ_1M,
++ },
++ {
++ .name = "Kernel",
++ .offset = 0,
++ .size = 2 * SZ_1M,
+ },
+ {
+ .name = "Root File System",
+--
+1.7.5.4
+
diff --git a/recipes/linux/linux_2.6.30.bb b/recipes/linux/linux_2.6.30.bb
index 87b7d2fb1e..a595f36e9f 100644
--- a/recipes/linux/linux_2.6.30.bb
+++ b/recipes/linux/linux_2.6.30.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r7"
+PR = "r8"
AT91_EXPERIMENTAL = "4"
S = "${WORKDIR}/linux-${PV}"
@@ -16,6 +16,8 @@ DEFAULT_PREFERENCE_at91sam9m10ekes = "2"
DEFAULT_PREFERENCE_at91sam9m10g45ek = "2"
DEFAULT_PREFERENCE_at91sam9g10ek = "2"
DEFAULT_PREFERENCE_at91sam9g20ek = "2"
+DEFAULT_PREFERENCE_at91sam9g20ek_2mmc = "2"
+DEFAULT_PREFERENCE_at91sam9g20ek-2mmc = "2"
DEFAULT_PREFERENCE_ronetix-pm9g45 = "2"
DEFAULT_PREFERENCE_vulcano-g20 = "2"
@@ -33,6 +35,7 @@ AT91_EXPERIMENTAL_4 = " \
ftp://www.at91.com/pub/linux/${PV}-at91/${PV}-at91-exp.${AT91_EXPERIMENTAL}.tar.gz;apply=no;name=at91exp${AT91_EXPERIMENTAL} \
file://at91/exp.4/0001-Configurable-partition-size.patch;apply=yes \
file://at91/exp.4/0002-mach-at91-KConfig-cleanup.patch;apply=yes \
+ file://at91/exp.4/0003-change-NAND-partitions-for-Atmel-SAM9G20-boards.patch \
http://linux.hd-wireless.se/pub/Linux/BuildSAM9M10EKES/2.6.30-at91-sdio-irq-support-both-slots.patch;apply=yes;name=owlwifi \
file://defconfig"
@@ -50,19 +53,19 @@ at91sam_patch = " \
SRC_URI_at91sam9m10ekes = "${AT91_EXPERIMENTAL_4}"
SRC_URI_at91cap9stk = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_at91sam9g20ek-2mmc = "${AT91_EXPERIMENTAL_4}"
SRC_URI_at91 = "${AT91_EXPERIMENTAL_2}"
-SRC_URI_append_at91sam9260ek = ${at91sam_patch}
-SRC_URI_append_at91sam9261ek = ${at91sam_patch}
-SRC_URI_append_at91sam9263ek = ${at91sam_patch}
-SRC_URI_append_at91sam9g10ek = ${at91sam_patch}
-SRC_URI_append_at91sam9g20ek = ${at91sam_patch}
-SRC_URI_append_at91sam9g20ek_2mmc = ${at91sam_patch}
-SRC_URI_append_at91sam9g45ekes = ${at91sam_patch}
-SRC_URI_append_at91sam9m10ekes = ${at91sam_patch}
-SRC_URI_append_at91sam9m10g45ek = ${at91sam_patch}
-SRC_URI_append_at91sam9rlek = ${at91sam_patch}
-SRC_URI_append_at91sam9xeek = ${at91sam_patch}
+SRC_URI_append_at91sam9260ek = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9261ek = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9263ek = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9g10ek = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9g20ek = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9g45ekes = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9m10ekes = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9m10g45ek = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9rlek = "${AT91_EXPERIMENTAL_4}"
+SRC_URI_append_at91sam9xeek = "${AT91_EXPERIMENTAL_4}"
#do_patch_prepend_at91sam9m10ekes() {
# bb.build.exec_func('do_apply_at91_exp_patch', d)