aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf_samuelsson@telia.com>2011-11-16 15:49:24 +0100
committerUlf Samuelsson <ulf_samuelsson@telia.com>2011-11-21 17:12:58 +0100
commitf18d531fab6d2247bddd1223f9c4953de6cfa8f4 (patch)
tree31cfc6163010654c9b427ff424280fc303f4177c
parent77f5a01ab39c2efe4b80a6442e74861a688accf2 (diff)
downloadopenembedded-f18d531fab6d2247bddd1223f9c4953de6cfa8f4.tar.gz
sam9gx5 configurations
Signed-off-by: Ulf Samuelsson <ulf.samuelsson@telia.com>
-rw-r--r--recipes/alsa/alsa-state/at91sam9x5ek/asound.conf2
-rw-r--r--recipes/alsa/alsa-state/at91sam9x5ek/asound.state166
-rw-r--r--recipes/pointercal/files/at91sam9x5ek/pointercal1
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/at91sam9x5ek/xorg.conf43
-rw-r--r--recipes/xserver-common/files/Xserver.add.at91sam9x5ek.patch11
-rw-r--r--recipes/xserver-common/xserver-common_1.34.bb41
6 files changed, 250 insertions, 14 deletions
diff --git a/recipes/alsa/alsa-state/at91sam9x5ek/asound.conf b/recipes/alsa/alsa-state/at91sam9x5ek/asound.conf
new file mode 100644
index 0000000000..fa98593515
--- /dev/null
+++ b/recipes/alsa/alsa-state/at91sam9x5ek/asound.conf
@@ -0,0 +1,2 @@
+pcm.!default { type hw card 0 }
+ctl.!default { type hw card 0 }
diff --git a/recipes/alsa/alsa-state/at91sam9x5ek/asound.state b/recipes/alsa/alsa-state/at91sam9x5ek/asound.state
new file mode 100644
index 0000000000..5f0349b6b9
--- /dev/null
+++ b/recipes/alsa/alsa-state/at91sam9x5ek/asound.state
@@ -0,0 +1,166 @@
+state.AT91SAM9X5 {
+ control.1 {
+ iface MIXER
+ name 'Master Playback Volume'
+ value.0 100
+ value.1 100
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 127'
+ dbmin -9999999
+ dbmax 600
+ dbvalue.0 0
+ dbvalue.1 0
+ }
+ }
+ control.2 {
+ iface MIXER
+ name 'Master Playback ZC Switch'
+ value.0 false
+ value.1 false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.3 {
+ iface MIXER
+ name 'Capture Volume'
+ value.0 29
+ value.1 29
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -3450
+ dbmax 1200
+ dbvalue.0 900
+ dbvalue.1 900
+ }
+ }
+ control.4 {
+ iface MIXER
+ name 'Line Capture Switch'
+ value.0 true
+ value.1 true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.5 {
+ iface MIXER
+ name 'Mic Boost Volume'
+ value 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 1'
+ dbmin 0
+ dbmax 2000
+ dbvalue.0 0
+ }
+ }
+ control.6 {
+ iface MIXER
+ name 'Mic Capture Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.7 {
+ iface MIXER
+ name 'Sidetone Playback Volume'
+ value 3
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 3'
+ dbmin -1500
+ dbmax -600
+ dbvalue.0 -600
+ }
+ }
+ control.8 {
+ iface MIXER
+ name 'ADC High Pass Filter Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.9 {
+ iface MIXER
+ name 'Store DC Offset Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.10 {
+ iface MIXER
+ name 'Playback Deemphasis Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.11 {
+ iface MIXER
+ name 'Input Mux'
+ value 'Line In'
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 'Line In'
+ item.1 Mic
+ }
+ }
+ control.12 {
+ iface MIXER
+ name 'Output Mixer Line Bypass Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.13 {
+ iface MIXER
+ name 'Output Mixer Mic Sidetone Switch'
+ value false
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.14 {
+ iface MIXER
+ name 'Output Mixer HiFi Playback Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+}
diff --git a/recipes/pointercal/files/at91sam9x5ek/pointercal b/recipes/pointercal/files/at91sam9x5ek/pointercal
new file mode 100644
index 0000000000..86a90ff7c6
--- /dev/null
+++ b/recipes/pointercal/files/at91sam9x5ek/pointercal
@@ -0,0 +1 @@
+160 54744 -1903496 -36668 -218 33587932 65536 800 4800 \ No newline at end of file
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/at91sam9x5ek/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/at91sam9x5ek/xorg.conf
new file mode 100644
index 0000000000..a8b4491736
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-conf/at91sam9x5ek/xorg.conf
@@ -0,0 +1,43 @@
+Section "Device"
+ Identifier "Device0"
+ Driver "fbdev"
+ Option "UseFBDev" "true"
+ Option "ShadowFB" "false"
+EndSection
+
+Section "Monitor"
+ Identifier "Monitor0"
+ Option "DPMS" "false"
+ DisplaySize 108 64.8
+EndSection
+
+Section "Screen"
+ Identifier "Screen0"
+ Device "Device0"
+ Monitor "Monitor0"
+EndSection
+
+Section "InputDevice"
+ Identifier "atmel-tsadcc-ev"
+ Driver "evdev"
+ Option "Device" "/dev/input/touchscreen0"
+ Option "SwapAxes" "1"
+ Option "InvertY" "1"
+ Option "Calibration" "51 924 33 992"
+EndSection
+
+Section "InputDevice"
+ Identifier "atmel-tsadcc-ts"
+ Driver "tslib"
+ Option "Device" "/dev/input/touchscreen0"
+EndSection
+
+Section "ServerFlags"
+ Option "AutoAddDevices" "false"
+EndSection
+
+Section "ServerLayout"
+ Identifier "default"
+ InputDevice "atmel-tsadcc-ts" "CorePointer"
+ Screen "Screen0"
+EndSection
diff --git a/recipes/xserver-common/files/Xserver.add.at91sam9x5ek.patch b/recipes/xserver-common/files/Xserver.add.at91sam9x5ek.patch
new file mode 100644
index 0000000000..f36cc127a0
--- /dev/null
+++ b/recipes/xserver-common/files/Xserver.add.at91sam9x5ek.patch
@@ -0,0 +1,11 @@
+--- xserver-common-1.34.orig/X11/xserver-common
++++ xserver-common-1.34/X11/xserver-common
+@@ -186,6 +186,8 @@
+ # this is to rotate X display properly, tested with display TX09D71VM1CCA
+ ronetix*pm9261* | ronetix*pm9263*)
+ ARGS="$ARGS -screen 240/54x320/81@90x16" ;;
++ "atmel_at91sam9x5-ek")
++ DPI="188" ;;
+ # This is a fallback for PCs
+ "")
+ if [ -f $BINDIR/Xvesa ]; then
diff --git a/recipes/xserver-common/xserver-common_1.34.bb b/recipes/xserver-common/xserver-common_1.34.bb
index 8774078d65..6e4ab67e01 100644
--- a/recipes/xserver-common/xserver-common_1.34.bb
+++ b/recipes/xserver-common/xserver-common_1.34.bb
@@ -1,8 +1,15 @@
DESCRIPTION = "Common X11 scripts and support files"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+SECTION = "x11"
-PR = "r3"
+PR = "r4"
+
+PACKAGE_ARCH = "all"
+DEFAULT_PREFERENCE = "-1"
+
+RCONFLICTS_${PN} = "xserver-kdrive-common"
+RREPLACES_${PN} = "xserver-kdrive-common"
# we are using a gpe-style Makefile
inherit gpe
@@ -14,21 +21,27 @@ SRC_URI_append = " \
file://gplv2-license.patch \
file://setDPI.sh \
file://89xdgautostart.sh \
- file://89xTs_Calibrate.xinput_calibrator.patch \
- file://90xXWindowManager.patch \
- file://Xserver.add.xserver-system.patch \
- file://Xserver.add.nocursor.for.gta.patch \
- file://Xserver.add.dpi.for.gta.patch \
- file://Xserver.n900.patch \
- file://Xserver.htcdream.patch \
- file://Xserver.nexusone.patch \
-"
-
+ file://Xserver.add.at91sam9x5ek.patch"
+
+SRC_URI_append_angstrom = " file://xtscal-fix.patch "
+RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
+RDEPENDS_${PN}_append_shr = " xinput-calibrator "
+
+SRC_URI_append_shr = " \
+ file://89xTs_Calibrate.xinput_calibrator.patch \
+ file://90xXWindowManager.patch \
+ file://Xserver.add.xserver-system.patch \
+ file://Xserver.add.nocursor.for.gta.patch \
+ file://Xserver.add.dpi.for.gta.patch \
+ file://Xserver.n900.patch \
+ file://Xserver.htcdream.patch \
+ file://Xserver.nexusone.patch \
+ "
do_install_append() {
- install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
- install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
- sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+ install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
+ sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
}
PACKAGE_ARCH = "all"