aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-03-04 14:38:08 +0100
committerKoen Kooi <koen@openembedded.org>2009-03-04 14:38:08 +0100
commita607dfe046fc5eb0f20dc8f3901b8aaded42d17c (patch)
treeb92d707c3bdb26bef6bb66435c060a258fc122e3
parent01d1763f4d02cfa2b4e7397d84428e3f30407b65 (diff)
parent5bfe29a25496da5ea5ebc9b0314f4d38a53e6691 (diff)
downloadopenembedded-a607dfe046fc5eb0f20dc8f3901b8aaded42d17c.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
-rw-r--r--classes/package_ipk.bbclass11
-rw-r--r--conf/distro/include/sane-toolchain.inc8
-rw-r--r--conf/machine/include/tune-arm1136-novfp.inc2
-rw-r--r--packages/qmake/files/0008-backport-qt-lib-infix.patch33
-rw-r--r--packages/qt4/qt-embedded-4.4.3/allow-configure-plugins.patch62
-rw-r--r--packages/qt4/qt-embedded.inc46
-rw-r--r--packages/qt4/qt-embedded_4.4.3.bb48
7 files changed, 53 insertions, 157 deletions
diff --git a/classes/package_ipk.bbclass b/classes/package_ipk.bbclass
index 89d5071c09..d4cb3b62e2 100644
--- a/classes/package_ipk.bbclass
+++ b/classes/package_ipk.bbclass
@@ -297,16 +297,7 @@ python do_package_ipk () {
bb.utils.unlockfile(lf)
raise bb.build.FuncFailed("ipkg-build execution failed")
- for script in ["preinst", "postinst", "prerm", "postrm", "control" ]:
- scriptfile = os.path.join(controldir, script)
- try:
- os.remove(scriptfile)
- except OSError:
- pass
- try:
- os.rmdir(controldir)
- except OSError:
- pass
+ bb.utils.prunedir(controldir)
bb.utils.unlockfile(lf)
}
diff --git a/conf/distro/include/sane-toolchain.inc b/conf/distro/include/sane-toolchain.inc
index 0d859903e1..b261d635af 100644
--- a/conf/distro/include/sane-toolchain.inc
+++ b/conf/distro/include/sane-toolchain.inc
@@ -73,7 +73,7 @@ PREFERRED_ARM_INSTRUCTION_SET ?= "arm"
PREFERRED_ARM_INSTRUCTION_SET_armv4t = "thumb"
PREFERRED_ARM_INSTRUCTION_SET_armv5te = "thumb"
PREFERRED_ARM_INSTRUCTION_SET_armv5teb = "thumb"
-ARM_INSTRUCTION_SET = "${PREFERRED_ARM_INSTRUCTION_SET}
+ARM_INSTRUCTION_SET = "${PREFERRED_ARM_INSTRUCTION_SET}"
# "arm" "thumb"
# The instruction set the compiler should use when generating application
# code. The kernel is always compiled with arm code at present. arm code
@@ -91,9 +91,6 @@ THUMB_INTERWORK = "yes"
# We don't want to keep OABI compat
ARM_KEEP_OABI = "0"
-# Do keep OABI compat for om-gta01 to keep the gllin binary working
-ARM_KEEP_OABI_pn-linux-openmoko-2.6.24_om-gta01 = "1"
-ARM_KEEP_OABI_pn-linux-openmoko-2.6.28_om-gta01 = "1"
# ARM EABI is softfloat by default, but let's make sure :)
# make it overridable for platforms with FPU, like ep93xx or i.mx31
@@ -108,7 +105,8 @@ TARGET_FPU_armv7a ?= "hard"
TARGET_FPU_ppc603e ?= "hard"
# webkit-gtk and cairo have alignment issues with double instructions on armv5 so
-# disable them here
+# disable them here. TODO: This knowledge should rather be encoded in the actual
+# recipes!
TARGET_CC_ARCH_pn-webkit-gtk_armv5te = "-march=armv4t"
TARGET_CC_ARCH_pn-cairo_armv5te = "-march=armv4t"
diff --git a/conf/machine/include/tune-arm1136-novfp.inc b/conf/machine/include/tune-arm1136-novfp.inc
index 372148e7a2..e1f7945a0f 100644
--- a/conf/machine/include/tune-arm1136-novfp.inc
+++ b/conf/machine/include/tune-arm1136-novfp.inc
@@ -6,3 +6,5 @@ FEED_ARCH = "armv6-novfp"
BASE_PACKAGE_ARCH = "armv6-novfp"
PACKAGE_EXTRA_ARCHS += "armv4 armv4t armv5te armv6-novfp"
+# Include tune file for thumb support, it defaults to off so DISTROs can turn it on if they wish
+require conf/machine/include/tune-thumb.inc
diff --git a/packages/qmake/files/0008-backport-qt-lib-infix.patch b/packages/qmake/files/0008-backport-qt-lib-infix.patch
deleted file mode 100644
index f87576a07b..0000000000
--- a/packages/qmake/files/0008-backport-qt-lib-infix.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
-index 32a7fd5..48d584f 100644
---- a/mkspecs/features/qt_functions.prf
-+++ b/mkspecs/features/qt_functions.prf
-@@ -28,7 +28,7 @@ defineTest(qtAddLibrary) {
- INCLUDEPATH -= $$FRAMEWORK_INCLUDE
- INCLUDEPATH = $$FRAMEWORK_INCLUDE $$INCLUDEPATH
- }
-- LINKAGE = -framework $${LIB_NAME}
-+ LINKAGE = -framework $${LIB_NAME}$${QT_LIBINFIX}
- } else:!qt_no_framework { #detection
- for(frmwrk_dir, $$list($$QMAKE_LIBDIR_QT $$QMAKE_LIBDIR $$(DYLD_FRAMEWORK_PATH) /Library/Frameworks)) {
- exists($${frmwrk_dir}/$${LIB_NAME}.framework) {
-@@ -46,15 +46,15 @@ defineTest(qtAddLibrary) {
- }
- isEmpty(LINKAGE) {
- CONFIG(debug, debug|release) {
-- win32:LINKAGE = -l$${LIB_NAME}d
-- mac:LINKAGE = -l$${LIB_NAME}_debug
-+ win32:LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}d
-+ mac:LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}_debug
- }
-- isEmpty(LINKAGE):LINKAGE = -l$${LIB_NAME}
-+ isEmpty(LINKAGE):LINKAGE = -l$${LIB_NAME}$${QT_LIBINFIX}
- }
- !isEmpty(QMAKE_LSB) {
- QMAKE_LFLAGS *= --lsb-libpath=$$$$QMAKE_LIBDIR_QT
- QMAKE_LFLAGS *= -L/opt/lsb/lib
-- QMAKE_LFLAGS *= --lsb-shared-libs=$${LIB_NAME}
-+ QMAKE_LFLAGS *= --lsb-shared-libs=$${LIB_NAME}${QT_LIBINFIX}
- }
- LIBS += $$LINKAGE
- export(LIBS)
diff --git a/packages/qt4/qt-embedded-4.4.3/allow-configure-plugins.patch b/packages/qt4/qt-embedded-4.4.3/allow-configure-plugins.patch
deleted file mode 100644
index 601f2fc369..0000000000
--- a/packages/qt4/qt-embedded-4.4.3/allow-configure-plugins.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-Index: qtopia-core-opensource-src-4.3.3/configure
-===================================================================
---- qtopia-core-opensource-src-4.3.3.orig/configure 2008-01-20 11:42:07.000000000 +0100
-+++ qtopia-core-opensource-src-4.3.3/configure 2008-01-20 22:31:37.000000000 +0100
-@@ -639,10 +639,10 @@
-
- CFG_SQL_AVAILABLE=
- if [ -d "$relpath/src/plugins/sqldrivers" ]; then
-- for a in "$relpath/src/plugins/sqldrivers/"*; do
-- if [ -d "$a" ]; then
-- base_a=`basename $a`
-- CFG_SQL_AVAILABLE="${CFG_SQL_AVAILABLE} ${base_a}"
-+ for a in `ls $relpath/src/plugins/sqldrivers/`; do
-+ dir="$relpath/src/plugins/sqldrivers/$a"
-+ if [ -d "$dir" ]; then
-+ CFG_SQL_AVAILABLE="${CFG_SQL_AVAILABLE} ${a}"
- eval "CFG_SQL_${base_a}=auto"
- fi
- done
-@@ -650,30 +650,30 @@
-
- CFG_DECORATION_PLUGIN_AVAILABLE=
- if [ -d "$relpath/src/plugins/decorations" ]; then
-- for a in "$relpath/src/plugins/decorations/"*; do
-- if [ -d "$a" ]; then
-- base_a=`basename $a`
-- CFG_DECORATION_PLUGIN_AVAILABLE="${CFG_DECORATION_PLUGIN_AVAILABLE} ${base_a}"
-+ for a in `ls $relpath/src/plugins/decorations/`; do
-+ dir="$relpath/src/plugins/decorations/$a"
-+ if [ -d "$dir" ]; then
-+ CFG_DECORATION_PLUGIN_AVAILABLE="${CFG_DECORATION_PLUGIN_AVAILABLE} ${a}"
- fi
- done
- fi
-
- CFG_MOUSE_PLUGIN_AVAILABLE=
- if [ -d "$relpath/src/plugins/mousedrivers" ]; then
-- for a in "$relpath/src/plugins/mousedrivers/"*; do
-- if [ -d "$a" ]; then
-- base_a=`basename $a`
-- CFG_MOUSE_PLUGIN_AVAILABLE="${CFG_MOUSE_PLUGIN_AVAILABLE} ${base_a}"
-+ for a in `ls $relpath/src/plugins/mousedrivers/`; do
-+ dir="$relpath/src/plugins/mousedrivers/$a"
-+ if [ -d "$dir" ]; then
-+ CFG_MOUSE_PLUGIN_AVAILABLE="${CFG_MOUSE_PLUGIN_AVAILABLE} ${a}"
- fi
- done
- fi
-
- CFG_GFX_PLUGIN_AVAILABLE=
- if [ -d "$relpath/src/plugins/gfxdrivers" ]; then
-- for a in "$relpath/src/plugins/gfxdrivers/"*; do
-- if [ -d "$a" ]; then
-- base_a=`basename $a`
-- CFG_GFX_PLUGIN_AVAILABLE="${CFG_GFX_PLUGIN_AVAILABLE} ${base_a}"
-+ for a in `ls $relpath/src/plugins/gfxdrivers/`; do
-+ dir="$relpath/src/plugins/gfxdrivers/$a"
-+ if [ -d "$dir" ]; then
-+ CFG_GFX_PLUGIN_AVAILABLE="${CFG_GFX_PLUGIN_AVAILABLE} ${a}"
- fi
- done
- CFG_GFX_OFF="$CFG_GFX_AVAILABLE" # assume all off
diff --git a/packages/qt4/qt-embedded.inc b/packages/qt4/qt-embedded.inc
new file mode 100644
index 0000000000..7de7a80a47
--- /dev/null
+++ b/packages/qt4/qt-embedded.inc
@@ -0,0 +1,46 @@
+SUMMARY = "Qt is a versatile cross-platform application framework -- this is the embedded version."
+SECTION = "libs"
+LICENSE = "GPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+DEPENDS += "tslib"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://qconfig-oe.h \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0005-fix-mkspecs.patch;patch=1 \
+ file://0006-freetype-host-includes.patch;patch=1 \
+ file://0007-openssl-host-includes.patch;patch=1 \
+ file://qt-lib-infix.patch;patch=1 \
+ file://build-tools.patch;patch=1 \
+ file://support-2bpp.patch;patch=1 \
+ "
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+
+QT_CONFIG_FLAGS += " \
+ -nomake demos -nomake examples -nomake tools -qtlibinfix E\
+ -embedded ${QT_ARCH} \
+ -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
+ -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc\
+ -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb\
+ -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb\
+ -webkit \
+ -DQT_KEYPAD_NAVIGATION \
+ "
+
+do_configure_prepend() {
+ cp ${WORKDIR}/qconfig-oe.h ${S}/src/corelib/global
+}
+
+QT_BASE_NAME = "qt-embedded"
+QT_BASE_LIB = "libqt-embedded"
+QT_DIR_NAME = "qtopia"
+QT_LIBINFIX="E"
+require qt_depends.inc
+require qt_configuration.inc
+require qt_packaging.inc
+require qt_staging.inc
+
+inherit qt4e
diff --git a/packages/qt4/qt-embedded_4.4.3.bb b/packages/qt4/qt-embedded_4.4.3.bb
index 24f45a11eb..22715cc382 100644
--- a/packages/qt4/qt-embedded_4.4.3.bb
+++ b/packages/qt4/qt-embedded_4.4.3.bb
@@ -1,48 +1,2 @@
-SUMMARY = "Qt is a versatile cross-platform application framework -- this is the embedded version."
-SECTION = "libs"
-LICENSE = "GPL"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.trolltech.com"
-DEPENDS += "tslib"
+require qt-embedded.inc
PR = "r6"
-
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
- file://qconfig-oe.h \
- file://0001-cross-compile.patch;patch=1 \
- file://0003-no-tools.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0005-fix-mkspecs.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0007-openssl-host-includes.patch;patch=1 \
- file://qt-lib-infix.patch;patch=1 \
- file://build-tools.patch;patch=1 \
- file://support-2bpp.patch;patch=1 \
-# file://allow-configure-plugins.patch;patch=1 \
- "
-S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
-
-QT_CONFIG_FLAGS += " \
- -nomake demos -nomake examples -nomake tools -qtlibinfix E\
- -embedded ${QT_ARCH} \
- -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
- -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc\
- -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb\
- -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb\
- -webkit \
- -DQT_KEYPAD_NAVIGATION \
- "
-
-do_configure_prepend() {
- cp ${WORKDIR}/qconfig-oe.h ${S}/src/corelib/global
-}
-
-QT_BASE_NAME = "qt-embedded"
-QT_BASE_LIB = "libqt-embedded"
-QT_DIR_NAME = "qtopia"
-QT_LIBINFIX="E"
-require qt_depends.inc
-require qt_configuration.inc
-require qt_packaging.inc
-require qt_staging.inc
-
-inherit qt4e