aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-10-18 21:07:47 +0200
committerLeon Woestenberg <leon@sidebranch.com>2009-10-18 21:08:42 +0200
commit559544e75c5b09d2f51a21d0d7aefbabf50bd58d (patch)
tree33dedce6aa3060d3378001d4d0652ab958ea6065
parentf6bb1d830c51b78b3e99619645152add67fad3e9 (diff)
downloadopenembedded-559544e75c5b09d2f51a21d0d7aefbabf50bd58d.tar.gz
gnash: Add gnash-fb 0.8.5, gnash for framebuffer devices.
Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
-rw-r--r--recipes/gnash/files/gnash-glib-dependency.patch33
-rw-r--r--recipes/gnash/gnash-fb_0.8.5.bb66
2 files changed, 99 insertions, 0 deletions
diff --git a/recipes/gnash/files/gnash-glib-dependency.patch b/recipes/gnash/files/gnash-glib-dependency.patch
new file mode 100644
index 0000000000..e75026c031
--- /dev/null
+++ b/recipes/gnash/files/gnash-glib-dependency.patch
@@ -0,0 +1,33 @@
+If glib is not brought in via GTK, we still need it for GStreamer. This
+seems an upstream bug in gnash, exposed when the FB GUI is built instead of
+the GTK+ GUI.
+
+Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
+
+Index: gnash-0.8.5/gui/Makefile.am
+===================================================================
+--- gnash-0.8.5.orig/gui/Makefile.am 2009-10-18 20:34:19.000000000 +0200
++++ gnash-0.8.5/gui/Makefile.am 2009-10-18 20:35:14.000000000 +0200
+@@ -137,8 +137,8 @@
+ endif
+
+ if USE_GST_ENGINE
+-AM_CPPFLAGS += $(GSTREAMER_CFLAGS)
+-AM_LDFLAGS += $(GSTREAMER_LIBS)
++AM_CPPFLAGS += $(GSTREAMER_CFLAGS) $(GLIB_CFLAGS)
++AM_LDFLAGS += $(GSTREAMER_LIBS) $(GLIB_LIBS)
+ endif
+
+ # if USE_GUI_FLTK
+Index: gnash-0.8.5/plugin/plugin.h
+===================================================================
+--- gnash-0.8.5.orig/plugin/plugin.h 2009-10-18 20:34:19.000000000 +0200
++++ gnash-0.8.5/plugin/plugin.h 2009-10-18 20:34:58.000000000 +0200
+@@ -44,6 +44,7 @@
+ #ifdef HAVE_GTK2
+ #include <gtk/gtk.h>
+ #endif
++#include <glib.h>
+ #include <string>
+ #include <map>
+ #include "pluginbase.h"
diff --git a/recipes/gnash/gnash-fb_0.8.5.bb b/recipes/gnash/gnash-fb_0.8.5.bb
new file mode 100644
index 0000000000..455d2d3c42
--- /dev/null
+++ b/recipes/gnash/gnash-fb_0.8.5.bb
@@ -0,0 +1,66 @@
+require gnash.inc
+
+DEPENDS += "gst-plugins-base cairo libmad"
+
+acpaths = " -Imacros"
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
+
+SRC_URI += "file://gnash-glib-dependency.patch;patch=1"
+
+S = "${WORKDIR}/gnash-${PV}"
+
+# Boost lacks defines for lots of archs
+TARGET_CC_ARCH_append = " -I${STAGING_INCDIR}/libxml2 -DHAVE_POLL_H ${@[' -D_BIG_ENDIAN', ' -D_LITTLE_ENDIAN'][bb.data.getVar('SITEINFO_ENDIANESS', d, 1) == 'le']}"
+
+
+do_configure_prepend() {
+ # fix an upstream case-typo in the configure script
+ sed -i s:Media_handler:media_handler:g ${S}/configure.ac
+ # find png not libpng
+ sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
+ for i in $(find ${S} -name "Makefile.am") ; do
+ sed -i -e s:LIBPNG:PNG:g $i
+ done
+ export CFLAGS="${CFLAGS} -lpng"
+}
+
+do_install_append() {
+ oe_runmake DESTDIR=${D} install-plugin
+}
+
+EXTRA_OECONF = "--enable-gui=fb \
+ --enable-renderer=agg \
+ --disable-klash \
+ --enable-z \
+ --enable-jpeg \
+ --disable-glext \
+ --enable-Xft \
+ --enable-expat \
+ --enable-mad \
+ --enable-cairo \
+ --enable-plugin \
+ --enable-plugins \
+ --enable-npapi \
+ --with-npapi-plugindir=${libdir}/mozilla/plugins \
+ --enable-mit-shm \
+ --disable-cygnal \
+ --with-top-level=${STAGING_DIR_HOST}/usr \
+ --without-included-ltdl \
+ --with-ltdl-include=${STAGING_INCDIR} \
+ --with-ltdl-lib=${STAGING_LIBDIR} \
+ --enable-png \
+ --with-png-incl=${STAGING_INCDIR} \
+ --with-png-lib=${STAGING_LIBDIR} \
+ --with-cairo-incl=${STAGING_DIR_HOST}/usr/include/cairo \
+ --with-cairo-lib=${STAGING_DIR_HOST}/usr/lib \
+ --enable-media=gst \
+ --with-gstreamer-incl=${STAGING_DIR_HOST}/usr/include/gstreamer-0.10 \
+ --with-gstreamer-lib=${STAGING_DIR_HOST}/usr/lib \
+ --with-glib-incl=${STAGING_DIR_HOST}/usr/include/glib-2.0 \
+ --with-glib-lib=${STAGING_DIR_HOST}/usr/lib \
+ --disable-speex \
+ --disable-speexdsp \
+ "
+