aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-10-31 13:59:27 +0100
committerLeon Woestenberg <leon@sidebranch.com>2009-10-31 14:06:58 +0100
commit91403056b1467560c9452a0def50402b53b16597 (patch)
treedfc73d0981557cc59d951cb1f29d105440cc48f4
parent138f792724e42d5b87668d470e3162ba4148ed14 (diff)
downloadopenembedded-91403056b1467560c9452a0def50402b53b16597.tar.gz
linux-kirkwood-2.6.31: Add PCI Express support for openrd-base.
Note there are upstream problems involving devices using PCI IOMEM. Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
-rw-r--r--recipes/linux/linux-kirkwood/openrd-base/defconfig44
-rw-r--r--recipes/linux/linux-kirkwood/openrd-base/openrd-base-enable-pcie.patch22
-rw-r--r--recipes/linux/linux-kirkwood_2.6.31.bb2
3 files changed, 62 insertions, 6 deletions
diff --git a/recipes/linux/linux-kirkwood/openrd-base/defconfig b/recipes/linux/linux-kirkwood/openrd-base/defconfig
index 8e56415e92..159eed3000 100644
--- a/recipes/linux/linux-kirkwood/openrd-base/defconfig
+++ b/recipes/linux/linux-kirkwood/openrd-base/defconfig
@@ -1,7 +1,5 @@
#
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.32-rc4
-# Fri Oct 30 11:17:30 2009
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -2413,7 +2411,7 @@ CONFIG_NLS_UTF8=y
#
# Kernel hacking
#
-# CONFIG_PRINTK_TIME is not set
+CONFIG_PRINTK_TIME=y
CONFIG_ENABLE_WARN_DEPRECATED=y
CONFIG_ENABLE_MUST_CHECK=y
CONFIG_FRAME_WARN=1024
@@ -2422,9 +2420,43 @@ CONFIG_MAGIC_SYSRQ=y
# CONFIG_UNUSED_SYMBOLS is not set
# CONFIG_DEBUG_FS is not set
# CONFIG_HEADERS_CHECK is not set
-# CONFIG_DEBUG_KERNEL is not set
-# CONFIG_DEBUG_BUGVERBOSE is not set
-# CONFIG_DEBUG_MEMORY_INIT is not set
+CONFIG_DEBUG_KERNEL=y
+# CONFIG_DEBUG_SHIRQ is not set
+CONFIG_DETECT_SOFTLOCKUP=y
+# CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC is not set
+CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC_VALUE=0
+CONFIG_DETECT_HUNG_TASK=y
+# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
+CONFIG_BOOTPARAM_HUNG_TASK_PANIC_VALUE=0
+# CONFIG_SCHED_DEBUG is not set
+# CONFIG_SCHEDSTATS is not set
+# CONFIG_TIMER_STATS is not set
+# CONFIG_DEBUG_OBJECTS is not set
+# CONFIG_SLUB_DEBUG_ON is not set
+# CONFIG_SLUB_STATS is not set
+# CONFIG_DEBUG_KMEMLEAK is not set
+CONFIG_DEBUG_PREEMPT=y
+# CONFIG_DEBUG_RT_MUTEXES is not set
+# CONFIG_RT_MUTEX_TESTER is not set
+# CONFIG_DEBUG_SPINLOCK is not set
+# CONFIG_DEBUG_MUTEXES is not set
+# CONFIG_DEBUG_LOCK_ALLOC is not set
+# CONFIG_PROVE_LOCKING is not set
+# CONFIG_LOCK_STAT is not set
+# CONFIG_DEBUG_SPINLOCK_SLEEP is not set
+# CONFIG_DEBUG_LOCKING_API_SELFTESTS is not set
+CONFIG_STACKTRACE=y
+# CONFIG_DEBUG_KOBJECT is not set
+CONFIG_DEBUG_BUGVERBOSE=y
+CONFIG_DEBUG_INFO=y
+# CONFIG_DEBUG_VM is not set
+# CONFIG_DEBUG_WRITECOUNT is not set
+CONFIG_DEBUG_MEMORY_INIT=y
+# CONFIG_DEBUG_LIST is not set
+# CONFIG_DEBUG_SG is not set
+# CONFIG_DEBUG_NOTIFIERS is not set
+# CONFIG_BOOT_PRINTK_DELAY is not set
+# CONFIG_RCU_TORTURE_TEST is not set
# CONFIG_RCU_CPU_STALL_DETECTOR is not set
# CONFIG_LATENCYTOP is not set
CONFIG_SYSCTL_SYSCALL_CHECK=y
diff --git a/recipes/linux/linux-kirkwood/openrd-base/openrd-base-enable-pcie.patch b/recipes/linux/linux-kirkwood/openrd-base/openrd-base-enable-pcie.patch
new file mode 100644
index 0000000000..165334b632
--- /dev/null
+++ b/recipes/linux/linux-kirkwood/openrd-base/openrd-base-enable-pcie.patch
@@ -0,0 +1,22 @@
+Index: git/arch/arm/mach-kirkwood/openrd_base-setup.c
+===================================================================
+--- git.orig/arch/arm/mach-kirkwood/openrd_base-setup.c 2009-09-19 19:31:45.000000000 +0200
++++ git/arch/arm/mach-kirkwood/openrd_base-setup.c 2009-09-19 19:31:54.000000000 +0200
+@@ -70,8 +70,17 @@
+ kirkwood_ge00_init(&openrd_base_ge00_data);
+ kirkwood_sata_init(&openrd_base_sata_data);
+ kirkwood_sdio_init(&openrd_base_mvsdio_data);
++ kirkwood_i2c_init();
+ }
+
++static int __init openrd_base_pci_init(void)
++{
++ if (machine_is_openrd_base())
++ kirkwood_pcie_init();
++ return 0;
++}
++subsys_initcall(openrd_base_pci_init);
++
+ MACHINE_START(OPENRD_BASE, "Marvell OpenRD Base Board")
+ /* Maintainer: Dhaval Vasa <dhaval.vasa@einfochips.com> */
+ .phys_io = KIRKWOOD_REGS_PHYS_BASE,
diff --git a/recipes/linux/linux-kirkwood_2.6.31.bb b/recipes/linux/linux-kirkwood_2.6.31.bb
index a40a09e49a..49833a488e 100644
--- a/recipes/linux/linux-kirkwood_2.6.31.bb
+++ b/recipes/linux/linux-kirkwood_2.6.31.bb
@@ -18,6 +18,8 @@ SRCREV = "8cb424312d88810bb62edbeef42a510725ceb482"
SRC_URI = "git://git.marvell.com/orion.git;protocol=git \
file://defconfig"
+SRC_URI_append_openrd-base = " file://openrd-base-enable-pcie.patch;patch=1"
+
# update machine types list for ARM architecture, only for machines that need it
do_arm_mach_types() {
if test ${MACHINE} == openrd-base; then