aboutsummaryrefslogtreecommitdiffstats
path: root/base-files
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-03-31 17:55:10 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-03-31 17:55:10 +0000
commit832d7c8d51907cad6b8301fc0186b179d4300afa (patch)
tree6a12089f4ca0b400e7dd0bf7c02cb578b0c20691 /base-files
parentc076f74a069c7e6b4427593296a04d3e123e82ca (diff)
downloadopenembedded-832d7c8d51907cad6b8301fc0186b179d4300afa.tar.gz
Merge bk://openembedded@openembedded.bkbits.net/packages
into gandalf.tm.informatik.uni-frankfurt.de:/usr/local/projects/packages 2004/03/31 12:27:56-05:00 mine.nu!erich Merge openembedded@openembedded.bkbits.net:packages into erichl.mine.nu:/home/erich/src/packages 2004/03/31 12:27:35-05:00 mine.nu!erich pango_1.2.5.oe, gtk+_2.2.4.oe: pango_1.2.5.oe, gtk+_2.2.4.oe fixes from pb_ 2004/03/31 19:26:09+02:00 de[mickey]!mickey packages-patch-20040331 BKrev: 406b05feE_NWQ67K3z6ZwOtzB3rumg
Diffstat (limited to 'base-files')
-rw-r--r--base-files/base-files_3.0.14.oe40
1 files changed, 40 insertions, 0 deletions
diff --git a/base-files/base-files_3.0.14.oe b/base-files/base-files_3.0.14.oe
index e69de29bb2..9adff46935 100644
--- a/base-files/base-files_3.0.14.oe
+++ b/base-files/base-files_3.0.14.oe
@@ -0,0 +1,40 @@
+SRC_URI = "${DEBIAN_MIRROR}/main/b/base-files/base-files_${PV}.tar.gz"
+DESCRIPTION = "Base system miscellaneous files."
+
+docdir_append = "/${P}"
+PACKAGES = "base-files"
+FILES_${PN} := "*"
+
+do_install () {
+ install -d ${D}/${docdir}
+ install -d ${D}${datadir}/${PN}
+ install -p -m 644 debian/changelog debian/FAQ \
+ debian/README.FHS debian/README.base ${D}/${docdir}/
+ cat debian/copyright.in | sed -e "s&#OSNAME#&${TARGET_OS}&g" \
+ > ${docdir}/copyright
+ install -m 755 debian/remove-base ${docdir}
+# cd debian && install -m 755 preinst postinst ${D}/DEBIAN
+# cd debian && install -m 644 conffiles ${D}/DEBIAN
+ ( cd ${D} && install -d `cat ${S}/debian/directory-list` )
+ install -p -m 644 share/* ${D}${datadir}/base-files
+ install -p -m 644 licenses/* ${D}${datadir}/common-licenses
+ ln -s LGPL-2.1 ${D}${datadir}/common-licenses/LGPL
+ ln -s GPL-2 ${D}${datadir}/common-licenses/GPL
+ install -p -m 644 `ls etc/|grep -v debian` ${D}/etc
+ rm -f ${D}/etc/motd
+ cat etc/motd | sed -e "s&#OSNAME#&${TARGET_OS}&g" > ${D}${datadir}/base-files/motd
+ cat share/info.dir | sed -e "s&#OSNAME#&${TARGET_OS}&g" > ${D}${datadir}/base-files/info.dir
+ gzip -9 ${docdir}/changelog
+# chown -R root:root ${D}
+# cd ${D} && chown root:src usr/src
+# cd ${D} && chown root:staff var/local
+# cd ${D} && chown root:staff home
+ cd ${D} && chmod 755 `find . -type d`
+ cd ${D} && chmod 1777 `cat ${S}/debian/1777-dirs`
+ cd ${D} && chmod 2775 `cat ${S}/debian/2775-dirs`
+
+ install -d ${D}/${sysconfdir}
+ oe_machinstall -m 0644 ${FILESDIR}/fstab ${D}/${sysconfdir}/fstab
+ oe_machinstall -m 0644 ${FILESDIR}/hostname ${D}/${sysconfdir}/hostname
+ oe_machinstall -m 0644 ${FILESDIR}/profile ${D}/${sysconfdir}/profile
+}