aboutsummaryrefslogtreecommitdiffstats
path: root/base-passwd
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-03-13 05:42:36 +0000
committerChris Larson <clarson@kergoth.com>2004-03-13 05:42:36 +0000
commit06f7d17e81de21a95e35b03453242bc62b05a6aa (patch)
treebc9c53bce2c6a2fdce3caf5bb45bc3f8634b56be /base-passwd
parent4b022a36ced4930af6bcdeb7d75a5ed10c4ac9cd (diff)
downloadopenembedded-06f7d17e81de21a95e35b03453242bc62b05a6aa.tar.gz
First pass of .oe cleanups.
BKrev: 40529f4crFtRY5_1DubNmWhDeHSmPw
Diffstat (limited to 'base-passwd')
-rw-r--r--base-passwd/base-passwd_3.5.7.oe68
1 files changed, 68 insertions, 0 deletions
diff --git a/base-passwd/base-passwd_3.5.7.oe b/base-passwd/base-passwd_3.5.7.oe
index e69de29bb2..8094ba04c9 100644
--- a/base-passwd/base-passwd_3.5.7.oe
+++ b/base-passwd/base-passwd_3.5.7.oe
@@ -0,0 +1,68 @@
+DEPENDS = "virtual/libc"
+RDEPENDS = "libc6"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/base-passwd/base-passwd_${PV}.tar.gz \
+ file://${FILESDIR}/configure.patch;patch=1 \
+ file://${FILESDIR}/nobash.patch;patch=1"
+
+inherit autotools
+
+#do_compile_append () {
+# oe_runmake -C doc
+#}
+
+do_install () {
+ install -d -m 755 ${D}/${sbindir}
+ install -p -m 755 update-passwd ${D}/${sbindir}/
+ install -d -m 755 \
+ ${D}/${mandir}/man8 ${D}/${mandir}/pl/man8
+ install -p -m 644 man/update-passwd.8 \
+ ${D}/${mandir}/man8/
+ install -p -m 644 man/update-passwd.pl.8 \
+ ${D}/${mandir}/pl/man8/update-passwd.8
+ gzip -9 ${D}/${mandir}/man8/* \
+ ${D}/${mandir}/pl/man8/*
+ install -d -m 755 ${D}/${datadir}/base-passwd
+ install -p -m 644 passwd.master \
+ ${D}/${datadir}/base-passwd/
+ install -p -m 644 group.master \
+ ${D}/${datadir}/base-passwd/
+
+ install -d -m 755 ${D}/${docdir}/${P}
+ install -p -m 644 debian/changelog ${D}/${docdir}/${P}/
+ gzip -9 ${D}/${docdir}/${P}/*
+ install -p -m 644 README ${D}/${docdir}/${P}/
+ install -p -m 644 debian/copyright ${D}/${docdir}/${P}/
+# install -p -m 644 \
+# doc/users-and-groups.html doc/users-and-groups.txt \
+# ${D}/${docdir}/${P}/
+# gzip -9 ${D}/${docdir}/${P}/users-and-groups.txt
+}
+
+pkg_postinst () {
+ set -e
+
+# if [ X"$1" != Xconfigure ]; then
+# exit 0
+# fi
+
+ if [ ! -e ${D}/${sysconfdir}/passwd ] ; then
+ cp ${D}/${datadir}/base-passwd/passwd.master ${D}/${sysconfdir}/passwd
+ fi
+
+ if [ ! -e ${D}/${sysconfdir}/group ] ; then
+ cp ${D}/${datadir}/base-passwd/group.master ${D}/${sysconfdir}/group
+ fi
+
+# if ! [ -x ${sbindir}/update-passwd ]; then
+# echo >&2 "`dirname $0`: ${sbindir}/update-passwd does not exist,"
+# echo >&2 "or is not executable"
+# exit 1
+# fi
+# update-passwd -p ${D}/${datadir}/base-passwd/passwd.master \
+# -g ${D}/${datadir}/base-passwd/group.master \
+# -P ${D}/${sysconfdir}/passwd \
+# -G ${D}/${sysconfdir}/group \
+# -S ${D}/${sysconfdir}/shadow --dry-run
+ exit 0
+}