aboutsummaryrefslogtreecommitdiffstats
path: root/base-passwd
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2003-10-16 19:16:09 +0000
committerChris Larson <clarson@kergoth.com>2003-10-16 19:16:09 +0000
commitf8b3aa23e9901401a9ea7013e0743360392f2f6e (patch)
treefb187cc1cc9fa24f3ba05222f02b70315efe7120 /base-passwd
parent30d22eb1316703a8c5e0a7da49b56f7dc266e617 (diff)
downloadopenembedded-f8b3aa23e9901401a9ea7013e0743360392f2f6e.tar.gz
base-passwd_3.5.4.oe:
Add initial pass at pkg_postinst target for base-passwd. BKrev: 3f8eee79HVVRxLE8qg0JxRajnfhHPQ
Diffstat (limited to 'base-passwd')
-rw-r--r--base-passwd/base-passwd_3.5.4.oe68
1 files changed, 68 insertions, 0 deletions
diff --git a/base-passwd/base-passwd_3.5.4.oe b/base-passwd/base-passwd_3.5.4.oe
index e69de29bb2..f9fae0580a 100644
--- a/base-passwd/base-passwd_3.5.4.oe
+++ b/base-passwd/base-passwd_3.5.4.oe
@@ -0,0 +1,68 @@
+DEPENDS = virtual/libc
+RDEPENDS = libc6
+
+SRC_URI := ${DEBIAN_MIRROR}/main/b/base-passwd/base-passwd_3.5.4.tar.gz
+S := ${WORKDIR}/${P}
+
+inherit autotools
+
+#do_compile_append () {
+# oe_runmake -C doc
+#}
+
+do_install () {
+ install -d -m 755 ${D}/${sbindir}
+ install -p -m 755 update-passwd ${D}/${sbindir}/
+ install -d -m 755 \
+ ${D}/${mandir}/man8 ${D}/${mandir}/pl/man8
+ install -p -m 644 man/update-passwd.8 \
+ ${D}/${mandir}/man8/
+ install -p -m 644 man/update-passwd.pl.8 \
+ ${D}/${mandir}/pl/man8/update-passwd.8
+ gzip -9 ${D}/${mandir}/man8/* \
+ ${D}/${mandir}/pl/man8/*
+ install -d -m 755 ${D}/${datadir}/base-passwd
+ install -p -m 644 passwd.master \
+ ${D}/${datadir}/base-passwd/
+ install -p -m 644 group.master \
+ ${D}/${datadir}/base-passwd/
+
+ install -d -m 755 ${D}/${docdir}/${P}
+ install -p -m 644 debian/changelog ${D}/${docdir}/${P}/
+ gzip -9 ${D}/${docdir}/${P}/*
+ install -p -m 644 README ${D}/${docdir}/${P}/
+ install -p -m 644 debian/copyright ${D}/${docdir}/${P}/
+# install -p -m 644 \
+# doc/users-and-groups.html doc/users-and-groups.txt \
+# ${D}/${docdir}/${P}/
+# gzip -9 ${D}/${docdir}/${P}/users-and-groups.txt
+}
+
+pkg_postinst () {
+ set -e
+
+ if [ X"$1" != Xconfigure ]; then
+ exit 0
+ fi
+
+ if ! [ -x ${sbindir}/update-passwd ]; then
+ echo >&2 "`dirname $0`: ${sbindir}/update-passwd does not exist,"
+ echo >&2 "or is not executable"
+ exit 1
+ fi
+
+ if [ ! -e ${D}/${sysconfdir}/passwd ] ; then
+ cp ${D}/${datadir}/base-passwd/passwd.master ${D}/${sysconfdir}/passwd
+ fi
+
+ if [ ! -e ${D}/${sysconfdir}/group ] ; then
+ cp ${D}/${datadir}/base-passwd/group.master ${D}/${sysconfdir}/group
+ fi
+
+# update-passwd -p ${D}/${datadir}/base-passwd/passwd.master \
+# -g ${D}/${datadir}/base-passwd/group.master \
+# -P ${D}/${sysconfdir}/passwd \
+# -G ${D}/${sysconfdir}/group \
+# -S ${D}/${sysconfdir}/shadow --dry-run
+ exit 0
+}