aboutsummaryrefslogtreecommitdiffstats
path: root/cetools
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-09 09:47:41 +0000
committerChris Larson <clarson@kergoth.com>2004-12-09 09:47:41 +0000
commit2c5b8ec6d95cf68650265941530e5ce38c8dd6d9 (patch)
treebf879bea7ef8517ba8c3d1286ef300401d3d484c /cetools
parent101e2f1623def0a355d20aacb8bd93810703e834 (diff)
downloadopenembedded-2c5b8ec6d95cf68650265941530e5ce38c8dd6d9.tar.gz
Merge oe-devel@oe-devel.bkbits.net:openembedded
into hyperion.kergoth.com:/home/kergoth/code/openembedded 2004/12/09 03:39:39-06:00 kergoth.com!kergoth Break people's builds again.. this time moving the packages into a packages/ subdir to clean things up a bit. BKrev: 41b81f3dvlp3rU7_8MUXLcI8LDdDoA
Diffstat (limited to 'cetools')
-rw-r--r--cetools/cetools-native_0.3.bb7
-rw-r--r--cetools/cetools_0.3.bb0
-rw-r--r--cetools/files/sean-hsieh.patch97
3 files changed, 0 insertions, 104 deletions
diff --git a/cetools/cetools-native_0.3.bb b/cetools/cetools-native_0.3.bb
deleted file mode 100644
index 4e5408cb85..0000000000
--- a/cetools/cetools-native_0.3.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-SECTION = "console/network"
-include cetools_${PV}.bb
-inherit native
-
-do_stage() {
- install -m 0755 rom2files rom2bin bin2rom dump2bin ${STAGING_BINDIR}
-}
diff --git a/cetools/cetools_0.3.bb b/cetools/cetools_0.3.bb
deleted file mode 100644
index e69de29bb2..0000000000
--- a/cetools/cetools_0.3.bb
+++ /dev/null
diff --git a/cetools/files/sean-hsieh.patch b/cetools/files/sean-hsieh.patch
deleted file mode 100644
index ce1b4965af..0000000000
--- a/cetools/files/sean-hsieh.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- cetools-0.3/bin2rom.c~sean-hsieh
-+++ cetools-0.3/bin2rom.c
-@@ -14,6 +14,12 @@
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-+
-+ History:
-+ 07/14/2000 Sean Hsieh
-+ Clear padding bytes of the input buffer when
-+ "blockSize < BLOCKSIZE" to avoid the checksum
-+ error
- */
- #include <stdio.h>
- #include <sys/stat.h>
-@@ -28,7 +34,7 @@
-
- #define min(a, b) (a<b)?(a):(b)
-
--int bin2rom( char * inputName, char * outputName, long start, long boot )
-+int bin2rom( char * inputName, char * outputName, long start, long boot, long record )
- {
- int input;
- int output;
-@@ -48,7 +54,7 @@
-
- int reste;
-
-- printf("bin2rom : input filename = %s, output filename = %s, start = 0x%lx, boot=0x%lx\n", inputName, outputName, start, boot );
-+ printf("bin2rom : input filename = %s, output filename = %s, start = 0x%08lx, boot=0x%08lx, record=0x%08lx\n", inputName, outputName, start, boot, record );
-
- input = open( inputName, O_RDONLY );
- if( input == -1 )
-@@ -247,7 +253,14 @@
- while( reste > 0 )
- {
- blockSize = min( BLOCKSIZE, reste );
--
-+ /**********************************************************************/
-+ /* Modified by Sean Hsieh */
-+ /* Clear the padding bytes to zero, this can avoid the checksum error */
-+ /**********************************************************************/
-+ if ( blockSize != BLOCKSIZE ) {
-+ memset( inStart, 0, BLOCKSIZE );
-+ //printf( "adding padding bytes\n" );
-+ }
- read( input, inStart, blockSize );
-
- #ifdef MAP_OUTPUT
-@@ -285,7 +298,8 @@
-
- write( output, &boot, 4);
-
-- write( output, &nullData, 4);
-+ //write( output, &nullData, 4);
-+ write( output, &record, 4);
-
- #endif
-
-@@ -339,17 +353,26 @@
- {
- long start;
- long boot;
-+ long record;
-
-- if( argc < 5 )
-+ if ( argc < 5 )
- {
-- printf("bin2rom: <input file> <output file> <start address> <boot address>\n");
-- exit( -1 );
-+ printf("bin2rom: <input file> <output file> <start address> <boot address> [<record address>] [-s] [-c]\n");
-+ exit( -1 );
- }
-
- sscanf( argv[3], "%lx", &start );
- sscanf( argv[4], "%lx", &boot );
--
-- bin2rom( argv[1], argv[2], start, boot );
-+ if ( argc >= 6 )
-+ {
-+ sscanf( argv[5], "%lx", &record );
-+ }
-+ else
-+ {
-+ record = 0xffffffff;
-+ }
-+
-+ bin2rom( argv[1], argv[2], start, boot, record );
-
- return 0;
- }
-\ No newline at end of file