summaryrefslogtreecommitdiffstats
path: root/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-10-30 02:42:06 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-09 12:55:02 +0000
commit6f481bcc549751aa1d7017de8c77a7606a74c468 (patch)
tree9df05637f7996c53c548d053abe596bbf3858c08 /classes/autotools.bbclass
parent96b090d1b469720f6f6a44a20f1bb96228979d6b (diff)
downloadopenembedded-6f481bcc549751aa1d7017de8c77a7606a74c468.tar.gz
autotools.bbclass: Allow for leading whitespace in gettext and intltool searches (from Poky)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'classes/autotools.bbclass')
-rw-r--r--classes/autotools.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/classes/autotools.bbclass b/classes/autotools.bbclass
index b4b1c6ec8a..b7a91693e1 100644
--- a/classes/autotools.bbclass
+++ b/classes/autotools.bbclass
@@ -113,7 +113,7 @@ autotools_do_configure() {
else
CONFIGURE_AC=configure.ac
fi
- if grep "^AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+ if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
: do nothing -- we still have an old unmodified configure.ac
else
@@ -121,7 +121,7 @@ autotools_do_configure() {
echo "no" | glib-gettextize --force --copy
fi
fi
- if grep "^[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
+ if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
oenote Executing intltoolize --copy --force --automake
intltoolize --copy --force --automake
fi