aboutsummaryrefslogtreecommitdiffstats
path: root/classes/insane.bbclass
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-06-11 12:51:28 +0000
committerKoen Kooi <koen@openembedded.org>2007-06-11 12:51:28 +0000
commitef828c09c96cdc47f0b6901f2ee83cdb4bbcc8ec (patch)
tree4951178ef7a32bd5fbf984230aef2fd5cd22f5e7 /classes/insane.bbclass
parent55c9ddab073ec7a7e404053861dd479f260688db (diff)
downloadopenembedded-ef828c09c96cdc47f0b6901f2ee83cdb4bbcc8ec.tar.gz
Blackfin support:
* siteinfo.bbclass, bfin-common: autofoo support * kernel-arch.bbclass, linux-libc-headers_2.6.20.bb: bfin -> blackfin mapping for the kernel * insane.bbclass: stubs for bfin arch, needs proper number, but that will get reported when it encounters the first binary * uclibc: config for adsp-bf537-stamp machine * adsp-bf537-stamp.conf: machine description for adsp-bf537-stamp board (http://www.analog.com/en/prod/0%2C2877%2CBF537%25252DSTAMP%2C00.html) The build currently stops in binutils cross with the "ld not supported on this archicture" message
Diffstat (limited to 'classes/insane.bbclass')
-rw-r--r--classes/insane.bbclass3
1 files changed, 2 insertions, 1 deletions
diff --git a/classes/insane.bbclass b/classes/insane.bbclass
index e6f4f1440d..d983af3f9f 100644
--- a/classes/insane.bbclass
+++ b/classes/insane.bbclass
@@ -58,7 +58,8 @@ def package_qa_get_machine_dict():
"armeb": ( 40, 97, 0, False, True),
"powerpc": ( 20, 0, 0, False, True),
"mipsel": ( 8, 0, 0, True, True),
- "avr32": (6317, 0, 0, False, True),
+ "avr32": (6317, 0, 0, False, True),
+ "bfin": ( 0, 0, 0, True, True),
},
"linux-gnueabi" : {
"arm" : (40, 0, 0, True, True),