aboutsummaryrefslogtreecommitdiffstats
path: root/classes/rootfs_ipk.bbclass
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-24 01:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-24 01:40:08 +0000
commita702a4829935cbe81edef1de716bc81664f94e0a (patch)
treeb9e32f8d19be7ba4b12a7d1a55c2e5ff74b14209 /classes/rootfs_ipk.bbclass
parent58b704b108847c779bf8fef38bd523183207c1ae (diff)
downloadopenembedded-a702a4829935cbe81edef1de716bc81664f94e0a.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 19:29:51-06:00 ti.com!kergoth Rename gnupg-devel to gnupg2, since this development branch has the binaries postfixed that way, so is clearly for the upcoming 2.x stable release. Also change libexecdir from /usr/libexec to /usr/libexec/gnupg2, as it was resulting in the gnupg binaries ending up in the root of /usr/libexec, rather than by packagename. 2005/02/23 19:24:52-06:00 ti.com!kergoth Fix the ipk rootfs/image classes to use ${libdir}/ipkg, now that ipkg does so as well. 2005/02/23 19:22:38-06:00 ti.com!kergoth Add a development version of gnupg (version 1.9.15) as gnupg-devel. Note that the 'gpgsm' and 'scdaemon' binaries are not currently being built, due to the additional dependencies they introduce. If you need them, let me know. One issue that needs to be fixed is that the gnupg-devel build needs to prefix or postfix its binaries, or conflict with 'gnupg', to ensure they don't step on one another's toes. 2005/02/23 19:18:34-06:00 ti.com!kergoth Add libgpg-error 1.0 (required by gnupg 0.9.15) and make the libgpg-error .bb's inherit binconfig. 2005/02/23 19:17:35-06:00 ti.com!kergoth Add libgcrypt 1.2.1 and make the libgcrypt .bb's inherit binconfig. 2005/02/23 19:16:20-06:00 ti.com!kergoth Add libassuan 0.6.9 (required by gnupg 0.9.15) and make the libassuan .bb's inherit binconfig. BKrev: 421d3078taXhU4QcW7mi0rDTzgYsgA
Diffstat (limited to 'classes/rootfs_ipk.bbclass')
-rw-r--r--classes/rootfs_ipk.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/classes/rootfs_ipk.bbclass b/classes/rootfs_ipk.bbclass
index 9897c1d901..e42704b5ae 100644
--- a/classes/rootfs_ipk.bbclass
+++ b/classes/rootfs_ipk.bbclass
@@ -57,12 +57,12 @@ real_do_rootfs () {
mkdir -p ${IMAGE_ROOTFS}/etc/ipkg/
grep "^arch" ${T}/ipkg.conf >${IMAGE_ROOTFS}/etc/ipkg/arch.conf
- for i in ${IMAGE_ROOTFS}/usr/lib/ipkg/info/*.preinst; do
+ for i in ${IMAGE_ROOTFS}${libdir}/ipkg/info/*.preinst; do
if [ -f $i ] && ! sh $i; then
ipkg-cl ${IPKG_ARGS} flag unpacked `basename $i .preinst`
fi
done
- for i in ${IMAGE_ROOTFS}/usr/lib/ipkg/info/*.postinst; do
+ for i in ${IMAGE_ROOTFS}${libdir}/ipkg/info/*.postinst; do
if [ -f $i ] && ! sh $i configure; then
ipkg-cl ${IPKG_ARGS} flag unpacked `basename $i .postinst`
fi