aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-03-03 12:05:33 -0700
committerTom Rini <tom_rini@mentor.com>2010-03-03 12:05:33 -0700
commit679a2367acde02f76f43f446c56c1eefed4e69c0 (patch)
treef97b3a6ce9f22fb4ad39e52a43bf560bf5e65c12 /classes
parentb9601a21e733d20d2dbf805609aca4b2cdc57bf1 (diff)
downloadopenembedded-679a2367acde02f76f43f446c56c1eefed4e69c0.tar.gz
firefox: Perform a number of cleanups and fix consistency issues.
- parallel builds need to happen via MOZ_MAKE_FLAGS and it gripes if still passed -jN, so keep the old value before we clear it. - Move the HOST_LIBIDL stuff into configure, otherwise bad things happen when you don't have pkg-config on the build host. - Prior to 3.6, wireless-tools can be, or not be built already and the Necko wifi options deals. With how 3.6 is configured, it must be disabled or DEPENDED on. For consistency, turn it off. - In 3.5 and newer, libnotify can be used, add it to DEPENDS (could be disabled). - Because of both of the above, bump PR. Signed-off-by: Tom Rini <tom_rini@mentor.com> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'classes')
-rw-r--r--classes/mozilla.bbclass26
1 files changed, 20 insertions, 6 deletions
diff --git a/classes/mozilla.bbclass b/classes/mozilla.bbclass
index c9a3966709..4e3054b9ab 100644
--- a/classes/mozilla.bbclass
+++ b/classes/mozilla.bbclass
@@ -6,10 +6,12 @@ SRC_URI += "file://mozconfig"
inherit gettext pkgconfig
+# Parallel make is special in mozilla.
+OLD_PARALLEL_MAKE := "${PARALLEL_MAKE}"
+PARALLEL_MAKE = ""
+
EXTRA_OECONF = "--target=${TARGET_SYS} --host=${BUILD_SYS} \
--build=${BUILD_SYS} --prefix=${prefix}"
-EXTRA_OEMAKE = "'HOST_LIBIDL_LIBS=${HOST_LIBIDL_LIBS}' \
- 'HOST_LIBIDL_CFLAGS=${HOST_LIBIDL_CFLAGS}'"
SELECTED_OPTIMIZATION = "-Os -fsigned-char -fno-strict-aliasing"
export CROSS_COMPILE = "1"
@@ -17,9 +19,6 @@ export MOZCONFIG = "${WORKDIR}/mozconfig"
export MOZ_OBJDIR = "${S}"
export CONFIGURE_ARGS = "${EXTRA_OECONF}"
-export HOST_LIBIDL_CFLAGS = "`${HOST_LIBIDL_CONFIG} --cflags`"
-export HOST_LIBIDL_LIBS = "`${HOST_LIBIDL_CONFIG} --libs`"
-export HOST_LIBIDL_CONFIG = "PKG_CONFIG_PATH=${STAGING_LIBDIR_NATIVE}/pkgconfig pkg-config libIDL-2.0"
export HOST_CC = "${BUILD_CC}"
export HOST_CXX = "${BUILD_CXX}"
export HOST_CFLAGS = "${BUILD_CFLAGS}"
@@ -38,7 +37,22 @@ mozilla_do_configure() {
`dirname $cg`/
done
)
- if [ -e ${MOZ_OBJDIR}/Makefile ] ; then
+
+ # Put PARALLEL_MAKE into mozconfig
+ if [ ! -z "${OLD_PARALLEL_MAKE}" ] ; then
+ echo mk_add_options MOZ_MAKE_FLAGS=\"${OLD_PARALLEL_MAKE}\" \
+ >> ${MOZCONFIG}
+ fi
+
+ # Set the host libIDL stuff correctly.
+ export HOST_LIBIDL_CONFIG="PKG_CONFIG_PATH=${STAGING_LIBDIR_NATIVE}/pkgconfig pkg-config libIDL-2.0"
+ # Due to sysroot we need to sed out references to the target staging
+ # when building the native version of xpidl Symptons of the failure
+ # include "gthread.h:344: error: size of array 'type name' is negative"
+ export HOST_LIBIDL_CFLAGS="`${HOST_LIBIDL_CONFIG} --cflags | sed -e s:${STAGING_DIR_TARGET}:${STAGING_DIR_NATIVE}:g`"
+ export HOST_LIBIDL_LIBS="`${HOST_LIBIDL_CONFIG} --libs`"
+
+ if [ -e ${MOZ_OBJDIR}/Makefile ] ; then
oe_runmake -f client.mk ${MOZ_OBJDIR}/Makefile \
${MOZ_OBJDIR}/config.status
fi