aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-21 18:40:14 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-21 18:40:14 +0000
commit289081ace1d9f300fbe9cec21b05585c5526baef (patch)
tree94d74de526857a86de25bb4cdc023776ca69ed02 /classes
parente291dce916f8867a8cb23cd808cae33830ef8d74 (diff)
downloadopenembedded-289081ace1d9f300fbe9cec21b05585c5526baef.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 10:56:50-07:00 amd.com!jcrouse gnome-common_2.4.0.bb: No longer requres scrollkeeper omf.patch: Patch to remove scrollkeeper dependancy 2005/02/21 10:53:41-07:00 amd.com!jcrouse firefox_1.0.bb: add fix for 64 bit ickiness jsautocfg.h, firefox-cc-fix.patch: Hand crafted files - replace the automatically generated one nasm_0.98.38.bb: add x86_64 to the compatible host list 2005/02/21 10:47:34-07:00 amd.com!jcrouse xfce.bbclass: change source repo and add packaging info Many files: Add XFCE 4.2.0 2005/02/21 10:39:50-07:00 amd.com!jcrouse guile-native_1.6.4.bb: add AMD64 bit fixes to guile guile-amd64.patch: new file gpdf_2.8.0.bb: Add omf.make fix for gftp BKrev: 421a2b0emv8E6lWfEOpXxE6h9MBOPg
Diffstat (limited to 'classes')
-rw-r--r--classes/xfce.bbclass26
1 files changed, 26 insertions, 0 deletions
diff --git a/classes/xfce.bbclass b/classes/xfce.bbclass
index e69de29bb2..02e9559fbc 100644
--- a/classes/xfce.bbclass
+++ b/classes/xfce.bbclass
@@ -0,0 +1,26 @@
+# xfce.oeclass
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+# Global class to make it easier to maintain XFCE packages
+
+HOMEPAGE="http://www.xfce.org"
+LICENSE="LGPL-2"
+
+SRC_URI="http://www.us.xfce.org/archive/xfce-${PV}/src/${PN}-${PV}.tar.gz"
+
+# Most, but not *all* packages use pkgconfig, so we can't include it here
+# too
+
+inherit autotools
+
+EXTRA_OECONF += "--with-pluginsdir=${libdir}/xfce4/panel-plugins/"
+
+# FIXME: Put icons in their own package too?
+
+PACKAGES += "${PN}-mcs-plugins ${PN}-panel-plugins"
+
+FILES_${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
+FILES_${PN}-panel-plugins += "${libdir}/xfce4/panel-plugins/*.so*"
+FILES_${PN}-doc += " ${datadir}/xfce4/doc"
+FILES_${PN}-mcs-plugins="${libdir}/xfce4/mcs-plugins/*.so"