aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-10-15 10:56:42 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-10-15 21:41:43 +0200
commitaa03004ace2fabb135a6208ef8c2d2b312aa7b0b (patch)
tree422c1d0883e7a5b9fd5ac111f39baf22aceb31a3 /conf
parentf629930ce8c8e4950e46af9bae5b911ca150e7c7 (diff)
downloadopenembedded-aa03004ace2fabb135a6208ef8c2d2b312aa7b0b.tar.gz
[PR] Change PR to FILE_PR and intro PR as FILE_PR + DISTRO_PR
Allow a distribution to globally bump the PR of every package this is useful when there was a change in the toolchain and every package is going to be different. find packages/ \( -name '*.bb' -or -name '*.inc' \) -exec sed -i s/"^PR="/"FILE_PR ="/ {} \; find packages/ \( -name '*.bb' -or -name '*.inc' \) -exec sed -i s/"^PR ="/"FILE_PR ="/ {} \; Acked-By: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'conf')
-rw-r--r--conf/bitbake.conf9
1 files changed, 7 insertions, 2 deletions
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index 8fd24c637c..a655fcb24c 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -133,16 +133,21 @@ ASSUME_PROVIDED = "\
##################################################################
# Package default variables.
##################################################################
-
PN = "${@bb.parse.BBHandler.vars_from_file(bb.data.getVar('FILE',d),d)[0] or 'defaultpkgname'}"
PV = "${@bb.parse.BBHandler.vars_from_file(bb.data.getVar('FILE',d),d)[1] or '1.0'}"
-PR = "${@bb.parse.BBHandler.vars_from_file(bb.data.getVar('FILE',d),d)[2] or 'r0'}"
+FILE_PR = "${@bb.parse.BBHandler.vars_from_file(bb.data.getVar('FILE',d),d)[2] or 'r0'}"
+PR = "${FILE_PR}${DISTRO_PR}"
PF = "${PN}-${EXTENDPE}${PV}-${PR}"
EXTENDPE = "${@['','${PE\x7d_'][bb.data.getVar('PE',d,1) > 0]}"
EXTENDPEVER = "${@['','${PE\x7d:'][bb.data.getVar('PE',d,1) > 0]}"
DEBPV = "${EXTENDPEVER}${PV}-${PR}"
P = "${PN}-${PV}"
+##################################################################
+# Distro default
+##################################################################
+DISTRO_PR ?= ""
+
# Package info.
SECTION = "base"