aboutsummaryrefslogtreecommitdiffstats
path: root/conf
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-08-03 23:14:59 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-03 23:14:59 +0000
commit380db973435bedaa512df8e5fd62bcaf4e2d4459 (patch)
treefb6322178ceec7a816baa3f417484b34080af8fb /conf
parentfaa3ea865bbec5433bcc950fae04d7554de7ba33 (diff)
downloadopenembedded-380db973435bedaa512df8e5fd62bcaf4e2d4459.tar.gz
Make netpbm work by removing the use of built in sin and cos (not supported
by uclibc).
Diffstat (limited to 'conf')
-rw-r--r--conf/distro/ucslugc-packages.conf9
-rw-r--r--conf/distro/ucslugc.conf2
-rw-r--r--conf/machine/nslu2.conf4
3 files changed, 11 insertions, 4 deletions
diff --git a/conf/distro/ucslugc-packages.conf b/conf/distro/ucslugc-packages.conf
index c6575241ba..013a0b031b 100644
--- a/conf/distro/ucslugc-packages.conf
+++ b/conf/distro/ucslugc-packages.conf
@@ -1,5 +1,4 @@
-# automatically generated by bitbake freeze
-# hacked by the addition of UCSLUG_EXTRA_BBFILES at the end
+# hand editted from bitbake freeze output
BBFILES := "\
${PKGDIR}/packages/atftp/*.bb \
${PKGDIR}/packages/autoconf/*.bb \
@@ -62,6 +61,8 @@ ${PKGDIR}/packages/libiconv/*.bb \
${PKGDIR}/packages/libid3tag/*.bb \
${PKGDIR}/packages/libogg/*.bb \
${PKGDIR}/packages/libpcap/*.bb \
+${PKGDIR}/packages/libpng/*.bb \
+${PKGDIR}/packages/libtiff/*.bb \
${PKGDIR}/packages/libtool/*.bb \
${PKGDIR}/packages/libusb/*.bb \
${PKGDIR}/packages/libvorbis/*.bb \
@@ -90,6 +91,7 @@ ${PKGDIR}/packages/nano/*.bb \
${PKGDIR}/packages/ncftp/*.bb \
${PKGDIR}/packages/ncurses/*.bb \
${PKGDIR}/packages/netbase/*.bb \
+${PKGDIR}/packages/netpbm/*.bb \
${PKGDIR}/packages/nslu2-binary-only/*.bb \
${PKGDIR}/packages/ntp/*.bb \
${PKGDIR}/packages/obexftp/*.bb \
@@ -106,6 +108,7 @@ ${PKGDIR}/packages/patcher/*.bb \
${PKGDIR}/packages/pciutils/*.bb \
${PKGDIR}/packages/pcmcia-cs/*.bb \
${PKGDIR}/packages/pcre/*.bb \
+${PKGDIR}/packages/perl/*.bb \
${PKGDIR}/packages/pkgconfig/*.bb \
${PKGDIR}/packages/popt/*.bb \
${PKGDIR}/packages/portmap/*.bb \
@@ -142,4 +145,4 @@ ${PKGDIR}/packages/util-linux/*.bb \
${PKGDIR}/packages/vlan/*.bb \
${PKGDIR}/packages/wget/*.bb \
${PKGDIR}/packages/zlib/*.bb \
-${OPENSLUG_UCSLUGC_BBFILES}"
+${UCSLUGC_EXTRA_BBFILES}"
diff --git a/conf/distro/ucslugc.conf b/conf/distro/ucslugc.conf
index 34bc39a3a3..c321f18009 100644
--- a/conf/distro/ucslugc.conf
+++ b/conf/distro/ucslugc.conf
@@ -24,7 +24,7 @@ OVERRIDES = "local:${MACHINE}:${DISTRO}:openslug:${TARGET_OS}:${TARGET_ARCH}:bui
# NOTE: to build new packages set UCSLUGC_EXTRA_BBFILES to the full path name to
# the .bb files for the packages to build - see ucslugc-packages.conf in this
# directory
-OPENSLUG_UCSLUGC_BBFILES ?= ""
+UCSLUGC_EXTRA_BBFILES ?= ""
# pull in the frozen list of bbfiles - this sets BBFILES and this will override any
# setting in local.conf
diff --git a/conf/machine/nslu2.conf b/conf/machine/nslu2.conf
index 3beac45143..83849396b2 100644
--- a/conf/machine/nslu2.conf
+++ b/conf/machine/nslu2.conf
@@ -27,6 +27,10 @@ PACKAGE_ARCH = "armeb"
# values are.)
FULL_OPTIMIZATION = "-fomit-frame-pointer -frename-registers -fweb -funit-at-a-time -Os"
+# uClibc does not include sinf or cosf, so the gcc auto-use of
+# these functions must be disabled (this only occurs with -O)
+FULL_OPTIMIZATION_append_linux-uclibc = " -fno-builtin-sin -fno-builtin-cos"
+
SERIAL_CONSOLE = "115200 ttyS0"
KERNEL_CONSOLE = "ttyS0,115200n8"
USE_VT = "0"