aboutsummaryrefslogtreecommitdiffstats
path: root/contrib
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2010-12-16 21:48:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-10 18:00:13 +0100
commitb329bb24204c59f4f9c156f9942f5a876bdad136 (patch)
tree0ac57cf8b4d1bb738707abb3f6d92a30887d4eec /contrib
parent48d527cd249636f34497612ef06e9d1e04f3cab1 (diff)
downloadopenembedded-b329bb24204c59f4f9c156f9942f5a876bdad136.tar.gz
xorg: upgrade to X11R7.6 and remove preferred-xorg-versions*.inc files
* X11R7.6-RC1 was already released http://www.x.org/releases/X11R7.6-RC1/doc/xorg-docs/ReleaseNotes.html so it's IMHO time to start migration there * preferred-xorg-versions-live.inc was tracking latest stable released tarballs, but only reason I was maintaining it was to overwrite older preferred-xorg-versions-X11R7.5.inc if your distribution included ie X11R7.5.inc and you wanted live.inc from local.conf * default recipe versions without any preferred-xorg-versions include are now the same as live.inc * we will get better test coverage if we use same versions * if someone really needs older release then pinning only core stuff like xserver/libx11 will be probably better, than pinning every xorg app/proto/font etc. * I can slow down adding newest xorg stuff or ie keep it everytime for at least a week on ML for another review and test on more targets (I'm testing it only on om-gta02/spitz/nokia900) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Ackey-by: Tom Rini <tom_rini@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'contrib')
-rwxr-xr-xcontrib/source-checker/bump.preferred-xorg-versions-7.5.sh7
-rwxr-xr-xcontrib/source-checker/bump.preferred-xorg-versions-live.sh25
2 files changed, 0 insertions, 32 deletions
diff --git a/contrib/source-checker/bump.preferred-xorg-versions-7.5.sh b/contrib/source-checker/bump.preferred-xorg-versions-7.5.sh
index 07fa914ee2..a7be100a33 100755
--- a/contrib/source-checker/bump.preferred-xorg-versions-7.5.sh
+++ b/contrib/source-checker/bump.preferred-xorg-versions-7.5.sh
@@ -5,7 +5,6 @@ DIR=${SCRDIR}/${DATE}
PREFIX=http://www.x.org/releases/X11R7.5/src/
GRPS="app data doc driver font lib proto util xserver"
OETREE=${SCRDIR}/../..
-PREFS_LIVE=${OETREE}/conf/distro/include/preferred-xorg-versions-X11R7.5-live.inc
BBS=${OETREE}/recipes/xorg-
OUT_LOG=${DIR}.log
OUT_CMD=${DIR}.cmd
@@ -30,9 +29,6 @@ function updateVersions {
VER=$3
BB_VER=`ls -1 ${BBS}${GRP}/${PKG}_*.bb 2>/dev/null | sed "s%${BBS}${GRP}/${PKG}_%%g; s%.bb$%%g" | grep -v X11R7.0 | grep -v cvs | grep -v git | grep -v svn | sort -V | tail -n 1`
#echo ${GRP}/${PKG}/${VER} ${PREF_VER} ${BB_VER}
- if ls -1 ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ; then
- echo "PREFERRED_VERSION_${PKG} ?= \"${VER}\"" >> ${PREFS_LIVE}
- fi
if [[ -n ${BB_VER} && ${BB_VER} != ${VER} ]] ; then
echo "bump: $GRP ${PKG} ${BB_VER} -> ${VER}" | tee -a ${OUT_LOG}
echo "cp ${BBS}${GRP}/${PKG}_${BB_VER}.bb ${BBS}${GRP}/${PKG}_${VER}.bb" >> ${OUT_CMD}
@@ -53,14 +49,11 @@ done
sort -u ${DIR}/latest.txt > ${DIR}/latest.sort.txt
-echo "#`date`" > ${PREFS_LIVE}
-
echo "#`date`" > ${OUT_LOG}
echo "#`date`" > ${OUT_CMD}
cat ${DIR}/latest.txt | while read LINE; do
if [[ ${LINE} =~ \#.* ]]; then
- echo ${LINE} >> ${PREFS_LIVE}
continue
fi
#echo ${LINE};
diff --git a/contrib/source-checker/bump.preferred-xorg-versions-live.sh b/contrib/source-checker/bump.preferred-xorg-versions-live.sh
index 49bce219d0..eb1afbf3ca 100755
--- a/contrib/source-checker/bump.preferred-xorg-versions-live.sh
+++ b/contrib/source-checker/bump.preferred-xorg-versions-live.sh
@@ -5,7 +5,6 @@ DIR=${SCRDIR}/${DATE}
PREFIX=http://xorg.freedesktop.org/releases/individual/
GRPS="app data doc driver font lib proto util xserver"
OETREE=${SCRDIR}/../..
-PREFS_LIVE=${OETREE}/conf/distro/include/preferred-xorg-versions-live.inc
BBS=${OETREE}/recipes/xorg-
OUT_LOG=${DIR}.log
OUT_CMD=${DIR}.cmd
@@ -30,27 +29,6 @@ function updateVersions {
VER=$3
BB_VER=`ls -1 ${BBS}${GRP}/${PKG}_*.bb 2>/dev/null | sed "s%${BBS}${GRP}/${PKG}_%%g; s%.bb$%%g" | grep -v X11R7.0 | grep -v cvs | grep -v git | grep -v svn | sort -V | tail -n 1`
#echo ${GRP}/${PKG}/${VER} ${PREF_VER} ${BB_VER}
- if ls -1 ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ; then
- echo "PREFERRED_VERSION_${PKG} ?= \"${VER}\"" >> ${PREFS_LIVE}
- fi
- if [[ ${GRP} == "proto" ]] ||
- ls -1 ${BBS}${GRP}/${PKG}-native_*.bb >/dev/null 2>/dev/null ||
- grep "BBCLASSEXTEND.*native[ \"]" ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ||
- grep "BBCLASSEXTEND.*native[ \"]" ${BBS}${GRP}/${PKG}.inc >/dev/null 2>/dev/null ; then
- echo "PREFERRED_VERSION_${PKG}-native ?= \"${VER}\"" >> ${PREFS_LIVE}
- fi
- if [[ ${GRP} == "proto" ]] ||
- ls -1 ${BBS}${GRP}/${PKG}-nativesdk_*.bb >/dev/null 2>/dev/null ||
- grep "BBCLASSEXTEND.*nativesdk" ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ||
- grep "BBCLASSEXTEND.*nativesdk" ${BBS}${GRP}/${PKG}.inc >/dev/null 2>/dev/null ; then
- echo "PREFERRED_VERSION_${PKG}-nativesdk ?= \"${VER}\"" >> ${PREFS_LIVE}
- fi
- if [[ ${GRP} == "proto" ]] ||
- ls -1 ${BBS}${GRP}/${PKG}-sdk_*.bb >/dev/null 2>/dev/null ||
- grep "BBCLASSEXTEND.*[ \"]sdk" ${BBS}${GRP}/${PKG}_*.bb >/dev/null 2>/dev/null ||
- grep "BBCLASSEXTEND.*[ \"]sdk" ${BBS}${GRP}/${PKG}.inc >/dev/null 2>/dev/null ; then
- echo "PREFERRED_VERSION_${PKG}-sdk ?= \"${VER}\"" >> ${PREFS_LIVE}
- fi
if [[ -n ${BB_VER} && ${BB_VER} != ${VER} ]] ; then
echo "bump: $GRP ${PKG} ${BB_VER} -> ${VER}" | tee -a ${OUT_LOG}
echo "cp ${BBS}${GRP}/${PKG}_${BB_VER}.bb ${BBS}${GRP}/${PKG}_${VER}.bb" >> ${OUT_CMD}
@@ -71,14 +49,11 @@ done
sort -u ${DIR}/latest.txt > ${DIR}/latest.sort.txt
-echo "#`date`" > ${PREFS_LIVE}
-
echo "#`date`" > ${OUT_LOG}
echo "#`date`" > ${OUT_CMD}
cat ${DIR}/latest.txt | while read LINE; do
if [[ ${LINE} =~ \#.* ]]; then
- echo ${LINE} >> ${PREFS_LIVE}
continue
fi
#echo ${LINE};