aboutsummaryrefslogtreecommitdiffstats
path: root/glib-2.0
diff options
context:
space:
mode:
authoropenembedded@(none) <openembedded@(none)>2004-12-09 07:33:46 +0000
committeropenembedded@(none) <openembedded@(none)>2004-12-09 07:33:46 +0000
commitab0c911319b8197f06806d13b558869be38aedc0 (patch)
tree59c0fa6ff60b4945811136d04a456975a4787155 /glib-2.0
parentca41b2f07257d46792b1145d29a2fdf9b965dcaa (diff)
downloadopenembedded-ab0c911319b8197f06806d13b558869be38aedc0.tar.gz
glib-2_2.4.6 Added the "Old Headers found" patch that some systems complain about
BKrev: 41b7ffdaM90STkWzlY1CPzReij3wKQ
Diffstat (limited to 'glib-2.0')
-rw-r--r--glib-2.0/files/glibinclude.patch0
-rw-r--r--glib-2.0/glib-2.0_2.4.6.bb49
2 files changed, 49 insertions, 0 deletions
diff --git a/glib-2.0/files/glibinclude.patch b/glib-2.0/files/glibinclude.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/glib-2.0/files/glibinclude.patch
diff --git a/glib-2.0/glib-2.0_2.4.6.bb b/glib-2.0/glib-2.0_2.4.6.bb
index e69de29bb2..a80dd1fac5 100644
--- a/glib-2.0/glib-2.0_2.4.6.bb
+++ b/glib-2.0/glib-2.0_2.4.6.bb
@@ -0,0 +1,49 @@
+PR = "r1"
+DESCRIPTION = "GLib is a general-purpose utility library, \
+which provides many useful data types, macros, \
+type conversions, string utilities, file utilities, a main \
+loop abstraction, and so on. It works on many \
+UNIX-like platforms, Windows, OS/2 and BeOS."
+LICENSE = "GPLv2"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+DEPENDS += "glib-2.0-native gtk-doc"
+DEPENDS += "virtual/libiconv virtual/libintl"
+PACKAGES =+ "glib-2.0-utils "
+
+LEAD_SONAME = "libglib-2.0.*"
+FILES_glib-2.0-utils = "${bindir}/*"
+
+EXTRA_OECONF = "--disable-debug"
+
+SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.4/glib-${PV}.tar.bz2 \
+ file://glibinclude.patch;patch=1;pnum=2 \
+ file://glibconfig-sysdefs.h"
+
+S = "${WORKDIR}/glib-${PV}"
+
+inherit autotools pkgconfig gettext
+
+python () {
+ if bb.data.getVar("USE_NLS", d, 1) == "no":
+ raise bb.parse.SkipPackage("${PN} requires native language support.")
+}
+
+acpaths = ""
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
+}
+
+do_stage () {
+ oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
+ autotools_stage_includes
+ install -d ${STAGING_INCDIR}/glib-2.0/glib
+ install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
+ install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
+}