aboutsummaryrefslogtreecommitdiffstats
path: root/glib-2.0
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /glib-2.0
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
downloadopenembedded-f96441b9faf769c9ecdd4d338b605ea3d0cc4010.tar.gz
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'glib-2.0')
-rw-r--r--glib-2.0/files/glibconfig-sysdefs.h6
-rw-r--r--glib-2.0/files/gtk-doc.patch59
-rw-r--r--glib-2.0/glib-2.0-2.2.3/automake-lossage.patch43
-rw-r--r--glib-2.0/glib-2.0-2.2.3/configure.patch174
-rw-r--r--glib-2.0/glib-2.0-2.2.3/glibconfig-sysdefs.h6
5 files changed, 288 insertions, 0 deletions
diff --git a/glib-2.0/files/glibconfig-sysdefs.h b/glib-2.0/files/glibconfig-sysdefs.h
index e69de29bb2..1329e7f21c 100644
--- a/glib-2.0/files/glibconfig-sysdefs.h
+++ b/glib-2.0/files/glibconfig-sysdefs.h
@@ -0,0 +1,6 @@
+#define GLIB_SYSDEF_POLLIN =1
+#define GLIB_SYSDEF_POLLOUT =4
+#define GLIB_SYSDEF_POLLPRI =2
+#define GLIB_SYSDEF_POLLERR =8
+#define GLIB_SYSDEF_POLLHUP =16
+#define GLIB_SYSDEF_POLLNVAL =32
diff --git a/glib-2.0/files/gtk-doc.patch b/glib-2.0/files/gtk-doc.patch
index e69de29bb2..4b9c234e21 100644
--- a/glib-2.0/files/gtk-doc.patch
+++ b/glib-2.0/files/gtk-doc.patch
@@ -0,0 +1,59 @@
+--- glib/acinclude.m4 2004-05-08 11:14:46.000000000 +0100
++++ glib/acinclude.m4 2004-05-08 11:14:55.000000000 +0100
+@@ -446,3 +446,56 @@
+ ])
+
+
++dnl -*- mode: autoconf -*-
++
++# serial 1
++
++dnl Usage:
++dnl GTK_DOC_CHECK([minimum-gtk-doc-version])
++AC_DEFUN([GTK_DOC_CHECK],
++[
++ AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
++ AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
++ dnl for overriding the documentation installation directory
++ AC_ARG_WITH(html-dir,
++ AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),,
++ [with_html_dir='${datadir}/gtk-doc/html'])
++ HTML_DIR="$with_html_dir"
++ AC_SUBST(HTML_DIR)
++
++ dnl enable/disable documentation building
++ AC_ARG_ENABLE(gtk-doc,
++ AC_HELP_STRING([--enable-gtk-doc],
++ [use gtk-doc to build documentation [default=no]]),,
++ enable_gtk_doc=no)
++
++ have_gtk_doc=no
++ if test -z "$PKG_CONFIG"; then
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++ fi
++ if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then
++ have_gtk_doc=yes
++ fi
++
++ dnl do we want to do a version check?
++ifelse([$1],[],,
++ [gtk_doc_min_version=$1
++ if test "$have_gtk_doc" = yes; then
++ AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version])
++ if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then
++ AC_MSG_RESULT(yes)
++ else
++ AC_MSG_RESULT(no)
++ have_gtk_doc=no
++ fi
++ fi
++])
++ if test x$enable_gtk_doc = xyes; then
++ if test "$have_gtk_doc" != yes; then
++ enable_gtk_doc=no
++ fi
++ fi
++
++ AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
++ AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL")
++])
diff --git a/glib-2.0/glib-2.0-2.2.3/automake-lossage.patch b/glib-2.0/glib-2.0-2.2.3/automake-lossage.patch
index e69de29bb2..02e9b5f25e 100644
--- a/glib-2.0/glib-2.0-2.2.3/automake-lossage.patch
+++ b/glib-2.0/glib-2.0-2.2.3/automake-lossage.patch
@@ -0,0 +1,43 @@
+--- glib-2.2.3/gobject/Makefile.am.old 2004-03-06 20:48:33.000000000 +0000
++++ glib-2.2.3/gobject/Makefile.am 2004-03-06 20:50:58.000000000 +0000
+@@ -87,7 +87,7 @@
+ gobject_private_h_sources = @STRIP_BEGIN@ \
+ @STRIP_END@
+ # GObject library C sources to build the library from
+-gobject_c_sources = @STRIP_BEGIN@ \
++gobject_c_sources = \
+ gboxed.c \
+ gclosure.c \
+ genums.c \
+@@ -102,8 +102,7 @@
+ gvalue.c \
+ gvaluearray.c \
+ gvaluetransform.c \
+- gvaluetypes.c \
+-@STRIP_END@
++ gvaluetypes.c
+
+ # we use our own built_sources variable rules to avoid automake's
+ # BUILT_SOURCES oddities
+@@ -135,9 +134,9 @@
+ #
+ gobject_target_headers = $(gobject_public_h_sources) $(gobject_built_public_sources)
+ gobject_target_sources = $(gobject_c_sources)
+-MAINTAINERCLEANFILES += $(gobject_built_sources)
+-EXTRA_HEADERS +=
+-EXTRA_DIST += $(gobject_private_h_sources) $(gobject_extra_sources)
++MAINTAINERCLEANFILES = $(gobject_built_sources)
++EXTRA_HEADERS =
++EXTRA_DIST = $(gobject_private_h_sources) $(gobject_extra_sources)
+ EXTRA_DIST += $(gobject_built_sources)
+
+ #
+@@ -145,7 +144,7 @@
+ #
+ # setup autogeneration dependancies
+ gen_sources = xgen-gmh xgen-gmc xgen-gms
+-CLEANFILES += $(gen_sources)
++CLEANFILES = $(gen_sources)
+
+ $(libgobject_2_0_la_OBJECTS): $(gobject_built_sources) ${gobject_built_public_sources} # this is our oldest file, used for implicit auto-generation deps
+ # initial creation of the real stamp-* files
diff --git a/glib-2.0/glib-2.0-2.2.3/configure.patch b/glib-2.0/glib-2.0-2.2.3/configure.patch
index e69de29bb2..f6a04e34c5 100644
--- a/glib-2.0/glib-2.0-2.2.3/configure.patch
+++ b/glib-2.0/glib-2.0-2.2.3/configure.patch
@@ -0,0 +1,174 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- glib-2.1.3/configure.in~configure
++++ glib-2.1.3/configure.in
+@@ -15,7 +15,9 @@
+ cflags_set=${CFLAGS+set}
+
+ # we rewrite this file
++if "x$cross_compiling" != xyes; then
+ rm -f glibconfig-sysdefs.h
++fi
+
+ GLIB_AC_DIVERT_BEFORE_HELP([
+ #
+@@ -402,10 +404,13 @@
+ fi
+ fi
+
++AC_CHECK_LIBM
++LIBS="$LIBS $LIBM"
++
+ dnl DU4 native cc currently needs -std1 for ANSI mode (instead of K&R)
+ AC_MSG_CHECKING([for extra flags to get ANSI library prototypes])
+ glib_save_LIBS=$LIBS
+-LIBS="$LIBS -lm"
++#LIBS="$LIBS -lm"
+ AC_TRY_RUN([#include <math.h>
+ int main (void) { return (log(1) != log(1.)); }],
+ AC_MSG_RESULT(none needed),
+@@ -417,8 +422,10 @@
+ AC_MSG_RESULT()
+ CFLAGS=$glib_save_CFLAGS
+ AC_MSG_WARN(
+- [No ANSI prototypes found in library. (-std1 didn't work.)])
+- )
++ [No ANSI prototypes found in library. (-std1 didn't work.)]),
++ AC_MSG_RESULT()
++ ),
++ AC_MSG_RESULT([assuming none needed])
+ )
+ LIBS=$glib_save_LIBS
+
+@@ -844,18 +851,18 @@
+ dnl *** strlcpy/strlcat ***
+ dnl ****************************************
+ # Check for strlcpy
+-AC_MSG_CHECKING(for OpenBSD strlcpy/strlcat)
+-AC_TRY_RUN([
+-#include <string.h>
+-int main() {
+- char *p = malloc (10);
+- (void) strlcpy (p, "hi", 10);
+- if (strlcat (p, "bye", 0) != 3)
+- exit (1);
+- return 0;
+-}], glib_ok=yes, glib_ok=no)
+-AC_MSG_RESULT($glib_ok)
+-if test "$glib_ok" = "yes"; then
++AC_CACHE_CHECK([for OpenBSD strlcpy/strlcat],[glib_cv_strlcpy],
++ AC_TRY_RUN([
++ #include <string.h>
++ int main() {
++ char *p = malloc (10);
++ (void) strlcpy (p, "hi", 10);
++ if (strlcat (p, "bye", 0) != 3)
++ exit (1);
++ return 0;
++ }], glib_cv_strlcpy=yes, glib_cv_strlcpy=no)
++)
++if test "x$glib_cv_strlcpy" = xyes; then
+ AC_DEFINE(HAVE_STRLCPY,1,[Have functions strlcpy and strlcat])
+ fi
+
+@@ -1302,16 +1309,15 @@
+ for flag in pthread pthreads; do
+ glib_save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS -$flag"
+- AC_TRY_RUN([#include <pthread.h>
++ AC_TRY_LINK([#include <pthread.h>],[
+ int check_me = 0;
+ void* func(void* data) {return check_me = 42;}
+- main()
+- { pthread_t t;
++ pthread_t t;
+ void *ret;
+ pthread_create (&t, 0, func, 0);
+ pthread_join (t, &ret);
+ exit (check_me != 42 || ret != 42);
+- }],
++ ],
+ [G_THREAD_CFLAGS=-$flag
+ G_THREAD_LIBS=-$flag])
+ CFLAGS="$glib_save_CFLAGS"
+@@ -1431,16 +1437,15 @@
+ LIBS="$glib_save_LIBS $add_thread_lib"
+
+ AC_MSG_CHECKING(for pthread_create/pthread_join$IN)
+- AC_TRY_RUN([#include <pthread.h>
++ AC_TRY_LINK([#include <pthread.h>],[
+ int check_me = 0;
+ void* func(void* data) {check_me = 42;}
+- main()
+- { pthread_t t;
++ pthread_t t;
+ void *ret;
+ pthread_create (&t, $defattr, func, 0);
+ pthread_join (t, &ret);
+ exit (check_me != 42);
+- }],
++ ],
+ [AC_MSG_RESULT(yes)
+ G_THREAD_LIBS="$add_thread_lib"
+ break],
+@@ -1466,12 +1471,11 @@
+ LIBS="$glib_save_LIBS $add_thread_lib"
+
+ AC_MSG_CHECKING(for sched_get_priority_min$IN)
+- AC_TRY_RUN([#include <sched.h>
+- #include <errno.h>
+- int main() {
++ AC_TRY_LINK([#include <sched.h>
++ #include <errno.h>],[
+ errno = 0;
+ return sched_get_priority_min(SCHED_OTHER)==-1
+- && errno != 0;}],
++ && errno != 0;],
+ [AC_MSG_RESULT(yes)
+ G_THREAD_LIBS="$G_THREAD_LIBS $add_thread_lib"
+ posix_priority_min="sched_get_priority_min(SCHED_OTHER)"
+@@ -1636,7 +1640,8 @@
+ AC_DEFINE_UNQUOTED(POSIX_YIELD_FUNC,$posix_yield_func,[The POSIX RT yield function])
+ CPPFLAGS="$glib_save_CPPFLAGS"
+
+- AC_MSG_CHECKING(whether to use the PID niceness surrogate for thread priorities)
++ AC_CACHE_CHECK([whether to use the PID niceness surrogate for thread priorities],
++ [glib_cv_sys_use_pid_niceness_surrogate],
+ AC_TRY_RUN([#include <pthread.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+@@ -1651,10 +1656,12 @@
+ exit (getpid()==other_pid ||
+ $posix_priority_min != $posix_priority_max);
+ }],
+- [AC_MSG_RESULT(yes)
+- AC_DEFINE(G_THREAD_USE_PID_SURROGATE, 1, [whether to use the PID niceness surrogate for thread priorities])
+- ],
+- [AC_MSG_RESULT(no)])
++ [ glib_cv_sys_use_pid_niceness_surrogate=yes ],
++ [ glib_cv_sys_use_pid_niceness_surrogate=no ])
++ )
++ if test x"$glib_cv_sys_use_pid_niceness_surrogate" = xyes; then
++ AC_DEFINE(G_THREAD_USE_PID_SURROGATE, 1, [whether to use the PID niceness surrogate for thread priorities])
++ fi
+ elif test x"$have_threads" = xwin32; then
+ # It's a pointer to a private struct
+ GLIB_SIZEOF(,struct _GThreadData *, system_thread)
+@@ -1717,12 +1724,14 @@
+ dnl ****************************************
+ dnl *** GLib POLL* compatibility defines ***
+ dnl ****************************************
++if test x"$cross_compiling" != xyes; then
+ GLIB_SYSDEFS(
+ [#include <sys/types.h>
+ #include <sys/poll.h>],
+ POLLIN:1 POLLOUT:4 POLLPRI:2 POLLERR:8 POLLHUP:16 POLLNVAL:32,
+ glibconfig-sysdefs.h,
+ =)
++fi
+
+ dnl **********************
+ dnl *** Win32 API libs ***
diff --git a/glib-2.0/glib-2.0-2.2.3/glibconfig-sysdefs.h b/glib-2.0/glib-2.0-2.2.3/glibconfig-sysdefs.h
index e69de29bb2..1329e7f21c 100644
--- a/glib-2.0/glib-2.0-2.2.3/glibconfig-sysdefs.h
+++ b/glib-2.0/glib-2.0-2.2.3/glibconfig-sysdefs.h
@@ -0,0 +1,6 @@
+#define GLIB_SYSDEF_POLLIN =1
+#define GLIB_SYSDEF_POLLOUT =4
+#define GLIB_SYSDEF_POLLPRI =2
+#define GLIB_SYSDEF_POLLERR =8
+#define GLIB_SYSDEF_POLLHUP =16
+#define GLIB_SYSDEF_POLLNVAL =32