aboutsummaryrefslogtreecommitdiffstats
path: root/guile
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-06-04 17:49:42 +0000
committerChris Larson <clarson@kergoth.com>2004-06-04 17:49:42 +0000
commitc742b3485b64edbd7d1ad41773f8029fe8681e44 (patch)
treee24ca5b2d416f710ae9694bb540228881597726b /guile
parent493b10222886a1d47ea2a055f259f56f6edb818c (diff)
downloadopenembedded-c742b3485b64edbd7d1ad41773f8029fe8681e44.tar.gz
Fix -p value for configure patch in guile, and add a call to AC_CONFIG_AUX_DIR
to remove the necessity of the manual libtoolize calls. BKrev: 40c0b636lUIRIa8nmOxYRs7Ma5yWww
Diffstat (limited to 'guile')
-rw-r--r--guile/configure-lossage.patch28
-rw-r--r--guile/guile_1.6.4.oe5
2 files changed, 28 insertions, 5 deletions
diff --git a/guile/configure-lossage.patch b/guile/configure-lossage.patch
index e69de29bb2..da1d0de6e7 100644
--- a/guile/configure-lossage.patch
+++ b/guile/configure-lossage.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- guile-1.6.4/configure.in~configure-lossage
++++ guile-1.6.4/configure.in
+@@ -462,7 +462,9 @@
+ # explicitly to LIBOBJS to make sure that it is translated to
+ # `alloca.lo' for libtool later on. This can and should be done more cleanly.
+ AC_FUNC_ALLOCA
+-if test "$ALLOCA" = "alloca.o"; then AC_LIBOBJ([alloca]); fi
++if test "$ALLOCA" = "alloca.o"; then
++ AC_LIBOBJ([alloca])
++fi
+
+ AC_CHECK_MEMBERS([struct stat.st_rdev])
+ AC_CHECK_MEMBERS([struct stat.st_blksize])
+--- guile-1.6.4/guile-readline/configure.in~configure-lossage
++++ guile-1.6.4/guile-readline/configure.in
+@@ -2,6 +2,7 @@
+
+ AC_INIT
+ AC_CONFIG_SRCDIR([readline.c])
++AC_CONFIG_AUX_DIR([..])
+ . $srcdir/../GUILE-VERSION
+ PACKAGE=guile-readline
+ AM_INIT_AUTOMAKE($PACKAGE, $VERSION, no-define)
diff --git a/guile/guile_1.6.4.oe b/guile/guile_1.6.4.oe
index f0c66adf2b..ef2024124c 100644
--- a/guile/guile_1.6.4.oe
+++ b/guile/guile_1.6.4.oe
@@ -7,11 +7,6 @@ inherit autotools
acpaths = "-I ${S}/guile-config"
-do_configure_prepend() {
- libtoolize --force
- (cd guile-readline; libtoolize --force)
-}
-
do_compile() {
(cd libguile; oe_runmake CC="${BUILD_CC}" CFLAGS="${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}" guile_filter_doc_snarfage)
oe_runmake preinstguile="`which guile`"