aboutsummaryrefslogtreecommitdiffstats
path: root/libetpan
diff options
context:
space:
mode:
authorral@home <ral@home>2004-07-22 13:23:06 +0000
committerral@home <ral@home>2004-07-22 13:23:06 +0000
commit73551bb73d6a816e7d0b2e8765c7ab80765355cd (patch)
tree956f25b6f16d9db723d33862b7e1cf09ddcfdb92 /libetpan
parentb257fbef63f206f8c8b0445d9bac49c03c7e6f31 (diff)
downloadopenembedded-73551bb73d6a816e7d0b2e8765c7ab80765355cd.tar.gz
step forward for libetpan
BKrev: 40ffbfba7ug5ZlL7K9VJoQWZn9widQ
Diffstat (limited to 'libetpan')
-rw-r--r--libetpan/libetpan-0.33pre/destdir.patch60
-rw-r--r--libetpan/libetpan-0.33pre/gcc34.patch16
-rw-r--r--libetpan/libetpan_0.33pre.oe13
3 files changed, 80 insertions, 9 deletions
diff --git a/libetpan/libetpan-0.33pre/destdir.patch b/libetpan/libetpan-0.33pre/destdir.patch
index e69de29bb2..c8cc60f709 100644
--- a/libetpan/libetpan-0.33pre/destdir.patch
+++ b/libetpan/libetpan-0.33pre/destdir.patch
@@ -0,0 +1,60 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/Rules.in~destdir 2004-05-23 18:44:44.000000000 +0200
++++ libetpan-0.33pre/Rules.in 2004-07-22 14:56:56.132455370 +0200
+@@ -3,6 +3,7 @@
+ # each submakefile should define SOURCES and TARGET
+ # optionnaly HEADRS and INCLUDES
+
++DESTDIR =
+ srcdir = $(top_builddir)/src
+ prefix = @prefix@
+ includedir = @includedir@/libetpan
+@@ -37,7 +38,7 @@
+ # install headers here only
+ install: $(HEADERS) install-recursive
+ for header in $(HEADERS); do \
+- $(INSTALL) -m 644 "$$header" $(includedir) ; \
++ $(INSTALL) -m 644 $$header $(DESTDIR)$(includedir)/libetpan ; \
+ done
+
+ Makefile: $(top_builddir)/Rules
+--- libetpan-0.33pre/Makefile.in~destdir 2004-05-23 18:44:44.000000000 +0200
++++ libetpan-0.33pre/Makefile.in 2004-07-22 14:59:17.321980703 +0200
+@@ -51,13 +51,13 @@
+ done && test -z "$$fail"
+
+ install: all install-dirs install-recursive
+- $(INSTALL) -m 755 libetpan-config $(bindir)
+- $(INSTALL) -m 644 libetpan-config.h $(includedir)/libetpan
++ $(INSTALL) -m 755 libetpan-config $(DESTDIR)$(bindir)
++ $(INSTALL) -m 644 libetpan-config.h $(DESTDIR)$(includedir)/libetpan
+
+ install-dirs:
+- $(INSTALL) -d -m 755 $(includedir)
+- $(INSTALL) -d -m 755 $(includedir)/libetpan
+- $(INSTALL) -d -m 755 $(bindir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(includedir)/libetpan
++ $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
+
+ #realclean: maintainer-clean
+
+--- libetpan-0.33pre/src/Makefile.in~destdir 2004-05-02 18:16:58.000000000 +0200
++++ libetpan-0.33pre/src/Makefile.in 2004-07-22 15:04:02.581981625 +0200
+@@ -38,10 +38,10 @@
+ $(SUBLIBS): all-recursive
+
+ install: all install-dirs install-recursive
+- $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(TARGET) $(libdir)
++ $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(TARGET) $(DESTDIR)$(libdir)
+
+ install-dirs:
+- $(INSTALL) -d -m 755 $(libdir)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(libdir)
+
+ clean: clean-recursive
+ rm $(TARGET)
diff --git a/libetpan/libetpan-0.33pre/gcc34.patch b/libetpan/libetpan-0.33pre/gcc34.patch
index e69de29bb2..5420c2f6d1 100644
--- a/libetpan/libetpan-0.33pre/gcc34.patch
+++ b/libetpan/libetpan-0.33pre/gcc34.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan-0.33pre/src/driver/implementation/imap/imapdriver_cached_message.c~gcc34 2003-12-08 16:36:36.000000000 +0100
++++ libetpan-0.33pre/src/driver/implementation/imap/imapdriver_cached_message.c 2004-07-22 14:49:02.459902029 +0200
+@@ -212,7 +212,7 @@
+ mmap_string_free(gstr);
+ free_section:
+ mailmime_section_free(part);
+- err:
++ err:;
+ }
+
+ static void generate_key_from_section(char * key, size_t size,
diff --git a/libetpan/libetpan_0.33pre.oe b/libetpan/libetpan_0.33pre.oe
index fed69afe9d..540e4e8eac 100644
--- a/libetpan/libetpan_0.33pre.oe
+++ b/libetpan/libetpan_0.33pre.oe
@@ -1,19 +1,14 @@
DESCRIPTION = "libetpan is a library for mail server functions"
SECTION = "libs"
DEPENDS = "openssl"
-PR = "r2"
+PR = "r3"
FILES_${PN} = "${libdir}/lib*.so.*"
FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la \
${libdir}/*.a ${libdir}/pkgconfig"
-SRC_URI = "http://www.alwins-world.de/oe/libetpan-${PV}.tar.bz2 \
- file://mailstream_socket.patch;patch=1 \
- file://smtptls.patch;patch=1 \
- file://config_iconv.patch;patch=1 \
- file://includedir.patch;patch=1;pnum=0 \
- file://pkgconfig.patch;patch=1 \
- file://gcc34.patch;patch=1 \
- file://destdir.patch;patch=1"
+SRC_URI = "http://www.alwins-world.de/oe/libetpan-${PV}.tar.bz2 \
+ file://gcc34.patch;patch=1 \
+ file://destdir.patch;patch=1"
inherit autotools pkgconfig