aboutsummaryrefslogtreecommitdiffstats
path: root/libtool
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2003-10-01 23:57:55 +0000
committerChris Larson <clarson@kergoth.com>2003-10-01 23:57:55 +0000
commit2a3e9b7ea7af418b86fab665e94c2dcfede07b51 (patch)
tree088b1dee9b4487bb5424aedb58f5349c32c56107 /libtool
parentf0cce9a40b2f65e690ce6ae62de80abc532f29fc (diff)
downloadopenembedded-2a3e9b7ea7af418b86fab665e94c2dcfede07b51.tar.gz
Correct various builds, including expat and pcre.
BKrev: 3f7b6a03P_KMk2YlUkmMee_qcSllSA
Diffstat (limited to 'libtool')
-rw-r--r--libtool/libtool-1.4.3.oe38
-rw-r--r--libtool/libtool-1.5.oe35
-rw-r--r--libtool/libtool-1.5/tag.patch38
3 files changed, 111 insertions, 0 deletions
diff --git a/libtool/libtool-1.4.3.oe b/libtool/libtool-1.4.3.oe
index e69de29bb2..c3072dc29b 100644
--- a/libtool/libtool-1.4.3.oe
+++ b/libtool/libtool-1.4.3.oe
@@ -0,0 +1,38 @@
+PR = r0
+
+DESCRIPTION = Generic library support script\
+ This is GNU libtool, a generic library support script. Libtool hides\
+ the complexity of generating special library types (such as shared\
+ libraries) behind a consistent interface. To use libtool, add the\
+ new generic library building commands to your Makefile, Makefile.in,\
+ or Makefile.am. See the documentation for details. Libtool supports\
+ building static libraries on all platforms.\
+ Libtool supports generation of C, C++ and Java libraries.
+
+DEPENDS=
+
+SRC_URI = ${DEBIAN_MIRROR}/main/libt/${PN}/${PN}_${PV}.orig.tar.gz \
+ file://${FILESDIR}/debian.patch;patch=1 \
+ file://${FILESDIR}/libdir.patch;patch=1 \
+ file://${FILESDIR}/sedvar.patch;patch=1 \
+ file://${FILESDIR}/libtoolize-staging.patch;patch=1
+S = "${WORKDIR}/${P}"
+
+inherit autotools
+
+EXTRA_OECONF = --disable-ltdl-install
+do_configure_prepend () {
+ ./bootstrap
+}
+
+do_stage () {
+ install -d ${STAGING_DIR}/share/libtool \
+ ${STAGING_DIR}/share/aclocal
+ install -m 0755 libtool ${STAGING_BINDIR}/libtool
+ install -m 0755 libtoolize ${STAGING_BINDIR}/libtoolize
+ install -c config.guess ${STAGING_DIR}/share/libtool/
+ install -c config.sub ${STAGING_DIR}/share/libtool/
+ install -c -m 0644 ltmain.sh ${STAGING_DIR}/share/libtool/
+ install -c -m 0644 libtool.m4 ${STAGING_DIR}/share/aclocal/
+ install -c -m 0644 ltdl.m4 ${STAGING_DIR}/share/aclocal/
+}
diff --git a/libtool/libtool-1.5.oe b/libtool/libtool-1.5.oe
index e69de29bb2..47e286a12d 100644
--- a/libtool/libtool-1.5.oe
+++ b/libtool/libtool-1.5.oe
@@ -0,0 +1,35 @@
+DESCRIPTION = Generic library support script\
+ This is GNU libtool, a generic library support script. Libtool hides\
+ the complexity of generating special library types (such as shared\
+ libraries) behind a consistent interface. To use libtool, add the\
+ new generic library building commands to your Makefile, Makefile.in,\
+ or Makefile.am. See the documentation for details. Libtool supports\
+ building static libraries on all platforms.\
+ Libtool supports generation of C, C++ and Java libraries.
+
+SRC_URI = http://ftp.club.cc.cmu.edu/pub/gnu/libtool/libtool-1.5.tar.gz \
+ file://${FILESDIR}/libdir-la.patch;patch=1 \
+ file://${FILESDIR}/sedvar.patch;patch=1 \
+ file://${FILESDIR}/tag.patch;patch=1 \
+ file://${FILESDIR}/libtoolize-staging.patch;patch=1
+# file://${FILESDIR}/libdir-rpath.patch;patch=1
+S = "${WORKDIR}/${P}"
+
+inherit autotools
+
+EXTRA_OECONF = --disable-ltdl-install
+do_configure_prepend () {
+ ./bootstrap
+ rm -f ${S}/ltmain.sh
+}
+
+do_stage () {
+ install -d ${STAGING_DIR}/share/{libtool,aclocal}
+ install -m 0755 libtool ${STAGING_BINDIR}/libtool
+ install -m 0755 libtoolize ${STAGING_BINDIR}/libtoolize
+ install -c config.guess ${STAGING_DIR}/share/libtool/
+ install -c config.sub ${STAGING_DIR}/share/libtool/
+ install -c -m 0644 ltmain.sh ${STAGING_DIR}/share/libtool/
+ install -c -m 0644 libtool.m4 ${STAGING_DIR}/share/aclocal/
+ install -c -m 0644 ltdl.m4 ${STAGING_DIR}/share/aclocal/
+}
diff --git a/libtool/libtool-1.5/tag.patch b/libtool/libtool-1.5/tag.patch
index e69de29bb2..dc69088b59 100644
--- a/libtool/libtool-1.5/tag.patch
+++ b/libtool/libtool-1.5/tag.patch
@@ -0,0 +1,38 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libtool-1.5/ltmain.in~tag
++++ libtool-1.5/ltmain.in
+@@ -549,8 +549,9 @@
+ # line option must be used.
+ if test -z "$tagname"; then
+ $echo "$modename: unable to infer tagged configuration"
+- $echo "$modename: specify a tag with \`--tag'" 1>&2
+- exit 1
++ tagname=CC
++# $echo "$modename: specify a tag with \`--tag'" 1>&2
++# exit 1
+ # else
+ # $echo "$modename: using $tagname tagged configuration"
+ fi
+@@ -1651,13 +1652,13 @@
+ # If $tagname still isn't set, then no tagged configuration
+ # was found and let the user know that the "--tag" command
+ # line option must be used.
+- if test -z "$tagname"; then
+- $echo "$modename: unable to infer tagged configuration"
+- $echo "$modename: specify a tag with \`--tag'" 1>&2
+- exit 1
++# if test -z "$tagname"; then
++# $echo "$modename: unable to infer tagged configuration"
++# $echo "$modename: specify a tag with \`--tag'" 1>&2
++# exit 1
+ # else
+ # $echo "$modename: using $tagname tagged configuration"
+- fi
++# fi
+ ;;
+ esac
+ fi