aboutsummaryrefslogtreecommitdiffstats
path: root/linux/nslu2-linksys-2.4.22
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-09-23 16:59:52 +0000
committerChris Larson <clarson@kergoth.com>2004-09-23 16:59:52 +0000
commit1ecd547694bf177fa6e2f1735e0ce9000369e6e6 (patch)
tree4ed87d77fa342e24f012337be06227a914fce100 /linux/nslu2-linksys-2.4.22
parent9e03927d80e5e9d8f235f8b1cf2c22c7c6adb2b5 (diff)
downloadopenembedded-1ecd547694bf177fa6e2f1735e0ce9000369e6e6.tar.gz
Merge handhelds.org:/home/kergoth/code/oe.nslu2/packages
into handhelds.org:/home/kergoth/code/oe/packages 2004/09/23 12:11:49-04:00 handhelds.org!kergoth Merge handhelds.org:/home/kergoth/code/oe/packages into handhelds.org:/home/kergoth/code/oe.nslu2/packages 2004/09/23 12:11:36-04:00 handhelds.org!kergoth Merge http://nslu2-linux.bkbits.net/packages into handhelds.org:/home/kergoth/code/oe.nslu2/packages 2004/09/24 00:09:28+09:30 (none)!rwhitby Merge bk://nslu2-linux@nslu2-linux.bkbits.net/packages into home.(none):/home/openembedded/packages 2004/09/24 00:06:48+09:30 (none)!rwhitby Added the three unslung kernels, and modified other packages to use them. 2004/09/23 07:23:34-07:00 bitkeeper.com!nslu2-linux.adm Merge bk://openembedded.bkbits.net/packages into hostme.bitkeeper.com:/repos/n/nslu2-linux/packages 2004/09/23 20:51:12+09:30 (none)!rwhitby Changed the html file patch into a sed to work around the line endings problem 2004/09/23 01:35:07-07:00 (none)!jacques checked in unslung.patch with proper EOL so it will apply. 2004/09/22 23:34:19-07:00 conversagent.com!fontenot Turn off EOLN_NATIVE flag for unslung.patch 2004/09/23 00:48:30-04:00 handhelds.org!kergoth Merge handhelds.org:/home/kergoth/code/oe/packages into handhelds.org:/home/kergoth/code/oe.nslu2/packages 2004/09/23 07:59:49+09:30 (none)!rwhitby Merge 2004/09/22 15:32:01-04:00 handhelds.org!kergoth Merge 2004/09/22 12:49:06-04:00 handhelds.org!kergoth Merge handhelds.org:/home/kergoth/code/oe/packages into handhelds.org:/home/kergoth/code/oe.nslu2/packages 2004/09/23 01:01:18+09:30 (none)!rwhitby Added nslu2-unslung-ramdisk and unslung-image packages 2004/09/22 22:24:58+09:30 (none)!rwhitby Now copies the original ramdisk contents to /nslu2-binaries so that it can be operated upon for the Unslung distribution. 2004/09/22 21:16:47+09:30 (none)!rwhitby Fixed native dependencies for e2tools-native, and made e2fsprogs-native call make install-libs to stage the header files that e2tools requires for compilation 2004/09/22 03:06:29-07:00 bitkeeper.com!nslu2-linux.adm Merge bk://openembedded.bkbits.net/packages into hostme.bitkeeper.com:/repos/n/nslu2-linux/packages 2004/09/21 21:27:36-07:00 bitkeeper.com!nslu2-linux.adm Merge bk://openembedded.bkbits.net/packages into hostme.bitkeeper.com:/repos/n/nslu2-linux/packages 2004/09/21 22:25:24-04:00 rant-central.com!roy Add mii.o to the root_fs so usbnet.o is happy. 2004/09/21 22:22:56-04:00 rant-central.com!roy Added a makefile dep so mii.o would build when usbnet.o is enabled. 2004/09/21 19:07:32-04:00 rant-central.com!roy Merge bk://nslu2-linux@nslu2-linux.bkbits.net/packages into rant-central.com:/home/roy/workspace/NSLU2/oe/packages 2004/09/21 19:07:05-04:00 rant-central.com!roy depmod was barfing on modules during boot on a nslu2. Reason was it was expecting LSB executable format. Missing ARMEB conditional added to elf_arm.h BKrev: 41530108OmOGBefCXk18Hv_4C9slIA
Diffstat (limited to 'linux/nslu2-linksys-2.4.22')
-rw-r--r--linux/nslu2-linksys-2.4.22/usbnet.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/linux/nslu2-linksys-2.4.22/usbnet.patch b/linux/nslu2-linksys-2.4.22/usbnet.patch
index e69de29bb2..84af8ee1a4 100644
--- a/linux/nslu2-linksys-2.4.22/usbnet.patch
+++ b/linux/nslu2-linksys-2.4.22/usbnet.patch
@@ -0,0 +1,43 @@
+--- linux-2.4.22/drivers/usb/usbnet.c.orig 2004-09-19 03:08:09.000000000 -0400
++++ linux-2.4.22/drivers/usb/usbnet.c 2004-09-19 03:10:58.000000000 -0400
+@@ -314,8 +314,6 @@ MODULE_PARM_DESC (msg_level, "Initial me
+ #define RUN_CONTEXT (in_irq () ? "in_irq" \
+ : (in_interrupt () ? "in_interrupt" : "can sleep"))
+
+-static struct ethtool_ops usbnet_ethtool_ops;
+-
+ /* mostly for PDA style devices, which are always present */
+ static int always_connected (struct usbnet *dev)
+ {
+@@ -2515,7 +2513,6 @@ usbnet_probe (struct usb_device *udev, u
+ net->watchdog_timeo = TX_TIMEOUT_JIFFIES;
+ net->tx_timeout = usbnet_tx_timeout;
+ net->do_ioctl = usbnet_ioctl;
+- net->ethtool_ops = &usbnet_ethtool_ops;
+
+ // allow device-specific bind/init procedures
+ // NOTE net->name still not usable ...
+@@ -2738,13 +2735,6 @@ static struct usb_driver usbnet_driver =
+ .disconnect = usbnet_disconnect,
+ };
+
+-/* Default ethtool_ops assigned. Devices can override in their bind() routine */
+-static struct ethtool_ops usbnet_ethtool_ops = {
+- .get_drvinfo = usbnet_get_drvinfo,
+- .get_link = usbnet_get_link,
+- .get_msglevel = usbnet_get_msglevel,
+- .set_msglevel = usbnet_set_msglevel,
+-};
+ /*-------------------------------------------------------------------------*/
+
+ static int __init usbnet_init (void)
+--- linux-2.4.22/drivers/net/Makefile.orig 2004-09-21 19:29:09.000000000 -0400
++++ linux-2.4.22/drivers/net/Makefile 2004-09-21 19:30:33.000000000 -0400
+@@ -267,6 +267,7 @@ obj-$(CONFIG_AMD8111_ETH) += amd8111e.o
+
+ # non-drivers/net drivers who want mii lib
+ obj-$(CONFIG_PCMCIA_SMC91C92) += mii.o
++obj-$(CONFIG_USB_USBNET) += mii.o
+
+ ifeq ($(CONFIG_ARCH_ACORN),y)
+ mod-subdirs += ../acorn/net