aboutsummaryrefslogtreecommitdiffstats
path: root/nmap
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2003-11-22 07:18:52 +0000
committerChris Larson <clarson@kergoth.com>2003-11-22 07:18:52 +0000
commit98e5596492ce4056911cfe0a16a1bde0786c9e4a (patch)
treeb65ee4bb69096e6e46b382a22c825cfadca7c597 /nmap
parent39b432aad0d35e96b48d063beafbc25fb040fabb (diff)
downloadopenembedded-98e5596492ce4056911cfe0a16a1bde0786c9e4a.tar.gz
Update some upstream URIs.
BKrev: 3fbf0ddcKa1Xea1ZrURxtxqG_150rQ
Diffstat (limited to 'nmap')
-rw-r--r--nmap/nmap_3.45.oe3
-rw-r--r--nmap/nmap_3.48.oe45
2 files changed, 46 insertions, 2 deletions
diff --git a/nmap/nmap_3.45.oe b/nmap/nmap_3.45.oe
index db94220cb2..a75d5af1b7 100644
--- a/nmap/nmap_3.45.oe
+++ b/nmap/nmap_3.45.oe
@@ -2,8 +2,7 @@ DEPENDS = virtual/libc libpcap
RDEPENDS = libc6 libpcap
DESCRIPTION = Nmap is a command line portscanner.
-SRC_URI = http://download.insecure.org/nmap/dist/nmap-${PV}.tgz \
- ${DEBIAN_MIRROR}/main/n/nmap/nmap_${PV}-1.diff.gz
+SRC_URI = http://download.insecure.org/nmap/dist/nmap-${PV}.tgz
inherit autotools
diff --git a/nmap/nmap_3.48.oe b/nmap/nmap_3.48.oe
index e69de29bb2..a75d5af1b7 100644
--- a/nmap/nmap_3.48.oe
+++ b/nmap/nmap_3.48.oe
@@ -0,0 +1,45 @@
+DEPENDS = virtual/libc libpcap
+RDEPENDS = libc6 libpcap
+DESCRIPTION = Nmap is a command line portscanner.
+
+SRC_URI = http://download.insecure.org/nmap/dist/nmap-${PV}.tgz
+
+inherit autotools
+
+EXTRA_OECONF = --with-pcap=linux --with-libpcap=${STAGING_DIR} --without-nmapfe
+EXTRA_OEMAKE = "STRIPPROG=arm-linux-strip"
+
+CXXFLAGS_append = " -fpermissive"
+# Ugly hack follows -- their configure.ac doesnt match their configure ..
+# doesnt include a check for the length type in recvfrom, so we hack it here
+CPPFLAGS_append = " -Drecvfrom6_t=socklen_t"
+
+#do_configure_prepend () {
+# if [ ! -e libpcap-possiblymodified/acinclude.m4 ]; then
+# cat libpcap-possiblymodified/aclocal.m4 > libpcap-possiblymodified/acinclude.m4
+# fi
+#}
+
+do_compile_prepend () {
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} libpcre/dftables.c -o libpcre/dftables
+ touch libpcre/dftables.o
+ libpcre/dftables > libpcre/chartables.c
+}
+
+do_configure () {
+# override this function to avoid the autoconf/automake/aclocal/autoheader
+# calls for now
+ oe_runconf
+}
+
+
+do_install () {
+ oe_runmake 'prefix=${D}/${prefix}' \
+ 'exec_prefix=${D}/${exec_prefix}' \
+ 'bindir=${D}/${bindir}' \
+ 'sbindir=${D}/${sbindir}' \
+ 'mandir=${D}/${mandir}' \
+ 'datadir=${D}/${datadir}' \
+ 'nmapdatadir=${D}/${datadir}/nmap' \
+ install
+}