aboutsummaryrefslogtreecommitdiffstats
path: root/nmap
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2003-11-21 18:27:14 +0000
committerChris Larson <clarson@kergoth.com>2003-11-21 18:27:14 +0000
commite9b171e0738c2acef0650328b7f2e1ae7cdc55cc (patch)
tree8afdd2f094195bb88a7a9636f5b9bd9f53ebb492 /nmap
parentacea8d73cb0c72991690d488915e426bf7e46675 (diff)
downloadopenembedded-e9b171e0738c2acef0650328b7f2e1ae7cdc55cc.tar.gz
Numerous build fixes from an oemake -a run, including two more fixes for libtool 'libdir from .la file leaking into library search path' situations.
BKrev: 3fbe5902eywlLRHkRQ1FaDS5C01-jg
Diffstat (limited to 'nmap')
-rw-r--r--nmap/nmap_3.45.oe46
1 files changed, 46 insertions, 0 deletions
diff --git a/nmap/nmap_3.45.oe b/nmap/nmap_3.45.oe
index e69de29bb2..db94220cb2 100644
--- a/nmap/nmap_3.45.oe
+++ b/nmap/nmap_3.45.oe
@@ -0,0 +1,46 @@
+DEPENDS = virtual/libc libpcap
+RDEPENDS = libc6 libpcap
+DESCRIPTION = Nmap is a command line portscanner.
+
+SRC_URI = http://download.insecure.org/nmap/dist/nmap-${PV}.tgz \
+ ${DEBIAN_MIRROR}/main/n/nmap/nmap_${PV}-1.diff.gz
+
+inherit autotools
+
+EXTRA_OECONF = --with-pcap=linux --with-libpcap=${STAGING_DIR} --without-nmapfe
+EXTRA_OEMAKE = "STRIPPROG=arm-linux-strip"
+
+CXXFLAGS_append = " -fpermissive"
+# Ugly hack follows -- their configure.ac doesnt match their configure ..
+# doesnt include a check for the length type in recvfrom, so we hack it here
+CPPFLAGS_append = " -Drecvfrom6_t=socklen_t"
+
+#do_configure_prepend () {
+# if [ ! -e libpcap-possiblymodified/acinclude.m4 ]; then
+# cat libpcap-possiblymodified/aclocal.m4 > libpcap-possiblymodified/acinclude.m4
+# fi
+#}
+
+do_compile_prepend () {
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} libpcre/dftables.c -o libpcre/dftables
+ touch libpcre/dftables.o
+ libpcre/dftables > libpcre/chartables.c
+}
+
+do_configure () {
+# override this function to avoid the autoconf/automake/aclocal/autoheader
+# calls for now
+ oe_runconf
+}
+
+
+do_install () {
+ oe_runmake 'prefix=${D}/${prefix}' \
+ 'exec_prefix=${D}/${exec_prefix}' \
+ 'bindir=${D}/${bindir}' \
+ 'sbindir=${D}/${sbindir}' \
+ 'mandir=${D}/${mandir}' \
+ 'datadir=${D}/${datadir}' \
+ 'nmapdatadir=${D}/${datadir}/nmap' \
+ install
+}