aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword/abiword.inc
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-09-04 09:51:04 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-09-04 09:51:04 +0000
commit470ea3658bea7dabd656a8644bc7aa841f12faf6 (patch)
tree6d8db587d6b7c91a615ee3c96cfcb4745a26bc7e /packages/abiword/abiword.inc
parent337c4e16e80b06c66b7b02d364d54acce543ad49 (diff)
downloadopenembedded-470ea3658bea7dabd656a8644bc7aa841f12faf6.tar.gz
abiword-embedded_2.4.5.bb, abiword_2.4.5.bb : add abiword-embedded package
which adds a version of abiword more suited for small screen devices. main abiword stuff moved into a .inc file.
Diffstat (limited to 'packages/abiword/abiword.inc')
-rw-r--r--packages/abiword/abiword.inc43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/abiword/abiword.inc b/packages/abiword/abiword.inc
new file mode 100644
index 0000000000..1df0303634
--- /dev/null
+++ b/packages/abiword/abiword.inc
@@ -0,0 +1,43 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+SECTION = "gnome/office"
+HOMEPAGE="http://www.abiword.org""
+MAINTAINER="Koen Kooi <koen@linuxtogo.org>"
+LICENSE="GPLv2"
+
+DEPENDS = "perl-native libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng perl glibc libxml2"
+RDEPENDS = "enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+PR="r1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+S = "${WORKDIR}/abiword-${PV}/abi"
+
+FILES_${PN} += " ${datadir}/icons/* \
+${datadir}/AbiSuite-2.4/AbiWord/glade \
+${datadir}/AbiSuite-2.4/AbiWord/scripts \
+${datadir}/AbiSuite-2.4/AbiWord/system.profile-en \
+${datadir}/AbiSuite-2.4/AbiWord/system.profile-en_GB \
+#${datadir}/AbiSuite-2.4/templates/A4.awt \
+#${datadir}/AbiSuite-2.4/templates/US-Letter.awt \
+${datadir}/AbiSuite-2.4/templates/normal.awt \
+${datadir}/AbiSuite-2.4/templates/normal.awt-en_GB \
+${datadir}/AbiSuite-2.4/templates/Employee-Directory.awt \
+${datadir}/AbiSuite-2.4/templates/Business-Report.awt \
+${datadir}/AbiSuite-2.4/templates/Fax-Coversheet.awt \
+${datadir}/AbiSuite-2.4/templates/Resume.awt \
+${datadir}/AbiSuite-2.4/templates/Two-Columns.awt \
+${datadir}/AbiSuite-2.4/templates/Memo.awt \
+${datadir}/AbiSuite-2.4/templates/Press-Release.awt "
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--disable-pspell --enable-enchant"
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+