aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-03-31 09:47:16 +0000
committerKoen Kooi <koen@openembedded.org>2008-03-31 09:47:16 +0000
commit15b87148d7d597c9fd213f95471b5c6ffb293d38 (patch)
treeca4687f427a8190f28343634cebe0043e969bd10 /packages/abiword
parentfea72465d5902d262c8771dded37f106b63993e3 (diff)
downloadopenembedded-15b87148d7d597c9fd213f95471b5c6ffb293d38.tar.gz
abiword-plugins: add latest stable, 2.6.0 and patch it to use CXX for LD
Diffstat (limited to 'packages/abiword')
-rw-r--r--packages/abiword/abiword-plugins_2.6.0.bb44
-rw-r--r--packages/abiword/files/abiword-cxx-for-ld-fix.patch12
2 files changed, 56 insertions, 0 deletions
diff --git a/packages/abiword/abiword-plugins_2.6.0.bb b/packages/abiword/abiword-plugins_2.6.0.bb
new file mode 100644
index 0000000000..f6cdcc56b0
--- /dev/null
+++ b/packages/abiword/abiword-plugins_2.6.0.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "boost loudmouth libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+ http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-cxx-for-ld-fix.patch;patch=1 \
+ "
+
+DEFAULT_PREFERENCE = "2"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+# Ugly hack to find libstdc++
+export LD="${CXX}"
+
+EXTRA_OECONF = " --without-libwmf \
+ --without-inter7eps \
+ --with-abiword=${WORKDIR}/abiword-${PV} \
+ --with-boost=${STAGING_DIR_HOST} \
+ --with-boost-thread=boost_thread-mt \
+ "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.6/plugins', d)
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.6/plugins/.debug"
+
diff --git a/packages/abiword/files/abiword-cxx-for-ld-fix.patch b/packages/abiword/files/abiword-cxx-for-ld-fix.patch
new file mode 100644
index 0000000000..e49b1e92e5
--- /dev/null
+++ b/packages/abiword/files/abiword-cxx-for-ld-fix.patch
@@ -0,0 +1,12 @@
+libstc++ isn't in staging anymore, so we must use g++ for linking
+
+--- /tmp/configure.ac 2008-03-31 11:39:13.130631737 +0200
++++ abiword-plugins-2.6.0/configure.ac 2008-03-31 11:39:22.754586487 +0200
+@@ -14,6 +14,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
++AC_LANG_CPLUSPLUS
+
+ AM_INIT_AUTOMAKE
+