aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-08-09 22:09:25 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-09 22:09:25 +0000
commit396e306ca6aebd899f31a13eeff5a80bbb2f7f8f (patch)
tree5eb1d2c5bf634d01da57ece4058cd9a55a3c1a93 /packages/abiword
parent6550c898206da5f81bdbab7b8660d2130d6e24b1 (diff)
downloadopenembedded-396e306ca6aebd899f31a13eeff5a80bbb2f7f8f.tar.gz
abiword-plugins: add 2.5.1
Diffstat (limited to 'packages/abiword')
-rw-r--r--packages/abiword/abiword-plugins_2.5.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/abiword/abiword-plugins_2.5.1.bb b/packages/abiword/abiword-plugins_2.5.1.bb
new file mode 100644
index 0000000000..8168b1d060
--- /dev/null
+++ b/packages/abiword/abiword-plugins_2.5.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word""
+HOMEPAGE = "http://www.abiword.org""
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "libwpd librsvg goffice poppler"
+RDEPENDS = "abiword"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+ http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ "
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = " --without-libwmf \
+ --without-inter7eps \
+ --with-abiword=${WORKDIR}/abiword-${PV} \
+ "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.5/plugins', d)
+
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+}
+