aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-11-07 13:06:39 +0000
committerKoen Kooi <koen@openembedded.org>2006-11-07 13:06:39 +0000
commit68098b31cc26db48681bd8121a7c07384b534ae5 (patch)
tree5058fde91b482c07dedfc4a89d9fac5a45d852aa /packages/abiword
parent7c7579827235fc6c433556b99c8a66dd59cfc627 (diff)
downloadopenembedded-68098b31cc26db48681bd8121a7c07384b534ae5.tar.gz
abiword: update to 2.4.6
Diffstat (limited to 'packages/abiword')
-rw-r--r--packages/abiword/abiword-embedded_2.4.6.bb12
-rw-r--r--packages/abiword/abiword-plugins_2.4.6.bb27
-rw-r--r--packages/abiword/abiword_2.4.6.bb4
3 files changed, 43 insertions, 0 deletions
diff --git a/packages/abiword/abiword-embedded_2.4.6.bb b/packages/abiword/abiword-embedded_2.4.6.bb
new file mode 100644
index 0000000000..9381bbd8a7
--- /dev/null
+++ b/packages/abiword/abiword-embedded_2.4.6.bb
@@ -0,0 +1,12 @@
+require abiword.inc
+
+EXTRA_OECONF += "--enable-embedded"
+
+RCONFLICTS = "abiword"
+RPROVIDES += "abiword"
+
+do_compile_prepend() {
+ cp ${S}/src/af/xap/unix/hildon/xap_EmbeddedFeatures.h ${S}/src/af/xap/unix/
+ cp ${S}/src/wp/ap/unix/hildon/ap_EmbeddedFeatures.h ${S}/src/wp/ap/unix/
+}
+
diff --git a/packages/abiword/abiword-plugins_2.4.6.bb b/packages/abiword/abiword-plugins_2.4.6.bb
new file mode 100644
index 0000000000..28d076aaa4
--- /dev/null
+++ b/packages/abiword/abiword-plugins_2.4.6.bb
@@ -0,0 +1,27 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+SECTION = "gnome/office"
+HOMEPAGE="http://www.abiword.org""
+LICENSE="GPLv2"
+
+DEPENDS = "libwpd librsvg goffice poppler"
+PR="r0"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-plugin-pdf-poppler.patch;patch=1;pnum=2"
+S = "${WORKDIR}/abiword-${PV}/abiword-plugins"
+RDEPENDS='abiword'
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--without-libwmf"
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.4/plugins', d)
+
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+}
+
diff --git a/packages/abiword/abiword_2.4.6.bb b/packages/abiword/abiword_2.4.6.bb
new file mode 100644
index 0000000000..b97556b735
--- /dev/null
+++ b/packages/abiword/abiword_2.4.6.bb
@@ -0,0 +1,4 @@
+require abiword.inc
+
+RCONFLICTS = "abiword-embedded"
+