aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-13 17:31:05 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-13 17:31:05 +0000
commite076cde4161b37f322b3fff4e054b5c59d420ff1 (patch)
tree25081bc5441bd08df40ef3cfa0fe727981c130e3 /packages/abiword
parenta7ff06b5a9a1db14003009e39a8d9a97678ab268 (diff)
downloadopenembedded-e076cde4161b37f322b3fff4e054b5c59d420ff1.tar.gz
abiword, abiword-plugins: update to 2.6.4
Diffstat (limited to 'packages/abiword')
-rw-r--r--packages/abiword/abiword-plugins_2.6.4.bb45
-rw-r--r--packages/abiword/abiword_2.6.4.bb10
2 files changed, 55 insertions, 0 deletions
diff --git a/packages/abiword/abiword-plugins_2.6.4.bb b/packages/abiword/abiword-plugins_2.6.4.bb
new file mode 100644
index 0000000000..94baeaf58e
--- /dev/null
+++ b/packages/abiword/abiword-plugins_2.6.4.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "AbiWord is a free word processing program similar to Microsoft(r) Word"
+HOMEPAGE = "http://www.abiword.org"
+SECTION = "x11/office"
+LICENSE = "GPLv2"
+DEPENDS = "asio boost loudmouth libwpd librsvg goffice poppler libglade"
+RDEPENDS = "abiword"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-plugins-${PV}.tar.gz \
+ http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+# file://abiword-cxx-for-ld-fix.patch;patch=1 \
+ "
+
+DEFAULT_PREFERENCE = "2"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+#export LDFLAGS += " -lstdc++ "
+
+EXTRA_OECONF = " --enable-shared=yes \
+ --enable-static \
+ --without-libwmf \
+ --without-inter7eps \
+ --with-abiword=${WORKDIR}/abiword-${PV} \
+ --with-boost=${STAGING_DIR_HOST} \
+ --with-boost-thread=boost_thread-mt \
+ "
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/abiword-2.6/plugins', d)
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.la$', 'abiword-plugin-%s-dev', 'Abiword plugin for %s', extra_depends='')
+}
+
+
+PACKAGES =+ "abiword-plugin-collab-glade"
+
+FILES_abiword-plugin-collab-glade += "${datadir}"
+RDEPENDS_abiword-plugin-collab-glade = "abiword-plugin-collab"
+
+FILES_${PN}-dbg += "${libdir}/abiword-2.6/plugins/.debug"
+
diff --git a/packages/abiword/abiword_2.6.4.bb b/packages/abiword/abiword_2.6.4.bb
new file mode 100644
index 0000000000..fe6399226f
--- /dev/null
+++ b/packages/abiword/abiword_2.6.4.bb
@@ -0,0 +1,10 @@
+require abiword-2.5.inc
+
+PR = "r1"
+
+RCONFLICTS = "abiword-embedded"
+
+FILES_${PN} += "${datadir}/mime-info"
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+