aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-04-14 08:36:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-14 08:36:57 +0000
commit158647a91226e4e3b6c73ac0467c41eced00a515 (patch)
treec9c73d952c2733f1ea04e2ff926c239794227ce5 /packages/abiword
parentba3e66a146c39911df0103fd47f7e40e7654b2ff (diff)
downloadopenembedded-158647a91226e4e3b6c73ac0467c41eced00a515.tar.gz
abiword_2.4.4.bb : new version, now support cdump in perl so I have
removed the need for cdump-native. Also autotools stuff works now without hacks so I have removed those.
Diffstat (limited to 'packages/abiword')
-rw-r--r--packages/abiword/abiword_2.4.4.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/abiword/abiword_2.4.4.bb b/packages/abiword/abiword_2.4.4.bb
new file mode 100644
index 0000000000..8b1ed52d8a
--- /dev/null
+++ b/packages/abiword/abiword_2.4.4.bb
@@ -0,0 +1,42 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+HOMEPAGE="http://www.abiword.org""
+MAINTAINER="Koen Kooi <koen@handhelds.org>"
+LICENSE="GPLv2"
+
+DEPENDS = "perl-native libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng perl glibc libxml2"
+RDEPENDS = "enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+PR="r0"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+S = "${WORKDIR}/abiword-${PV}/abi"
+
+FILES_${PN} += " ${datadir}/icons/* \
+${datadir}/AbiSuite-2.4/AbiWord/glade \
+${datadir}/AbiSuite-2.4/AbiWord/scripts \
+${datadir}/AbiSuite-2.4/AbiWord/system.profile-en \
+${datadir}/AbiSuite-2.4/AbiWord/system.profile-en_GB \
+#${datadir}/AbiSuite-2.4/templates/A4.awt \
+#${datadir}/AbiSuite-2.4/templates/US-Letter.awt \
+${datadir}/AbiSuite-2.4/templates/normal.awt \
+${datadir}/AbiSuite-2.4/templates/normal.awt-en_GB \
+${datadir}/AbiSuite-2.4/templates/Employee-Directory.awt \
+${datadir}/AbiSuite-2.4/templates/Business-Report.awt \
+${datadir}/AbiSuite-2.4/templates/Fax-Coversheet.awt \
+${datadir}/AbiSuite-2.4/templates/Resume.awt \
+${datadir}/AbiSuite-2.4/templates/Two-Columns.awt \
+${datadir}/AbiSuite-2.4/templates/Memo.awt \
+${datadir}/AbiSuite-2.4/templates/Press-Release.awt "
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--disable-pspell --enable-enchant"
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+