aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-07-04 14:55:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-04 14:55:46 +0000
commit8aba54be36f1c8ea60f376a55c4036449ad9bc99 (patch)
treefb7228f3a9f84897758e11e0eb4dd2fcf827dbdf /packages/abiword
parentbb0e56bcdd2b71e640badbfce4a8c75c777da1cc (diff)
downloadopenembedded-8aba54be36f1c8ea60f376a55c4036449ad9bc99.tar.gz
abiword_2.4.5.bb, abiword-plugins_2.4.5.bb : new versions.
Diffstat (limited to 'packages/abiword')
-rw-r--r--packages/abiword/abiword-plugins_2.4.5.bb26
-rw-r--r--packages/abiword/abiword_2.4.5.bb42
2 files changed, 68 insertions, 0 deletions
diff --git a/packages/abiword/abiword-plugins_2.4.5.bb b/packages/abiword/abiword-plugins_2.4.5.bb
new file mode 100644
index 0000000000..75861792dd
--- /dev/null
+++ b/packages/abiword/abiword-plugins_2.4.5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+HOMEPAGE="http://www.abiword.org""
+MAINTAINER="Koen Kooi <koen@dominion.kabel.utwente.nl>"
+LICENSE="GPLv2"
+
+DEPENDS = "abiword libwpd librsvg goffice poppler"
+PR="r0"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-plugin-pdf-poppler.patch;patch=1;pnum=2"
+S = "${WORKDIR}/abiword-${PV}/abiword-plugins"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--without-libwmf"
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.4/plugins', d)
+
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+}
+
diff --git a/packages/abiword/abiword_2.4.5.bb b/packages/abiword/abiword_2.4.5.bb
new file mode 100644
index 0000000000..8b1ed52d8a
--- /dev/null
+++ b/packages/abiword/abiword_2.4.5.bb
@@ -0,0 +1,42 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+HOMEPAGE="http://www.abiword.org""
+MAINTAINER="Koen Kooi <koen@handhelds.org>"
+LICENSE="GPLv2"
+
+DEPENDS = "perl-native libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng perl glibc libxml2"
+RDEPENDS = "enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+PR="r0"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+S = "${WORKDIR}/abiword-${PV}/abi"
+
+FILES_${PN} += " ${datadir}/icons/* \
+${datadir}/AbiSuite-2.4/AbiWord/glade \
+${datadir}/AbiSuite-2.4/AbiWord/scripts \
+${datadir}/AbiSuite-2.4/AbiWord/system.profile-en \
+${datadir}/AbiSuite-2.4/AbiWord/system.profile-en_GB \
+#${datadir}/AbiSuite-2.4/templates/A4.awt \
+#${datadir}/AbiSuite-2.4/templates/US-Letter.awt \
+${datadir}/AbiSuite-2.4/templates/normal.awt \
+${datadir}/AbiSuite-2.4/templates/normal.awt-en_GB \
+${datadir}/AbiSuite-2.4/templates/Employee-Directory.awt \
+${datadir}/AbiSuite-2.4/templates/Business-Report.awt \
+${datadir}/AbiSuite-2.4/templates/Fax-Coversheet.awt \
+${datadir}/AbiSuite-2.4/templates/Resume.awt \
+${datadir}/AbiSuite-2.4/templates/Two-Columns.awt \
+${datadir}/AbiSuite-2.4/templates/Memo.awt \
+${datadir}/AbiSuite-2.4/templates/Press-Release.awt "
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--disable-pspell --enable-enchant"
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+