aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-01-30 12:53:11 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-30 12:53:11 +0000
commitb8a997b5ad70a60f3e5400cb33fd642b0ba3759a (patch)
tree6e0f96876dd4709a8395598394fb8f2367ffc8b2 /packages/abiword
parentd2ade47c029ba289a8c576f9649d73b020486b62 (diff)
downloadopenembedded-b8a997b5ad70a60f3e5400cb33fd642b0ba3759a.tar.gz
abiword_2.4.2.bb : new version
Diffstat (limited to 'packages/abiword')
-rw-r--r--packages/abiword/abiword_2.4.2.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/packages/abiword/abiword_2.4.2.bb b/packages/abiword/abiword_2.4.2.bb
new file mode 100644
index 0000000000..26a16dfc32
--- /dev/null
+++ b/packages/abiword/abiword_2.4.2.bb
@@ -0,0 +1,52 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+HOMEPAGE="http://www.abiword.org""
+MAINTAINER="Koen Kooi <koen@handhelds.org>"
+LICENSE="GPLv2"
+
+DEPENDS = "cdump-native libgsf libgnomeprint libgnomeprintui libglade libfribidi enchant jpeg libpng perl glibc libxml2"
+RDEPENDS = "enchant glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+PR="r0"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://cdump-hack.patch;patch=1"
+S = "${WORKDIR}/abiword-${PV}/abi"
+
+FILES_${PN} += " ${datadir}/icons/* \
+${datadir}/AbiSuite-2.4/AbiWord/glade \
+${datadir}/AbiSuite-2.4/AbiWord/scripts \
+${datadir}/AbiSuite-2.4/AbiWord/system.profile-en \
+${datadir}/AbiSuite-2.4/AbiWord/system.profile-en_GB \
+#${datadir}/AbiSuite-2.4/templates/A4.awt \
+#${datadir}/AbiSuite-2.4/templates/US-Letter.awt \
+${datadir}/AbiSuite-2.4/templates/normal.awt \
+${datadir}/AbiSuite-2.4/templates/normal.awt-en_GB \
+${datadir}/AbiSuite-2.4/templates/Employee-Directory.awt \
+${datadir}/AbiSuite-2.4/templates/Business-Report.awt \
+${datadir}/AbiSuite-2.4/templates/Fax-Coversheet.awt \
+${datadir}/AbiSuite-2.4/templates/Resume.awt \
+${datadir}/AbiSuite-2.4/templates/Two-Columns.awt \
+${datadir}/AbiSuite-2.4/templates/Memo.awt \
+${datadir}/AbiSuite-2.4/templates/Press-Release.awt "
+
+inherit autotools
+
+#abiword needs this native tool
+export BUILD_CDUMPTOOL="${STAGING_BINDIR}/cdump"
+
+PARALLEL_MAKE=""
+
+do_configure () {
+ cd ${S}
+ ./autogen.sh
+ ./configure --prefix=/usr --host=${TARGET_SYS} --disable-pspell --enable-enchant
+# --enable-debug
+ cp -f ${STAGING_BINDIR}/cdump src/tools/cdump/xp/
+}
+
+do_install_append() {
+ install -d ${D}${datadir}/pixmaps/
+ mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
+}
+
+