aboutsummaryrefslogtreecommitdiffstats
path: root/packages/acpid
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/acpid
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/acpid')
-rw-r--r--packages/acpid/acpid_1.0.2.bb32
-rw-r--r--packages/acpid/acpid_1.0.3.bb32
2 files changed, 64 insertions, 0 deletions
diff --git a/packages/acpid/acpid_1.0.2.bb b/packages/acpid/acpid_1.0.2.bb
index e69de29bb2..c96f431224 100644
--- a/packages/acpid/acpid_1.0.2.bb
+++ b/packages/acpid/acpid_1.0.2.bb
@@ -0,0 +1,32 @@
+SECTION = "base"
+DESCRIPTION = "A daemon for delivering ACPI events."
+LICENSE="GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/acpid/acpid-${PV}.tar.gz \
+ file://init"
+
+EXTRA_OEMAKE = ""
+do_compile () {
+ oe_runmake 'CC=${CC}' 'CROSS=${HOST_PREFIX}'
+}
+
+do_install () {
+ oe_runmake 'INSTPREFIX=${D}' install
+ install -d ${D}${sysconfdir}/init.d
+ cat ${WORKDIR}/init | sed -e's,/usr/sbin,${sbindir},g' > ${D}${sysconfdir}/init.d/acpid
+ chmod 755 ${D}${sysconfdir}/init.d/acpid
+}
+
+pkg_postinst () {
+ if test -n "${D}"; then
+ D="-r $D"
+ fi
+ update-rc.d $D acpid defaults
+}
+
+pkg_prerm () {
+ if test -n "${D}"; then
+ D="-r $D"
+ fi
+ update-rc.d $D acpid remove
+}
diff --git a/packages/acpid/acpid_1.0.3.bb b/packages/acpid/acpid_1.0.3.bb
index e69de29bb2..c96f431224 100644
--- a/packages/acpid/acpid_1.0.3.bb
+++ b/packages/acpid/acpid_1.0.3.bb
@@ -0,0 +1,32 @@
+SECTION = "base"
+DESCRIPTION = "A daemon for delivering ACPI events."
+LICENSE="GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/acpid/acpid-${PV}.tar.gz \
+ file://init"
+
+EXTRA_OEMAKE = ""
+do_compile () {
+ oe_runmake 'CC=${CC}' 'CROSS=${HOST_PREFIX}'
+}
+
+do_install () {
+ oe_runmake 'INSTPREFIX=${D}' install
+ install -d ${D}${sysconfdir}/init.d
+ cat ${WORKDIR}/init | sed -e's,/usr/sbin,${sbindir},g' > ${D}${sysconfdir}/init.d/acpid
+ chmod 755 ${D}${sysconfdir}/init.d/acpid
+}
+
+pkg_postinst () {
+ if test -n "${D}"; then
+ D="-r $D"
+ fi
+ update-rc.d $D acpid defaults
+}
+
+pkg_prerm () {
+ if test -n "${D}"; then
+ D="-r $D"
+ fi
+ update-rc.d $D acpid remove
+}