aboutsummaryrefslogtreecommitdiffstats
path: root/packages/adobe-flash
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-02-10 15:47:04 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-02-13 10:49:49 -0200
commit168ba1763b4b997cfb5bf5eefdbca8ae89f1dd2e (patch)
tree3c73305bd021e99e84c331309e6f2654d0231f95 /packages/adobe-flash
parent4eeb691678a9c3ea8289d78eb8a81f95a96995ea (diff)
downloadopenembedded-168ba1763b4b997cfb5bf5eefdbca8ae89f1dd2e.tar.gz
flash-plugin: add 10.0.12.36
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'packages/adobe-flash')
-rw-r--r--packages/adobe-flash/flash-plugin_10.0.12.36.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/adobe-flash/flash-plugin_10.0.12.36.bb b/packages/adobe-flash/flash-plugin_10.0.12.36.bb
new file mode 100644
index 0000000000..d6cde60031
--- /dev/null
+++ b/packages/adobe-flash/flash-plugin_10.0.12.36.bb
@@ -0,0 +1,35 @@
+# Adobe provides two versions of flash player packages
+#
+# One "unversioned" download at :
+#
+# ${ADOBE_MIRROR}/install_flash_player_9_linux.tar.gz
+#
+# And the other, versioned, which is encapsulated in RPM.
+#
+# We use the versioned one to make sure we can keep track of the
+# version and thus do repeatable builds at the cost of future download
+# failures when adobe updates.
+DESCRIPTION = "Adobe Flash 9 plugin for Mozilla/Firefox web browsers"
+LICENSE = "AdobeFlash"
+DEPENDS = "rpm2cpio-native"
+PR = "r1"
+
+SRC_URI = "${ADOBE_MIRROR}/flash-plugin-${PV}-release.i386.rpm"
+
+do_configure() {
+ rpm=${WORKDIR}/flash-plugin-${PV}-release.i386.rpm
+ if [ -f "$rpm" ]; then
+ rpm2cpio.pl $rpm | cpio -id
+ find . -type f -exec mv -i {} "`pwd`" \;
+ fi
+}
+do_install() {
+ mkdir -p ${D}${libdir}/mozilla/plugins/
+ install -m 0755 libflashplayer.so ${D}${libdir}/mozilla/plugins/
+ # AFAIK this is not needed
+ # install -m 0644 flashplayer.xpt ${D}${libdir}/mozilla/plugins/
+}
+
+FILES_${PN} = "${libdir}/* ${libdir}/X11/*"
+
+COMPATIBLE_HOST = "i.86.*-linux"