aboutsummaryrefslogtreecommitdiffstats
path: root/packages/agg
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-12-10 00:45:03 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-12-10 00:45:03 +0000
commit9612a1d282b2a228ce1ef137b00c78a1a2823d64 (patch)
treeed89b95d5266003463e11dfa959dd6f704442232 /packages/agg
parent2574d02fbe69bd537053e05fe29dfd9ac08645b7 (diff)
downloadopenembedded-9612a1d282b2a228ce1ef137b00c78a1a2823d64.tar.gz
agg 2.5 use less offensive way to make it find sdl compile flags
Diffstat (limited to 'packages/agg')
-rw-r--r--packages/agg/agg_2.5.bb24
1 files changed, 14 insertions, 10 deletions
diff --git a/packages/agg/agg_2.5.bb b/packages/agg/agg_2.5.bb
index f91d0112be..a3cf4b9557 100644
--- a/packages/agg/agg_2.5.bb
+++ b/packages/agg/agg_2.5.bb
@@ -8,12 +8,12 @@ DEPENDS = "virtual/libx11 virtual/libsdl freetype"
PR = "r0"
SRC_URI = "http://www.antigrain.com/${P}.tar.gz"
-
S = "${WORKDIR}/${P}"
inherit autotools pkgconfig
-EXTRA_OECONF = "--with-sdl-exec-prefix=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+export SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config
+
CFLAGS += " -I{$STAGING_INCDIR} "
PACKAGES =+ "${PN}-sdl ${PN}-x11"
@@ -26,14 +26,18 @@ FILES_${PN} = "${libdir}/libagg.so.* \
LEAD_SONAME = "libagg.so"
do_stage() {
- install -m 0644 libagg.m4 ${STAGING_DATADIR}/aclocal/
- install -d ${STAGING_INCDIR}/agg2
- cd include
- headers=`find . -name "*.h"`
- for f in $headers
- do
- install -m 0644 $f ${STAGING_INCDIR}/agg2/
- done
+ oe_libinstall -a -so libagg ${STAGING_LIBDIR}
+ oe_libinstall -a -so libaggfontfreetype ${STAGING_LIBDIR}
+ oe_libinstall -a -so libaggplatformX11 ${STAGING_LIBDIR}
+ oe_libinstall -a -so libaggplatformsdl ${STAGING_LIBDIR}
+ install -m 0644 libagg.m4 ${STAGING_DATADIR}/aclocal/
+ install -d ${STAGING_INCDIR}/agg2
+ cd include
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/agg2/$f
+ done
}