aboutsummaryrefslogtreecommitdiffstats
path: root/packages/aiostress
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-10-14 18:32:58 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-10-14 18:32:58 +0000
commit9ad16bc2804fe0ddc38666aa5626f6ec44332bbf (patch)
tree6786f5901112a828bbbeaee7f1df38e913cb2d49 /packages/aiostress
parentfa314d00502a8707dff79bbb305a7e3d5012d39b (diff)
downloadopenembedded-9ad16bc2804fe0ddc38666aa5626f6ec44332bbf.tar.gz
aiostress: added as 0.0 as there is no version defined upstream
Diffstat (limited to 'packages/aiostress')
-rw-r--r--packages/aiostress/.mtn2git_empty0
-rw-r--r--packages/aiostress/aiostress_0.0.bb17
2 files changed, 17 insertions, 0 deletions
diff --git a/packages/aiostress/.mtn2git_empty b/packages/aiostress/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/aiostress/.mtn2git_empty
diff --git a/packages/aiostress/aiostress_0.0.bb b/packages/aiostress/aiostress_0.0.bb
new file mode 100644
index 0000000000..8b4085ad4f
--- /dev/null
+++ b/packages/aiostress/aiostress_0.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Asynchronous I/O stress util"
+LICENSE = "GPLv2"
+DEPENDS = "libaio"
+
+SRC_URI = "ftp://ftp.suse.com/pub/people/mason/utils/aio-stress.c;md5sum=727e5fc3566837b3ea72f887d048769b"
+
+S = "${WORKDIR}"
+
+do_compile() {
+
+ cd ${S} && ${CC} aio-stress.c -o aio-stress -I${STAGING_INCDIR} -L${STAGING_LIBDIR} -laio -lpthread
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 aio-stress ${D}${bindir}
+}