aboutsummaryrefslogtreecommitdiffstats
path: root/packages/alsa
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-07-19 13:56:52 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-07-19 13:56:52 +0000
commit08798024fd093d15a1e1f7f22bc14adf263275d3 (patch)
treef209026533844fdc5beba70c3950219b31dfa9e3 /packages/alsa
parenta967e9db239d0fdcdb13f24e88d6faa98a1eee68 (diff)
downloadopenembedded-08798024fd093d15a1e1f7f22bc14adf263275d3.tar.gz
alsa-lib: fix avr32 builds and libmath detection
* fix bug 4364 provided Geoffrey Wossum * add fix_libmath.patch to correct detection either -lm is needed or not * bump PR
Diffstat (limited to 'packages/alsa')
-rw-r--r--packages/alsa/alsa-lib/fix_libmath.patch17
-rw-r--r--packages/alsa/alsa-lib_1.0.15.bb14
-rw-r--r--packages/alsa/alsa-versym.inc21
3 files changed, 50 insertions, 2 deletions
diff --git a/packages/alsa/alsa-lib/fix_libmath.patch b/packages/alsa/alsa-lib/fix_libmath.patch
new file mode 100644
index 0000000000..23309ce381
--- /dev/null
+++ b/packages/alsa/alsa-lib/fix_libmath.patch
@@ -0,0 +1,17 @@
+Index: alsa-lib-1.0.15/configure.in
+===================================================================
+--- alsa-lib-1.0.15.orig/configure.in 2007-10-15 10:45:26.000000000 +0200
++++ alsa-lib-1.0.15/configure.in 2008-07-19 15:51:34.177119589 +0200
+@@ -191,9 +191,9 @@
+ AC_MSG_RESULT(no)
+ fi
+
+-ALSA_DEPLIBS=""
+-if test "$softfloat" != "yes"; then
+- ALSA_DEPLIBS="-lm"
++ALSA_DEPLIBS="-lm"
++if test "$softfloat" = "yes"; then
++ AC_CHECK_LIB([m], [floor], , [ALSA_DEPLIBS=""])
+ fi
+
+ dnl Check for libdl
diff --git a/packages/alsa/alsa-lib_1.0.15.bb b/packages/alsa/alsa-lib_1.0.15.bb
index 60b44dbc8e..399352f299 100644
--- a/packages/alsa/alsa-lib_1.0.15.bb
+++ b/packages/alsa/alsa-lib_1.0.15.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Alsa sound library"
HOMEPAGE = "http://www.alsa-project.org"
SECTION = "libs/multimedia"
LICENSE = "GPL"
+PR = "1"
# configure.in sets -D__arm__ on the command line for any arm system
# (not just those with the ARM instruction set), this should be removed,
@@ -10,14 +11,23 @@ LICENSE = "GPL"
ARM_INSTRUCTION_SET = "arm"
SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
- file://fix-tstamp-declaration.patch;patch=1"
+ file://fix-tstamp-declaration.patch;patch=1 \
+ file://fix_libmath.patch;patch=1 \
+ "
inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
+
+
require alsa-fpu.inc
EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
-EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
+
+require alsa-versym.inc
+EXTRA_OECONF += "${@get_alsa_versym_setting(bb, d)} "
+
do_stage () {
oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
diff --git a/packages/alsa/alsa-versym.inc b/packages/alsa/alsa-versym.inc
new file mode 100644
index 0000000000..6d585ecf4a
--- /dev/null
+++ b/packages/alsa/alsa-versym.inc
@@ -0,0 +1,21 @@
+
+def get_alsa_versym_setting(bb, d):
+ # Versioned symbols don't work propery with uClibc
+ if bb.data.getVar('TARGET_OS', d, 1).find('uclibc') >= 0:
+ return "--with-versioned=no"
+ return ""
+
+
+def get_alsa_versym_setting(bb, d):
+ # Versioned symbols don't work propery with uClibc
+ if bb.data.getVar('TARGET_OS', d, 1).find('uclibc') >= 0:
+ return "--with-versioned=no"
+ return ""
+
+
+def get_alsa_versym_setting(bb, d):
+ # Versioned symbols don't work propery with uClibc
+ if bb.data.getVar('TARGET_OS', d, 1).find('uclibc') >= 0:
+ return "--with-versioned=no"
+ return ""
+